Results 1 to 7 of 7

Thread: Screensaver blanks to KDM background, not screensaver module

  1. #1

    Default Screensaver blanks to KDM background, not screensaver module

    openSUSE version: 13.2 (x86_64)
    KDE Platform Version 4.14.9 (updated to current)
    Nvidia driver

    Hi, I have an odd screensaver problem. The screen blanks like it should after the amount of time set in the KDE Control Center's Screen Locker section > "Start automatically after:" dialog box. However, instead of getting the screensaver module that I want (say, "asciiquarium"), instead I get the default green KDM wallpaper. If I jiggle the mouse to return to the desktop, I can see "asciiquarium" displayed for a second, before it returns to my desktop, as if the green wallpaper was displaying "on top of" or "over" the screensaver module.

    Does anyone have a fix for this? It's been acting this way for a long while now.

    (The "require password" box is unchecked. And testing the screensaver works fine.)

  2. #2

    Default Re: Screensaver blanks to KDM background, not screensaver module

    Quote Originally Posted by eco2geek View Post
    Does anyone have a fix for this? It's been acting this way for a long while now.
    First, that's not "KDM's background", but Plasma's default wallpaper.

    Second, there is no fix for this (except maybe for replacing Plasma's wallpaper with a completely black one). That's how it's designed since the rewrite of the screenlocker in 4.10.
    And meanwhile KDE4 is dead. And screensaver support has been dropped completely in Plasma5.
    Last edited by wolfi323; 15-Aug-2015 at 15:21.

  3. #3

    Default Re: Screensaver blanks to KDM background, not screensaver module

    It's hard to tell if one's perception is correct when it's only text, but my perception is that your tone is "Tell the (stupid) newbie things he doesn't know", which is unhelpful.

    Quote Originally Posted by wolfi323 View Post
    First, that's not "KDM's background", but Plasma's default wallpaper.
    Yes, I know. The backgrounds in openSUSE 13.2's default KDM theme are symlinks to openSUSE's default wallpaper.

    Quote Originally Posted by wolfi323 View Post
    Second, there is no fix for this (except maybe for replacing Plasma's wallpaper with a completely black one). That's how it's designed since the rewrite of the screenlocker in 4.10.
    This would be surprising, since the screensaver works just fine and as expected in both Kubuntu 14.04.3, which, with backports enabled, is up to KDE Platform v4.14.2/SC 4.13.2; as well as in Mageia 5, which is up to KDE Platform v4.14.5.

    Quote Originally Posted by wolfi323 View Post
    And meanwhile KDE4 is dead. And screensaver support has been dropped completely in Plasma5.
    You could put it that way. Yes, I know.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,916
    Blog Entries
    2

    Default Re: Screensaver blanks to KDM background, not screensaver module

    I have found what you describing when your screen blanks because of a power setting (ACPI).

    In other words, if that setting blanks your screen instead of the screensaver, then you won't see the screensaver.

    TSU

  5. #5

    Default Re: Screensaver blanks to KDM background, not screensaver module

    Quote Originally Posted by eco2geek View Post
    It's hard to tell if one's perception is correct when it's only text, but my perception is that your tone is "Tell the (stupid) newbie things he doesn't know", which is unhelpful.
    Why is it unhelpful to tell somebody things he doesn't know?

    Anyway, I didn't take you as stupid, and I didn't want to offend you in any way.

    Yes, I know. The backgrounds in openSUSE 13.2's default KDM theme are symlinks to openSUSE's default wallpaper.
    Yes.
    But again, what you see is totally independent of KDM. You see the Plasma screenlocker screen without a password dialog, i.e. just Plasma's default wallpaper.

    KDM is the login screen, and has nothing to do with screen locking.

    This would be surprising, since the screensaver works just fine and as expected in both Kubuntu 14.04.3, which, with backports enabled, is up to KDE Platform v4.14.2/SC 4.13.2; as well as in Mageia 5, which is up to KDE Platform v4.14.5.
    Well, I did misunderstand you a bit I think.
    I thought you meant that the animations are running on top of the wallpaper instead of a black screen.

    The thing you mean is probably a well-known and old problem with enabling/disabling compositing.
    Turning off "suspend compositing for fullscreen applications" should make the screensaver appear correctly.

    But you'd see the same on other distributions too, except when using the intel driver. That option doesn't have any effect (is disabled) with intel.

    You could put it that way. Yes, I know.
    It's a fact.
    Nobody is working on the KDE4 desktop anymore. So things won't be changed, bugs won't be fixed.
    Last edited by wolfi323; 15-Aug-2015 at 16:55.

  6. #6

    Default Re: Screensaver blanks to KDM background, not screensaver module

    Thanks for the info (some of it I did not know :-) -- and thanks for your patience, as it is often difficult for me to get people's tone from their text postings.

    I did find the answer to this particular issue at the bottom of this "Make Tech Easier" article:

    In case your screensaver doesn’t start, check the “System Settings -> Desktop Effects -> Advanced” dialog and make sure the “Suspend desktop effects for fullscreen windows” option is disabled.

    That fixed it. The screensaver now displays correctly until the monitor goes into power-saving mode. And it sounds suspiciously close to your solution. :-)

  7. #7

    Default Re: Screensaver blanks to KDM background, not screensaver module

    Quote Originally Posted by eco2geek View Post
    and thanks for your patience, as it is often difficult for me to get people's tone from their text postings.
    Well, one advice: don't read the worst into a reply when posting in a technical support forum like this.
    Most people only reply when they want to help you anyway, and at least some try to keep on a technical level sometimes, i.e. rather terse or curtly, focussed to the topic.

    But, not everyone has english as their native language, so what you might read as unfriendly probably wasn't meant so actually.

    Also, in my case, I was tired already when I replied, it was very late here...

    That fixed it. The screensaver now displays correctly until the monitor goes into power-saving mode. And it sounds suspiciously close to your solution. :-)
    Yes, that was exactly what I meant.
    I should have mentioned in more detail where this setting is located (and actually wanted too, but as explained before, I was quite tired and forgot).
    Sorry for that!
    Last edited by wolfi323; 16-Aug-2015 at 11:31.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •