Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Yast2 won't work unless using --ncurses options

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    389

    Default Yast2 won't work unless using --ncurses options

    Greetings !!

    I just did an update that needs a restart (the kernel may changed) and now I can't launch Yast2 unless I launch it using terminal with --ncurses option.

    The different errors I had are:

    cyrius:/usr/share/YaST2/clients # yast2 --gtk

    GTK GUI wanted but not found, falling back to Qt.
    YaST got signal 11 at file /usr/share/YaST2/clients/menu.rb:192
    /sbin/yast2: line 440: 6171 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    cyrius:/usr/share/YaST2/clients # yast2 --qt

    /sbin/yast2: line 440: 6196 Segmentation fault $y2ccbin $Y2UI_ARGS "$@"

    I recently added a R7 graphical card... and removed qcad.

    Any clues ?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,379
    Blog Entries
    1

    Default Re: Yast2 won't work unless using --ncurses options

    FWIW, a similar thread here

    https://forums.opensuse.org/showthre...-opensuse-13-2

    although that was with a new installation where the user had a radeon card. Are you using a proprietary driver?

    If you boot up in failsafe mode, does YaST (graphical mode) then work?

    Configured repos?
    Code:
    zypper lr -d

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast2 won't work unless using --ncurses options

    On 2015-08-15 03:56, soundlord wrote:
    >
    > Greetings !!
    >
    > I just did an update that needs a restart (the kernel may changed) and
    > now I can't launch Yast2 unless I launch it using terminal with
    > --ncurses option.


    Please post your repository list. The output of "zypper lr --details",
    and please do so inside a code tags section. Use the '#' button in the
    forum editor.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  4. #4
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    389

    Default Re: Yast2 won't work unless using --ncurses options

    Effectively in "recovery mode" Yast2" worked !!
    I did not troubleshoot so far I was working.

    here is the zypper lr -d results:

    http://paste.opensuse.org/98878723

    I installed proprietary driver because of this: https://forums.opensuse.org/showthre...-recovery-mode

  5. #5
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    389

    Default Re: Yast2 won't work unless using --ncurses options

    Seems linked with opengl.

    http://paste.opensuse.org/65747bf7

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,379
    Blog Entries
    1

    Default Re: Yast2 won't work unless using --ncurses options

    Quote Originally Posted by soundlord View Post
    Seems linked with opengl.

    http://paste.opensuse.org/65747bf7
    So, this is really a graphics issue (as suspected). What is returned via the following?
    Code:
    fglrxinfo

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast2 won't work unless using --ncurses options

    On 2015-08-15 05:26, soundlord wrote:

    > here is the zypper lr -d results:
    >
    > http://paste.opensuse.org/98878723


    You have some duplicates.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    389

    Default Re: Yast2 won't work unless using --ncurses options

    This is the fglrxinfo (my program openglc is a test program to see if opengl is able to draw something...)

    Code:
    cyrius:/datas1/exemples/opengl # fglrxinfo 
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  157 (ATIFGLEXTENSION)
      Minor opcode of failed request:  66 ()
      Serial number of failed request:  13
      Current serial number in output stream:  13
    cyrius:/datas1/exemples/opengl #
    As far as I know, but it is still suppositions (guesses) in "recovery mode" the opengl is disabled.
    I don't know if Yast2 uses opengl... I saw that we could open yast2 in GTK or Qt and both could use opengl routines to draw at screen.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,379
    Blog Entries
    1

    Default Re: Yast2 won't work unless using --ncurses options

    Well, the proprietary ATI/AMD driver implements it's own openGL libraries, so IMO something is wrong with your driver install. I'd consider removing it entirely and starting over.

  10. #10
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    389

    Default Re: Yast2 won't work unless using --ncurses options

    Greetings !!

    I uninstalled the amd proprietary driver... now I can only boot on recovery mode.

    I tried to install again the driver but it fails... when the installer says "building package", in fact it does nothing, impossible to find the built rpm somewhere on the file system.

    Code:
    ./amd-driver-installer-15.20.1046-x86.x86_64.run --buildpkg SuSE/SUSE132-AMD64
    
    Created directory fglrx-install.qj3T5P
    Verifying archive integrity... All good.
    Uncompressing AMD Catalyst(TM) Proprietary Driver-15.20.1046............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
    =====================================================================
     AMD Catalyst(TM) Proprietary Driver Installer/Packager 
    =====================================================================
    Generating package: SuSE/SUSE132-AMD64
    Build the RPM package now ...  
    
    
    Install or update the RPM package as follows:
    
       zypper install 
    
    Removing temporary directory: fglrx-install.qj3T5P
    
    ls
    
    LICENSE.TXT  amd-driver-installer-15.20.1046-x86.x86_64.run        
    cyrius:/etc/ati #
    The installer is about to build the pkg in the current folder...
    No errors and nothing in the /usr/share/ati/glrx-install.log file.Still diggin...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •