Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: I can't install 3rd part packages from GUI (NO Key Error)

  1. #1

    Default I can't install 3rd part packages from GUI (NO Key Error)

    Hello,
    in the past I used to install rpms from GUI without any problem, but since two weeks ago I started to get this error:


    I haven't aboterted the install...... so I've run zypper from terminal and I've found that the abort reason is the missing key:



    Well, this is not a big problem, but I'd like to be able to install the packages from GUI again.. Is there a way to fix this ?

    Many thanks

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    On 2015-08-09 15:06, Luca91 wrote:

    > Well, this is not a big problem, but I'd like to be able to install the
    > packages from GUI again.. Is there a way to fix this ?


    No.

    Known problem.

    You have to use another GUI: ie, use YaST.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    thank you for your reply robin_listas, so is this actually a bug ? I was thinking that this was a sort of "secure" feature

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    On 2015-08-09 17:06, Luca91 wrote:
    >
    > thank you for your reply robin_listas, so is this actually a bug ? I was
    > thinking that this was a sort of "secure" feature


    Yes, it is a bug. I don't remember if it is in packagekit or apper.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,046
    Blog Entries
    2

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    You can configure your repo to not do a certificate check

    Code:
    zypper ar --no-gpgcheck repo_URI  repo_name 
    So, for example I just modified the instructions to Elasticsearch repos on my wiki
    https://en.opensuse.org/User:Tsu2/el...official_repos

    The reason why the gpgcheck needs to be invalidated is because apparently the ES repos upgraded to the latest version YUM repos while zypper hasn't upgraded to support the new repo format yet.

    TSU

  6. #6

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    This happens only installing rpms downloaded from the net (not from repository).
    Ok I'll wait for a zypper update then.
    Thank you

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    On 2015-08-10 15:16, Luca91 wrote:
    >
    > This happens only installing rpms downloaded from the net (not from
    > repository).


    Meaning that they don't have a PGP/GPG key, or as in this case, that you
    did not manually import the key used to sign the package, in advance,
    into the rpm database.

    > Ok I'll wait for a zypper update then.


    No, zypper update will not solve that.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,816

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    It is only a warning it should allow an install

    Note Appr is more picky and won't use Yast or zypper

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    On 2015-08-10 15:28, I wrote:
    > On 2015-08-10 15:16, Luca91 wrote:
    >>
    >> This happens only installing rpms downloaded from the net (not from
    >> repository).

    >
    > Meaning that they don't have a PGP/GPG key, or as in this case, that you
    > did not manually import the key used to sign the package, in advance,
    > into the rpm database.


    Have a look at "man rpmkeys", it says how to import the keys.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  10. #10

    Default Re: I can't install 3rd part packages from GUI (NO Key Error)

    Quote Originally Posted by robin_listas View Post
    On 2015-08-10 15:28, I wrote:
    > On 2015-08-10 15:16, Luca91 wrote:
    >>
    >> This happens only installing rpms downloaded from the net (not from
    >> repository).

    >
    > Meaning that they don't have a PGP/GPG key, or as in this case, that you
    > did not manually import the key used to sign the package, in advance,
    > into the rpm database.


    Have a look at "man rpmkeys", it says how to import the keys.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    Wait a moment, you are right that they don't have PGP/GPG key, but that shouldn't be an "ABORTED BY USER" error..
    I remember that I was able to install those rpms without problems in the past using apper.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •