Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Weird Xorg or windowing problem

  1. #1

    Default Weird Xorg or windowing problem

    I am running KDE4 on OpenSuSE 13.2.

    Have 32GB RAM and a rather beefy system - RAM, HDD space, processing power, graphics card power are all in abundance. I am using no proprietary drivers.

    The best way to describe this problem is to show a picture - it's weird, so in the image below:

    • The very left window is dolphin (KDE file manager) just opened up.
    • Next to it is the KDE system monitor
    • Below the system monitor is the KDE terminal
    • The two on the right are the Gnome system monitor and gnome terminal.


    As you can see the two gnome apps are just fine while the KDE apps clearly have a problem. These I just opened up. However a KDE terminal that was open before my windows start going weird will be just fine.

    Another thing to note is that this doesn't happen until my system has been running for a while -- everything seems fine from when I just log in anywhere from 10 minutes to a few hours and then it goes weird like this. Also, it never used to happen... some update did this in the last couple of weeks and I have no idea which one.

    Any ideas? My first guess is a memory leak and some graphics memory is getting completely used up in some windowing system that affects KDE apps but not other apps. It also doesn't seem to affect bigger applications like Evolution, FireFox, NetBeans. That is, it seems to be limited to KDE utilities but of course I haven't tried to open everything up to see what is and is not affected so it could seem that way just because I haven't tried enough things to see more.



  2. #2

    Default Re: Weird Xorg or windowing problem

    I think this app. bittorrent-sync might be the culprit, at least I have gone almost a day with the issue from not running it. I'll wait another day just be sure.

    Does anyone know how to check on all resources a particular app might be using up? If I find things are still good tomorrow I would like to start it but monitor everything it's using. It runs from a bash terminal.

    It also continuously throws out warning messages which is what made me suspect it and turn it off. I then tried running it while redirecting all messages to /dev/null just in case it was a matter of too many using up all the display memory but that made no difference. Not running it at all however, so far, is making a difference.

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Weird Xorg or windowing problem

    I've seen this in dolphin once or twice, but after restarting the session it didn't happen again. I don't use the app you mentioned.

    You could try a new user in KDE and see if the problem still happens when using the app.

  4. #4

    Default Re: Weird Xorg or windowing problem

    Good idea! I'll try that see what happens and post the results here.

  5. #5

    Default Re: Weird Xorg or windowing problem

    I have the same problem. The KDE console turns blur after awhile. But xterm console is fine.

    Everything returns to normal after a reboot.

    Shing

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Weird Xorg or windowing problem

    Check that you Video card fan is working. Overheat may cause the problem

  7. #7

    Default Re: Weird Xorg or windowing problem

    It's not the app. I thought it was because even not using it I have the same problem. Just seemingly takes a little longer before it happens when not running it.

    The video card not a problem from a hardware point however I monitor all temp sensors and now that you mention it the one for my video card is reading 0 degrees which shows temp. software connector to the video card sensor it's not working at all. However, my display has done that thing so we'll see if rebooting fixes up the sensor issue.

    The other temp. sensors are displaying just fine.

    I would do a keyword search on this but I don't even know what to search for... weird screen thingy I don't think is going get me very far.

  8. #8

    Default Re: Weird Xorg or windowing problem

    So logging out and back in (no need to reboot) fixes the display issue but even rebooting doesn't fix my sensor issue. I tell my system to keep all versions of software in repos it downloads so I might be able to roll back that sensor software to a version that's not broken.

  9. #9

    Default Re: Weird Xorg or windowing problem

    False alarm with the temp app. I guess an update caused it to be a little funky. I had relabelled one of the sensors from temp1 to HD5870 after the graphics card and it didn't like the relabelling anymore until I reapplied it.

  10. #10

    Default Re: Weird Xorg or windowing problem

    Does anyone one know what technology these things that are messing up are built with?

    I don't think this is an xorg thing because most things keep working and a serious xorg problem I would expect to affect any thing graphic whereas this seems to be specific programs.

    I noticed today that it also messes up Yast (the graphic version).

    I was thinking maybe these things are running something common like QT or glib (I'm not sure if these are two of the same thing, this is uncharted waters for me). If I can find a common thread then maybe I can find a bug report and have some sort of a fix or at least know what to roll back to a previous version.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •