Results 1 to 4 of 4

Thread: Firewall not working || openSUSE 13.2

  1. #1
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Exclamation Firewall not working || openSUSE 13.2

    Hi,
    I am using openSUSE 13.2. I have enable the firewall through YAST. I havent opened any port but still when I launch qbittorrent and run a nmap scan I get

    Code:
    # nmap 192.168.0.103
    
    Starting Nmap 6.47 ( http://nmap.org ) at 2015-07-30 10:12 IST
    Nmap scan report for 192.168.0.103
    Host is up (0.000011s latency).
    Not shown: 999 closed ports
    PORT     STATE SERVICE
    6881/tcp open  bittorrent-tracker
    My question is how is the port open despite no rules mentioned ? The firewall is not working ?

    I have tried wiith upnp deselected in qbittorrent but same thing.
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Firewall not working || openSUSE 13.2

    Quote Originally Posted by suse_kid View Post
    Hi,
    I am using openSUSE 13.2. I have enable the firewall through YAST. I havent opened any port but ...
    Code:
    # nmap 192.168.0.103
    
    6881/tcp open  bittorrent-tracker
    My question is how is the port open despite no rules mentioned ? The firewall is not working ?
    Two possibilities to check in YaST2 Firewall:

    1.) Is "192.168.0.103" on an internal zone (Interfaces), and is Protect Firewall from Internal Zone unchecked (Allowed Services)?

    2.) Was the port opened when you installed qbittorrent?
    Check in YaST > Firewall Configuration> Allowed Services > Advanced.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  3. #3
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: Firewall not working || openSUSE 13.2

    Quote Originally Posted by eng-int View Post
    Two possibilities to check in YaST2 Firewall:

    1.) Is "192.168.0.103" on an internal zone (Interfaces), and is Protect Firewall from Internal Zone unchecked (Allowed Services)?

    2.) Was the port opened when you installed qbittorrent?
    Check in YaST > Firewall Configuration> Allowed Services > Advanced.
    These are my settings







    As you can see no external zone is added by default. How do I add my ethernet port to the external zone.

    No, no that port was not opened atleast by me at the time of qbittorrent installation.
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Firewall not working || openSUSE 13.2

    Quote Originally Posted by suse_kid View Post
    These are my settings

    As you can see no external zone is added by default. How do I add my ethernet port to the external zone.

    No, no that port was not opened atleast by me at the time of qbittorrent installation.
    Why do you think that anyone would want to download files from an anonymously owned site in Costa Rica or anywhere else? This forum has a perfectly adequate means of uploading images. Anyway I have very diminished eyesight and mostly use text mode or text-to-speech.

    YaST > Firewall Configuration > Interfaces
    This lists your enabled network devices/interfaces.
    Select the required interface .
    Select [Change] and choose the appropriate zone.

    And/Or

    YaST > Firewall Configuration > Allowed Services
    [ Protect Firewall from Internal Zone] check/uncheck as required.

    YaST > Firewall Configuration> Allowed Services > Advanced
    This allows you to see, add and remove ports from the firewall that do not appear in the "YaST > Firewall Configuration > Allowed Services " drop-down list.

    PS How is the torrent client meant to operate if it cannot communicate with (upload to) the outside world?
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •