Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Vlc unsupported codec

  1. #1

    Default Vlc unsupported codec

    Hello. I am having trouble with vlc.
    when i try open up a file i get the following error.

    Codec not supported:

    VLC could not decode the format "h264" (H264 - MPEG-4 AVC (part 10))

    I have tried a bunch of things. I have sound and it plays but no video. I removed vlc and vlc-codecs. I made sure that the packman repository is being used. i then reinstalled everything and still the same error.

    Any help would be great.




  2. #2

    Default Re: Vlc unsupported codec

    Quote Originally Posted by jonkers71 View Post
    Hello. I am having trouble with vlc.
    when i try open up a file i get the following error.

    Codec not supported:

    VLC could not decode the format "h264" (H264 - MPEG-4 AVC (part 10))

    I have tried a bunch of things. I have sound and it plays but no video. I removed vlc and vlc-codecs. I made sure that the packman repository is being used. i then reinstalled everything and still the same error.

    Any help would be great.

    Hi,
    Have you tried reading this post?

    Code:
    https://forums.opensuse.org/entry.php/160-openSUSE-13-2-Multimedia-Guide

    or this?

    Code:
    http://opensuse-guide.org/codecs.php
    IMHO, a common mistake is to mix repos that has the same codecs i.e. mixing packman and others like vlc repo is not a good idea.
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  3. #3

    Default Re: Vlc unsupported codec

    Hello. Yeah i had read both of thoes. I did have vlc repo added and it wasnt working. Removed it uninstalled vlc and started again and this is the error i get. At the start i didnt even have sound.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,931

    Default AW: Vlc unsupported codec

    Post in Code-Tags:
    Code:
    zypper se -si vlc
    Code:
    zypper lr -d

  5. #5

    Default Re: Vlc unsupported codec

    Quote Originally Posted by jonkers71 View Post
    I did have vlc repo added and it wasnt working. Removed it uninstalled vlc and started again and this is the error i get.
    Well, if you remove a repo, things you might have installed from there will not be switched.
    And that's probably the source of your problem: you still have some libraries from the VLC repo installed that are incompatible to the Packman versions.

    Do a "full repository vendor switch update" to Packman as explained here:
    https://en.opensuse.org/SDB:Vendor_c..._Vendor_change

    Then it should work (if you have vlc-codecs installed).

  6. #6

    Default Re: AW: Vlc unsupported codec

    Code:
    zypper se -si vlc
    S | Name | Type | Version | Arch | Repository
    --+--------------+---------+-------------+--------+-------------------
    i | libvlc5 | package | 2.2.1-286.2 | x86_64 | Packman Repository
    i | libvlc5 | package | 2.2.1-286.2 | x86_64 | packman
    i | libvlc5 | package | 2.2.1-286.2 | x86_64 | packman-essentials
    i | libvlccore8 | package | 2.2.1-286.2 | x86_64 | Packman Repository
    i | libvlccore8 | package | 2.2.1-286.2 | x86_64 | packman
    i | libvlccore8 | package | 2.2.1-286.2 | x86_64 | packman-essentials
    i | vlc | package | 2.2.1-286.2 | x86_64 | Packman Repository
    i | vlc | package | 2.2.1-286.2 | x86_6
    4 | packman
    i | vlc | package | 2.2.1-286.2 | x86_64 | packman-essentials
    i | vlc-codecs | package | 2.2.1-286.2 | x86_64 | Packman Repository
    i | vlc-codecs | package | 2.2.1-286.2 | x86_64 | packman
    i | vlc-codecs | package | 2.2.1-286.2 | x86_64 | packman-essentials
    i | vlc-noX | package | 2.2.1-286.2 | x86_64 | Packman Repository
    i | vlc-noX | package | 2.2.1-286.2 | x86_64 | packman
    i | vlc-noX | package | 2.2.1-286.2 | x86_64 | packman-essentials
    i | vlc-noX-lang | package | 2.2.1-286.2 | noarch | Packman Repository
    i | vlc-noX-lang | package | 2.2.1-286.2 | noarch | packman
    i | vlc-noX-lang | package | 2.2.1-286.2 | noarch | packman-essentials
    i | vlc-qt | package | 2.2.1-286.2 | x86_64 | Packman Repository
    i | vlc-qt | package | 2.2.1-286.2 | x86_64 | packman
    i | vlc-qt | package | 2.2.1-286.2 | x86_64 | packman-essentials


    Code:
    zypper lr -d
    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
    1 | Packman Repository | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.2/ |
    2 | PlexRepo | PlexRepo | No | ---- | No | 99 | NONE | http://plex.r.worldssl.net/PlexMedia...elease/x86_64/ |
    3 | home:awissu | home:awissu | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    4 | libdvdcss | libdvdcss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
    5 | libdvdcss repository | libdvdcss repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
    6 | openSUSE-13.2-0 | openSUSE-13.2-0 | No | ---- | Yes | 99 | yast2 | hd:///?device=/dev/disk/by-id/usb-IS917_innostor_201207222478-0:0-part2 |
    7 | packman | packman | Yes | (r ) Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.2/ |
    8 | packman-essentials | packman-essentials | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/misc/pa....2/Essentials/ |
    9 | packman-multimedia | packman-multimedia | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/misc/pa....2/Multimedia/ |
    10 | repo-debug | openSUSE-13.2-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.2/repo/oss/ |
    11 | repo-debug-update | openSUSE-13.2-Update-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ |
    12 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2-non-oss/ |
    13 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    14 | repo-oss | openSUSE-13.2-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.2/repo/oss/ |
    15 | repo-source | openSUSE-13.2-Source | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/source/...13.2/repo/oss/ |
    16 | repo-update | openSUSE-13.2-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
    17 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | ( p) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/

  7. #7

    Default Re: Vlc unsupported codec

    Well, you don't really need Packman three! times... and the dvdcss repo is doubled too.
    I'd suggest to remove repos #5, #7, #8, and #9, but that's unrelated to your problem.
    Code:
    sudo zypper rr 5 7 8 9
    Your vlc packages do look ok, but some underlying library might be incompatible or crippled.
    So, as I already wrote, do a full switch to Packman and it should work:
    Code:
    sudo zypper dup --from 1

  8. #8

    Default Re: Vlc unsupported codec

    I followed both of those but still no luck. Still the same error.

    Also when running vlc from the terminal i get this.

    [00000000024680b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [00007f38f0c0b568] core decoder error: Codec `h264' (H264 - MPEG-4 AVC (part 10)) is not supported.
    [00007f3918c147a8] http access error: error: HTTP/1.1 403 Forbidden
    [00007f38f8000f28] http access error: error: HTTP/1.1 403 Forbidden
    [00007f3918c147a8] http access error: error: HTTP/1.1 403 Forbidden
    [00007f38f8000f28] http access error: error: HTTP/1.1 403 Forbidden
    [00007f3918c147a8] access_mms access error: error: HTTP/1.1 400 Invalid Request

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Vlc unsupported codec

    Quote Originally Posted by jonkers71 View Post
    [00000000024680b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    I had this bug a few days ago a recent update fixed it.
    My 2c, remove all vlc packages just changing repositories keeps old rpm's you probobly have a package from the oss repo.
    yast->software managment search and remove vlc vlc-codec etc
    goto yast ->repository management and remove all your current packman repo's (you only need the main one)
    then click add, select community repositories, select packman, then OK
    goto yast software management select repository view, select packman repo and click on the blue link that states switch system packages to this repo or better said do a Full Vendor Change
    https://en.opensuse.org/SDB:Vendor_c...e#Using_YaST_2
    click OK
    restart yast->software management search and install vlc and vlc-codec, yast will pull all necessary packages.

  10. #10

    Default Re: Vlc unsupported codec

    Quote Originally Posted by jonkers71 View Post
    Also when running vlc from the terminal i get this.

    [00000000024680b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [00007f38f0c0b568] core decoder error: Codec `h264' (H264 - MPEG-4 AVC (part 10)) is not supported.
    [00007f3918c147a8] http access error: error: HTTP/1.1 403 Forbidden
    [00007f38f8000f28] http access error: error: HTTP/1.1 403 Forbidden
    [00007f3918c147a8] http access error: error: HTTP/1.1 403 Forbidden
    [00007f38f8000f28] http access error: error: HTTP/1.1 403 Forbidden
    [00007f3918c147a8] access_mms access error: error: HTTP/1.1 400 Invalid Request
    And what kind of file are you actually trying to play?
    Looks like an online stream that cannot be accessed if you get such errors.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •