Results 1 to 3 of 3

Thread: mysql-systemd-helper[5161]: /usr/sbin/mysqld: Too many arguments (first extra is 'NAMES').

  1. #1

    Default mysql-systemd-helper[5161]: /usr/sbin/mysqld: Too many arguments (first extra is 'NAMES').

    So I can't start MariaDB since last week's update. The usual `systemctl start mysql.service` yields this error:
    mysql-systemd-helper[5161]: /usr/sbin/mysqld: Too many arguments (first extra is 'NAMES').

    What should I do?

  2. #2
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    427

    Default Re: mysql-systemd-helper[5161]: /usr/sbin/mysqld: Too many arguments (first extra is 'NAMES').

    Could you post your my.cnf?

    I'm using Tumbleweed (32 bit) and MariaDB 10.0.20 and "systemctl start mysql.service" works for me.

    Hendrik

  3. #3

    Default Re: mysql-systemd-helper[5161]: /usr/sbin/mysqld: Too many arguments (first extra is 'NAMES').

    Quote Originally Posted by benzene View Post
    So I can't start MariaDB since last week's update. The usual `systemctl start mysql.service` yields this error:
    mysql-systemd-helper[5161]: /usr/sbin/mysqld: Too many arguments (first extra is 'NAMES').

    What should I do?

    grep -i names /etc/my.* -R

    Comment out whatever config option there.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •