Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: setting up server (ssh, scp)

  1. #1

    Default setting up server (ssh, scp)

    Hi, on my computer suse 12.2 is installed (x86_64). I would like to use this computer remotely with ssh and scp. My question would be how to do this. Should I install a server? I would be grateful if someone could tell me what to do step by step.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,282

    Default Re: setting up server (ssh, scp)

    As openSUSE 12.2 is very old and unsupported (take care, no more security patches and you seemingly want to open it more to the network ), most answers must come from old memories.

    But the SSH server can normaly be switched on from YaST > System > System services IIRC.
    And you should configure it in /etc/ssh/sshd_config (but again that is the place it is in 13.1).

    II am not sure, but isn't scp part of SSH? And thus should be configured in the same place once sshd is running?
    Henk van Velden

  3. #3

    Default Re: setting up server (ssh, scp)

    Yes, upgrading is a good idea.

    Otherwise you can follow the other steps. It may be very wise to disable
    password-based logins in the config file hcvv mentioned (after setting up
    your user to login with keys). Changing the listening port is a good way
    to slow drive-by stinkers too (e.g. use 22222 instead, or something
    less-obvious). scp is indeed handled by the sshd daemon, as is sftp.

    Quicker way to enable things with default settings:

    Code:
    /sbin/chkconfig sshd on
    rcsshd start
    On 07/27/2015 04:26 AM, hcvv wrote:
    >
    > As openSUSE 12.2 is very old and unsupported (take care, no more
    > security patches and you seemingly want to open it more to the network
    > ), most answers must come from old memories.
    >
    > But the SSH server can normaly be switched on from YaST > System >
    > System services IIRC.
    > And you should configure it in /etc/ssh/sshd_config (but again that is
    > the place it is in 13.1).
    >
    > II am not sure, but isn't scp part of SSH? And thus should be configured
    > in the same place once sshd is running?
    >
    >


    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  4. #4

    Default Re: setting up server (ssh, scp)

    I allowed remote administration in YaST/Network Services/Remote Administration (VNC) on the "server" computer. But it does not work. The command ssh ipaddress does not get anything. What else should I do?

  5. #5

    Default Re: Re: setting up server (ssh, scp)

    Quote Originally Posted by walma View Post
    I allowed remote administration in YaST/Network Services/Remote Administration (VNC) on the "server" computer. But it does not work. The command ssh ipaddress does not get anything. What else should I do?
    Well, as the name implies, Remote Administration (VNC) only enables VNC (and XDMCP), not SSH.

    ab already told you how to enable SSH, and even start it immediately.
    You could also use YaST->System->System Services (Run-Levels) to enable it, or Services Manager in the latest versions as hcvv mentioned.
    There has been a SSH module in YaST too that should allow you to enable and configure it, but that has been removed. 12.2 should still have it though.

    And don't forget to open the corresponding port in the firewall.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: setting up server (ssh, scp)

    There are serious bugs in the older ssh versions. I'm fairly certain that 12.2 never go updated. if you keep ANY critical info on the 12.2 machine I'd not open it it the Internet where any one may get to it.

  7. #7

    Default Re: setting up server (ssh, scp)

    Hi, sshd is enabled on both computers. I can access other servers via ssh ipaddress, but it is not possible to have my computer as a server and access to that. Are you sure that enabling sshd is enough to act as a server?

  8. #8

    Default Re: setting up server (ssh, scp)

    Quote Originally Posted by walma View Post
    Are you sure that enabling sshd is enough to act as a server?
    Yes.

    But again, make sure that the corresponding ports are open in the firewall (on the server).
    Maybe try to disable the firewall completely as a test:
    Code:
    /sbin/SuSEfirewall2 stop

  9. #9

    Default Re: setting up server (ssh, scp)

    I have connected the computers to the same router with two ip addresses. There is a connectivity and ssh works. Hence, there is a problem with the network. The client connects to the internet with DSL (with password). Can this be a problem? I mean ssh may not be compatible with DSL.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: setting up server (ssh, scp)

    On 2015-07-28 19:26, walma wrote:
    >
    > I have connected the computers to the same router with two ip addresses.
    > There is a connectivity and ssh works. Hence, there is a problem with
    > the network. The client connects to the internet with DSL (with
    > password). Can this be a problem? I mean ssh may not be compatible with
    > DSL.


    You have two computers, and you say ssh works. I assume you mean that
    ssh from one to the other works. DSL or whatever is irrelevant for
    internal network connections.

    So what its the problem now?

    Are you trying to get ssh working from outside to your internal
    computers, perhaps? That is configured in the router, not in the computers.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •