Results 1 to 9 of 9

Thread: Applications not installed through YaST not starting after upgrade to 13.2

  1. #1

    Default Applications not installed through YaST not starting after upgrade to 13.2

    I am using ASUS Eee PC, T91MT. I upgraded from OpenSuSE 11.3 to 13.2. I did not format the home folder (I did not have anything more than base system under 11.3).
    I had Akonadi server initialisation problem, that was solved when I deleted the ~/.local/share/akonadi folder.
    I installed many software's through Yast and those I checked are working. I also installed TrueCrypt through the install script - truecrypt-7.1a-setup-x86 - from the tar.bz package. I also installed Google Chrome through the rpm - google-chrome-stable_current_i386.rpm. Both the installations completed normally - without any error code. Both the software's do not open. When I click on the menu items for these software's, their icons jump near the mouse for about 30 seconds. However, the applications do not start.
    I tried looking for relevant log (under /var/log) but couldn't find any.
    What am I missing? What do I need to do to use these applications? Any applications not installed through YaST?
    Thanks.
    Vikas Garud.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,982

    Default AW: Applications not installed through YaST not starting after upgrade to 13.2

    Start it from Konsole as User and post the Output.

  3. #3

    Default Re: Applications not installed through YaST not starting after upgrade to 13.2

    Here is the Konsole output for two commands:

    ------------------------------------------------------
    vikas@linux-x92t:~> /usr/bin/truecrypt
    /usr/bin/truecrypt: error while loading shared libraries: libgthread-2.0.so.0: cannot open shared object file: No such file or directory

    vikas@linux-x92t:~> /opt/google/chrome/google-chrome
    [1:1:0726/212201:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [2865:2865:0726/212201:ERROR:browser_main_loop.cc(213)] GTK theme error: Unable to locate theme engine in module_path: "oxygen-gtk",
    [2865:2865:0726/212201:ERROR:browser_main_loop.cc(213)] GTK theme error: Unable to locate theme engine in module_path: "oxygen-gtk",
    Aborted
    vikas@linux-x92t:~> libGL error: Couldn't dlopen libudev.so.1 or libudev.so.0, driver detection may be broken.
    libGL error: Couldn't dlopen libudev.so.1 or libudev.so.0, driver detection may be broken.
    ------------------------------------------------------

    It looks like library "libgthread-2.0.so.0" is not accessible for TrueCrypt. I located an RPM that provides "libgthread-2.0.so.0" and installed it through YaST. However, Truecrypt does not yet start.

    Don't know what to make for Chrome.

    What to try next?

  4. #4

    Default Re: Applications not installed through YaST not starting after upgrade to 13.2 - Update

    Searched once again, there were two RPMs which provided the library "libgthread-2.0.so.0". I had missed installing one of them in the first attempt. On installing it TrueCrypt is working.

    Thanks.

    Now, how do I proceed for Chrome?

    Thanks,
    Vikas Garud

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Applications not installed through YaST not starting after upgrade to 13.2

    truecrypot has been dead for quite some time now
    you can try realcrypt
    https://software.opensuse.org/package/realcrypt
    or veracrypt
    https://software.opensuse.org/package/veracrypt

    ps you seam to be missing oxygen-gtk (I'm not sure why it's not installed with the rest of oxygen)
    Code:
    sudo zypper in oxygen-gtk
    veracrypt is based on truecrypt 7.1a so it might be a better choice as realcrypt is based on truecrypt 7.0
    the best way to install it is to add the repo for install (you can disable or remove it after install)
    Code:
    sudo zypper ar http://download.opensuse.org/repositories/home:/kolbma:/veracrypt/openSUSE_13.2/home:kolbma:veracrypt.repo
    sudo zypper in veracrypt
    edit as reposetory seams to contain only 1 package you might not need to add it you can install veracrypt with this command
    Code:
    sudo zypper in http://download.opensuse.org/repositories/home:/kolbma:/veracrypt/openSUSE_13.2/i586/veracrypt-1.0f~2+53f6ba330ab1-1.1.i586.rpm
    ps. the above is true if you are running a 32bit OS (I assumed that from the version of truecrypt you are truing to install for a 64 bit OS install the 64 bit package)

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Applications not installed through YaST not starting after upgrade to 13.2

    about chrome, I'd suggest you add packman's repo and use chromium
    if you don't have packman do

    Code:
    zypper ar -f http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_13.2/ packman
    now install chromium, chromium-ffmpeg and pepper flash
    Code:
    sudo zypper in chromium chromium-ffmpeg chromium-pepper-flash
    you can always get chrome from google but that one has a few issues

  7. #7

    Smile Re: Applications not installed through YaST not starting after upgrade to 13.2 - Success

    Hi,
    I'm kind of successful on both the applications. TrueCrypt started working after installing two RPMs that provide the library that was not being found.

    Proceeding on similar lines, I located a RPM that provides "libudev.so.1". Chrome has started working after installing this RPM. However, Konsole still gives lots of error messages. Relevant Konsole output is pasted below. Due to all those errors, I'm worried about any future problems. Any pointers about what could be happening?

    Code:
    vikas@linux-x92t:~> /opt/google/chrome/google-chrome
    [1:1:0726/215615:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3586:3586:0726/215617:ERROR:browser_main_loop.cc(213)] GTK theme error: Unable to locate theme engine in module_path: "oxygen-gtk",
    [3586:3586:0726/215617:ERROR:browser_main_loop.cc(213)] GTK theme error: Unable to locate theme engine in module_path: "oxygen-gtk",
    libGL error: Version 4 or later of flush extension not found
    libGL error: failed to load driver: i915
    [3646:3646:0726/215622:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3648:3648:0726/215623:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3650:3650:0726/215623:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3652:3652:0726/215623:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3656:3656:0726/215623:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3586:3586:0726/215625:ERROR:extension_downloader.cc(693)] Invalid URL: '' for extension nmmhkkegccagdldgiimedpiccmgmieda
    [3742:3742:0726/215629:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3746:3746:0726/215629:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3749:3749:0726/215630:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3774:3774:0726/215631:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3804:3804:0726/215631:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3853:3853:0726/215632:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3911:3911:0726/215633:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3973:3973:0726/215633:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
    [3586:3609:0726/215638:ERROR:logging.h(775)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.kde.kwalletd was not provided by any .service files
    [3586:3609:0726/215638:ERROR:native_backend_kwallet_x.cc(405)] Error contacting kwalletd (isEnabled)
    [3586:3609:0726/215639:ERROR:logging.h(775)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
    [3586:3609:0726/215639:ERROR:native_backend_kwallet_x.cc(405)] Error contacting kwalletd (isEnabled)
    [3586:3595:0726/215645:ERROR:sandbox_ipc_linux.cc(431)] sendmsg: Broken pipe
    [3586:3595:0726/215645:ERROR:sandbox_ipc_linux.cc(431)] sendmsg: Broken pipe
    [3586:3595:0726/215645:ERROR:sandbox_ipc_linux.cc(431)] sendmsg: Broken pipe
    [3586:3595:0726/215649:ERROR:sandbox_ipc_linux.cc(431)] sendmsg: Broken pipe
    [1:2:0726/215652:ERROR:channel.cc(300)] RawChannel read error (connection broken)
    [3586:3614:0726/215652:ERROR:channel.cc(300)] RawChannel read error (connection broken)

    Thanks,
    Vikas Garud


    PS: I saw your suggestions while typing this reply. I've added packman repository and will install chromium and close the thread.
    Thanks,
    Vikas Garud
    Last edited by vdgarud; 26-Jul-2015 at 09:46. Reason: Additions

  8. #8

    Thumbs up SOLVED Applications not installed through YaST not starting after upgrade to 13.2

    Thanks. Installed Chromium and it is working fine.

    I'll try the other two options for encrypting files. I needed TrueCrypt since I've couple of files encrypted with TrueCrypt. Some links about Veracrypt and Realcrypt indicated possible incompatibility with Truecrypt. Hence using truecrypt to access those files.

    I'll also install oxygen - prevent any future problems.

    Thanks once again for quick resolution of the problem(s).

    Vikas Garud

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Applications not installed through YaST not starting after upgrade to 13.2

    veracrypt is basically truecrypt 7.1a with a few fixed bugs and a new name, the reason for a different name is truecrypt's license, their code is open-sourced but they copyrighted their name, in any case it's better to install software with an rpm package then a bash script it's easier to manage/update/remove.
    I've never used chrome but if you installed an rpm package with zypper or yast you should have no problems running it, your problems seam to come if you just unpacked a tar ball.
    in any case it's good you got truecrypt up and running and imo chromium is just as good if not better then chrome but I prefer Firefox.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •