Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: DigiKam/KF5

  1. #1
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default DigiKam/KF5

    Hi!

    I'm using openSUSE 13.2_64, kernel 3.16.7-21 and a mix of KDE 4.14.9 and wolfi323's repos for plasma5 and DigiKam/KF5. The reason I start to use DigiKam/KF5 was because DigiKam drop the support (lazy or forgot) for using a remote Mysql server for pictures/thumsnails. I did test and have been running DigiKam/KF5 for several months now both with mobile (my laptop) and using a remote Mysql server on my lan for my main DE.

    Yes it's a Beta. Some weeks ago I started to receive strange messages and then last week:



    Today It dident even show that when I put the command that "hides" behind the icon in a terminal at my main DE remote Mysql):
    Code:
    sh -c "[[ -e /opt/kf5/share/env/kf5.sh ]] && . /opt/kf5/share/env/kf5.sh; /opt/kf5/bin/digikam -qwindowtitle %c"
    Answer was:
    Code:
    sh: line 1:  3687 Segmentation fault      /opt/kf5/bin/digikam -qwindowtitle %c
    The same command in my laptop (who have the pictures stored in SQLlite on the local HD)the answer was:

    Code:
    sh: line 1:  2403 Segmentation fault      /opt/kf5/bin/digikam -qwindowtitle %c
    I notice that in the latest Thumbleweed(updated in the weekend) It still using ver 4.9.0 of DigiKam. There is no choice in there to select remote Mysql support.

    Not to complaining but have I miss something as usual ? Should I write a bug report and in that case to who (bugzilla, KDE, DigiKam)?

    regards
    Last edited by jonte1; 20-Jul-2015 at 08:37. Reason: change wording
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  2. #2

    Default Re: DigiKam/KF5

    Quote Originally Posted by jonte1 View Post
    Yes it's a Beta. Some weeks ago I started to receive strange messages and then last week:

    Might have been related to the mariadb update that messed up some library symlink. A followup update has been released already that fixes it.

    Today It dident even show that when I put the command that "hides" behind the icon in a terminal at my main DE remote Mysql):
    Code:
    sh -c "[[ -e /opt/kf5/share/env/kf5.sh ]] && . /opt/kf5/share/env/kf5.sh; /opt/kf5/bin/digikam -qwindowtitle %c"
    Answer was:
    Code:
    sh: line 1:  3687 Segmentation fault      /opt/kf5/bin/digikam -qwindowtitle %c
    The same command in my laptop (who have the pictures stored in SQLlite on the local HD)the answer was:

    Code:
    sh: line 1:  2403 Segmentation fault      /opt/kf5/bin/digikam -qwindowtitle %c
    Right, I can reproduce the crash on startup here.

    Might be a temporary problem (it is a development snapshot after all), or some mismatch in the dependencies.
    I will investigate...

    I notice that in the latest Thumbleweed(updated in the weekend) It still using ver 4.9.0 of DigiKam. There is no choice in there to select remote Mysql support.
    Hm, TW's digikam is built with mysql support AFAICS.

    You could also try the one from KDE:Extra though.

  3. #3

    Default Re: DigiKam/KF5

    The digikam5 crash should be fixed now, please update/reinstall digikam5.

    In case you're interested, this is what happened:
    • The digikam developers moved the DNGConverter from kipi-plugins to digikam itself.
    • Apparently the used 3rd-party dngwriter is not compatible with the XMP tools used in current exiv2 versions (or it is just plain broken), it caused the crash when being initialized.


    I reverted back to the last version before those changes, that's why it has a lower "version" number and is not seen as update at the moment.
    I changed the version to 4.81git now, so this should be "fixed" in a few hours...

  4. #4
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default Re: DigiKam/KF5

    Hello!

    Thanks for the info and work. I can confirm that digikam/KF5 (4.81git) now works on my main DE with remote mysql/storage and on my laptop with sqlite and local storage.

    Hm, TW's digikam is built with mysql support AFAICS.
    -not what I can see (in TW (digikam 4.9.0)), -have I missed something again ?


    regards
    Last edited by jonte1; 24-Jul-2015 at 05:00. Reason: added text
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  5. #5

    Default Re: DigiKam/KF5

    Quote Originally Posted by jonte1 View Post
    Thanks for the info and work. I can confirm that digikam/KF5 (4.81git) now works on my main DE with remote mysql/storage and on my laptop with sqlite and local storage.
    Thanks for confirming.

    I will update digikam5 to the latest version again when this is fixed.
    At the moment I do build the latest version in a separate repo to be able to test it... (at the moment it doesn't even build successfully though)

    -not what I can see (in TW (digikam 4.9.0)), -have I missed something again ?
    Hm, I haven't actually tried it (I'm not using Tumbleweed myself), I might do so over the weekend though.

    But it is built with the exact same options, and the package does require libqt4-sql-mysql.
    And the buildlog contains this:
    Code:
     --  Qt4 SQL module found..................... YES
    So it should be able to use all databases that Qt4 supports. If you have libqt4-sql-mysql installed, that should include mysql.

    Again, you could also try version 4.11 from KDE:Extra, that repo is available for Tumbleweed as well.
    Although this version should appear in Tumbleweed at some point anyway, I don't know why it hasn't been forwarded yet. (KDE:Extra is the devel repo for Factory/Tumbleweed)

  6. #6

    Default Re: DigiKam/KF5

    Hm, I just tried with digikam 4.6 on my 13.2 system, and I cannot select MySQL there either. (I thought I tried that a few days ago... )

    So it seems the mysql support is disabled in the KDE4 version in general. Apparently just building against libqt4-sql is not enough any more (it was in the past AFAIK, the build options used in the openSUSE package haven't been changed since 2 years at least).
    I haven't tried the version from KDE:Extra yet, but I'd expect the same there.
    Last edited by wolfi323; 24-Jul-2015 at 05:41.

  7. #7

    Default Re: DigiKam/KF5

    Ok, I suppose this changelog entry explains why digikam/KDE4 doesn't support MySQL any more:
    2014-11-14 Gilles Caulier <caulier.gilles@gmail.com>

    * CMakeLists.txt, README: turn off mysql support by default. thumbs
    db option will be removed later
    And nobody changed the KDE4 package to explicitly turn mysql support on. This is done in the KF5 package though, in both mine and the one from KDE:Unstable:Extra.

    I guess I'll try to submit a package with re-enabled mysql support over the weekend then...

  8. #8

    Default Re: DigiKam/KF5

    Quote Originally Posted by wolfi323 View Post
    I guess I'll try to submit a package with re-enabled mysql support over the weekend then...
    I submitted a "fixed" package to KDE:Extra now.
    If this gets accepted, and forwarded to Factory again, it should end up in Tumbleweed soon as well.

    If you think we should release an update for 13.2 too, please file an openSUSE bug report. I'll take all necessary actions then.
    Strictly speaking this is a regression in the last update for 13.2 to digikam 4.6.0.

  9. #9

    Default Re: DigiKam/KF5

    An update:
    My package has been accepted and is now available in KDE:Extra.

    The package has been forwarded to Factory/Tumbleweed as well, but this will take some time as it has to go through review and staging/testing first.
    But you should get digikam 4.11.0 with MySQL support in Tumbleweed soon.

    If you don't want to wait, you can install it from KDE:Extra now, for 13.2 too.
    Last edited by wolfi323; 24-Jul-2015 at 15:42.

  10. #10
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default Re: DigiKam/KF5

    Is this a "big" thing to write about? Yes it is if you have + 25 000 photos.

    Startup digikam/KF5 using remote storage/mysql takes longer (30-40 sec) but then digikam is considerable faster. You have to try/test to see the difference.

    Reported as bug 939431 .

    Oh I was whining already in January -post #37.

    Thanks Wolfgang.

    regards
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •