Results 1 to 9 of 9

Thread: All system fonts in italics

  1. #1

    Default All system fonts in italics

    Hi. I am using openSUSE 13.1 with KDE desktop.

    A few weeks after I installed this OS on my laptop, the fonts everywhere on the system changed to italics, everything from window titles to menus, taskbar text and even the contents of webpages are in italics. I have checked the fonts control module, done all the required updates and every other thing I think I should but I have not been able to change the font back to normal. Any help will be appreciated.
    Thanks.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: All system fonts in italics

    There are two levels of fonts system and user. Since Linux is multi user each user can have their own configuration.

    So you said System fonts, used by root/system function, so where exactly did your "change" the fonts?

    In KDE use
    Configure Desktop - Application Appearance - Fonts
    to set user fonts details

    Font management is just for adding/deleting etc fonts available to the system

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,631
    Blog Entries
    3

    Default Re: All system fonts in italics

    Logout. Then login to Icewm instead of to KDE.

    Click on the terminal icon in the panel to open a terminal (so that you have a window open).

    Are window titles still italic? Or is that only in KDE.

    A second test: Create a new user, and login as that user. Is everything still italic?

    The aim of these tests is to see if the problem is in system-wide settings or in individual user settings.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: All system fonts in italics

    Thanks for the prompt replies.

    I have logged in with Icewm and as a new user, the fonts are still in italics.
    I have also checked Configure Desktop - Application Appearance - Fonts as recommended, but found nothing about italics there.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: All system fonts in italics

    You have to select them the size and style can be selected from a popup window

    But that is not your problem if other users and desktops show the same.

    What video card do you have and what driver???

  6. #6

    Default Re: All system fonts in italics

    This is the result I got from running lspci -vnn | grep VGA -A 12

    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
            Subsystem: CLEVO/KAPOK Computer Device [1558:0805]
            Flags: bus master, fast devsel, latency 0, IRQ 47
            Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
            Memory at d0000000 (64-bit, prefetchable) [size=256M]
            I/O ports at 1800 [size=8]
            Expansion ROM at <unassigned> [disabled]
            Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
            Capabilities: [d0] Power Management version 3
            Kernel driver in use: i915
            Kernel modules: i915

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: All system fonts in italics

    Something similar happened to me once in KDE4, because I had deleted the .ttf font file set as the default sans in the substitution table - a text config file in .kde4/somewhere, can't remember exactly where.

    As it couldn't find the file, it went to the next-best matching name, which was the italic or bold variant. IINM I posted here about it, I'll see if I can find the thread.

  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: All system fonts in italics


  9. #9

    Default Re: All system fonts in italics

    Thanks brunomcl, by following the recommendations in the thread you shared then restarting the system, I was able to get the problem solved.

    And thanks to every other person that contributed to this thread.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •