Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: .rpm File does not install

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default .rpm File does not install

    I'm using OpenSuse 13.2 64 bit

    When I try to install the program SpiderOak with "SpiderOak-5.2.0-1.x86_64.rpm" from the site https://spideroak.com/opendownload
    When I click in the file .rmp, appear normal installation screens until the last saying "File was installed successfully" but in reality does not install anything.

    What could be happening?

    Thanks in advance.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: .rpm File does not install

    On 2015-07-14 00:26, sergelli wrote:
    >
    > I'm using OpenSuse 13.2 64 bit
    >
    > When I try to install the program SpiderOak with
    > "SpiderOak-5.2.0-1.x86_64.rpm" from the site
    > https://spideroak.com/opendownload
    > When I click in the file .rmp, appear normal installation screens until
    > the last saying "File was installed successfully" but in reality does
    > not install anything.
    >
    > What could be happening?


    Impossible to know.

    Why don't you open a terminal in the directory where the rpm is, and
    install it using rpm, yast, or zypper?

    Code:
    su
    yast sw_single package.rpm
    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: .rpm File does not install

    Quote Originally Posted by robin_listas View Post

    Impossible to know.

    Why don't you open a terminal in the directory where the rpm is, and
    install it using rpm, yast, or zypper?

    Code:
    su
    yast sw_single package.rpm
    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))




    My God !!
    This has medicine?



    Code:
    linux-kdup:/home/sergio/Downloads/spideOak # rpm -i SpiderOak-5.2.0-1.x86_64.rpm
    warning: SpiderOak-5.2.0-1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 87271cbf: NOKEY
    error: Failed dependencies:
            libc.so.6()(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libc.so.6(GLIBC_2.2.5)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libc.so.6(GLIBC_2.3)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libc.so.6(GLIBC_2.4)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libdl.so.2()(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libdl.so.2(GLIBC_2.2.5)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libgcc_s.so.1()(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libgcc_s.so.1(GCC_3.0)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libm.so.6()(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libm.so.6(GLIBC_2.2.5)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libpthread.so.0()(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            librt.so.1()(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64
            libz.so.1()(64bit) is needed by SpiderOak-1:5.2.0-1.x86_64

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: .rpm File does not install

    On 2015-07-14 01:36, sergelli wrote:

    > My God !!
    > This has medicine?


    Use yast... :-)


    Your machine and OS are 64 bits?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #5
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: .rpm File does not install

    Quote Originally Posted by robin_listas View Post

    Use yast... :-)


    Your machine and OS are 64 bits?
    Thanks, Carlos
    Yes. My machine and OS are 64 bits.
    But, how is the sintax of yast?

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: .rpm File does not install

    Please post the output of;
    uname -m

    Also you should never install .rpms directly with the command but instead use zypper so it'll take care of the dependencies, like this:
    sudo zypper in /path/to/SpiderOak-5.2.0-1.x86_64.rpm

    Adjust path to where the file is located, zypper needs to be pointed to the file itself.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: .rpm File does not install

    On 2015-07-14 12:26, sergelli wrote:

    > Yes. My machine and OS are 64 bits.
    > But, how is the sintax of yast?


    I wrote it in my first post here.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: .rpm File does not install

    On 2015-07-14 12:26, sergelli wrote:

    > Yes. My machine and OS are 64 bits.


    It doesn't look like it is...

    Please post the output of "uname -a".

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  9. #9
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: .rpm File does not install

    Hi Carlos & Mioku

    Code:
    sergio@linux-kdup:~/Downloads/spideOak> uname -a
    Linux linux-kdup 3.16.7-21-desktop #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) i686 i686 i386 GNU/Linux


    Hi Mioku


    Code:
    sergio@linux-kdup:~/Downloads/spideOak> uname -m
    i686
    
    sergio@linux-kdup:~/Downloads/spideOak> sudo zypper in /home/sergio/Downloads/spideOak/SpiderOak-5.2.0-1.x86_64.rpm
    Loading repository data...
    Reading installed packages...
    '_tmpRPMcache_:SpiderOak=1:5.2.0-1' not found in package names. Trying capabilities.
    No provider of '_tmpRPMcache_:SpiderOak=1:5.2.0-1' found.
    Resolving package dependencies...
    
    Nothing to do.

  10. #10
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: .rpm File does not install

    Your operating system is 32bit, it says i386 / i686 there instead of x86_64.

    That is why you cannot install the rpm properly, you need to acquire a 32bit rpm.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •