Results 1 to 10 of 10

Thread: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

  1. #1
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    after update ~4 days back I get this error
    Code:
    Unable to create io-slave:
    klauncher said: Error loading 'kio_file'.
    it was a minor issue but I can't open dolphin, copy/move files in krusader = it's embarassing I've looked for that file but and it's in
    Code:
    usr/lib64/kde4/kio_file.so
    
    as it shoud be. What can I do? I've btrfs so could I replace this file with file in some older snapshot ?
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  2. #2

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    Quote Originally Posted by roberto68 View Post
    after update ~4 days back I get this error
    Code:
    Unable to create io-slave:
    klauncher said: Error loading 'kio_file'.
    it was a minor issue but I can't open dolphin, copy/move files in krusader = it's embarassing I've looked for that file but and it's in
    Code:
    usr/lib64/kde4/kio_file.so
    
    as it shoud be. What can I do? I've btrfs so could I replace this file with file in some older snapshot ?
    Is your system fully up to date (with "zypper dup")? Do you have any 13.1/13.2 (or other non-Tumbleweed/Factory) repos active?
    Something like this can happen if you have a mixture of packages built with gcc48 and gcc5 installed. Tumbleweed was recently switched to use gcc5 by default, you might have some old packages installed causing the problem.

    See also: https://forums.opensuse.org/showthre...sh-kio_desktop

  3. #3
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    this is what I get from zypper dup
    Code:
     Problem: kscreen-lang-1.0.71-3.4.noarch requires kscreen = 1.0.71, but this requirement cannot be provided Problem: patterns-openSUSE-kde-20150603-4.1.x86_64 requires pattern() = kde_plasma, but this requirement cannot be provided
    and should I remove only gcc48 (& gcc48 c++), or other depedndencies of the gcc48??
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  4. #4

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    Quote Originally Posted by roberto68 View Post
    this is what I get from zypper dup
    And what options did you choose before?
    Please post all conflicts, and how you reacted.

    Code:
     Problem: kscreen-lang-1.0.71-3.4.noarch requires kscreen = 1.0.71, but this requirement cannot be provided 

    kscreen 1.0.71 is the KDE4 version that's not available any more. Remove it.

    Code:
    Problem: patterns-openSUSE-kde-20150603-4.1.x86_64 requires pattern() = kde_plasma, but this requirement cannot be provided

    Why can this not be provided?
    Did you lock Plasma5 or something like that?
    Last edited by wolfi323; 09-Jul-2015 at 08:11.

  5. #5
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    ok so after removing gcc48 zypper dup did not states any problem
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  6. #6

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    Quote Originally Posted by roberto68 View Post
    ok so after removing gcc48 zypper dup did not states any problem
    So, does it work now?

    It doesn't matter what compiler(s) _you_ have installed.
    The important thing is which compiler was used to _build_ the packages you have installed.

    If some of your KDE4 packages were built with gcc48, and others with gcc5, there will be problems.
    Upgrade your system, so that you only have packages installed that are built with gcc5.

    And please, answer the questions you are being asked, if you want help.

  7. #7
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    Ok so I did zypper dup breaking all dependencies, btw does it refresh & enable repos which a re disabled or not checked for refreshing ( it seems to me so)? cause I d not want that in case of ruby and nodeJS repo cause I want to let to gem and npm command so nothing'd be broken. and there was still problem but I just did not notice it somehow. btw still the same after zypper dup
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  8. #8

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    Quote Originally Posted by roberto68 View Post
    Ok so I did zypper dup breaking all dependencies
    What do you mean with that?
    You should rather not "break dependencies", things are likely to break then.

    So what did you do exactly? What dependencies did you break how?

    btw does it refresh & enable repos which a re disabled or not checked for refreshing ( it seems to me so)?
    No, it doesn't.
    It only refreshes and uses repos that are enabled.

    Can you please post a list of your repos?
    Code:
    zypper lr -d
    And maybe from which repos your dolphin and libkde4 come from:
    Code:
    rpm -qi dolphin libkde4
    Last edited by wolfi323; 09-Jul-2015 at 09:02.

  9. #9
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    ok so now after zypper dup it works and i've nice new design also. btw when ruby, Nodejs repo is not enabled it means that zypper won't be able to update it but gem, npm will ? and last question I mistakenly cancel KDE wallte migration is there way to do it "sane way" not copying ffiles
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  10. #10

    Default Re: Unable to create io-slave: klauncher said: Error loading 'kio_file'.

    Quote Originally Posted by roberto68 View Post
    btw when ruby, Nodejs repo is not enabled it means that zypper won't be able to update it but gem, npm will ?
    Depends in which repo it is available.
    If it's in some other repo, zypper can update it, unless there's a problem with dependencies.

    ruby is in the standard repos though, so there will be updates for it.

    But it also depends on whether you run "zypper up" or "zypper dup" of course. "up" will not switch a package to a version from another repo, "dup" will if there's a higher version in another repo.

    And another factor would be the priorities of your repos.

    and last question I mistakenly cancel KDE wallte migration is there way to do it "sane way" not copying ffiles
    If you just cancelled it, it should ask you again the next time it starts (on next login probably).

    If you told it to not migrate the wallet(s) but want to do it anyway now, then just delete ~/.local/share/kwalletd/. It will again ask you whether to migrate the data on next start.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •