Results 1 to 6 of 6

Thread: 12.3 KDE system will not shut computer off after shut-down

  1. #1

    Default 12.3 KDE system will not shut computer off after shut-down

    I searched...could not find anything that would help. This is not a huge deal since I leave my Linux server running 24/7 but the fact that it's not working bothers me:

    There are no applications running, no browser windows open, no files open. I use the "shut down" method from the KDE desktop. The system does the shut down sequence but then it just stops with a black screen and this message:

    dude login: [ 272.635821] System halted.


    ('dude' is the hostname). This is on a 12.3 "Dartmouth" system kernel 3.7.10-1.45-desktop

    Sometimes I don't get the black screen with the message, it will just sit at a blank screen with the large gecko (or chameleon?) openSUSE logo. I have to manually hit the power button on the computer to get it to shut off.

    Any pointers on how I can trace this or figure out how to get it to turn the computer off? thanks...

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: 12.3 KDE system will not shut computer off after shut-down

    BIOS problems maybe. Always worked like this or is this new behaviour?? Video/drivers can cause this also. Does a command line shut down work?

    But note that 12.3 is old and no longer supported. Thus no more updates

  3. #3

    Default Re: 12.3 KDE system will not shut computer off after shut-down

    Quote Originally Posted by soosehey View Post
    Any pointers on how I can trace this or figure out how to get it to turn the computer off? thanks...
    Does "sudo poweroff" or "systemctl poweroff" work?
    If not, it's probably an ACPI issue.

    If you are using kdm as login screen: what's set as "Shutdown Command" in "Configure Desktop"->Login Screen->Shutdown?

    Your message seems to indicate that you/KDE ran "halt" for shutdown. That's not powering off the system (although it did in earlier openSUSE versions by mistake), it only shuts down the OS.
    For powering off, you need to run "poweroff" or "halt -p", or "shutdown" which should be the default for kdm nowadays.
    All of those will effectively run "systemctl poweroff" though, as they are all symlinks to systemctl on systemd systems.

    Btw, 12.3 is out of support since January...

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 12.3 KDE system will not shut computer off after shut-down

    On 2015-07-04 18:16, wolfi323 wrote:
    > ran "halt" for shutdown.
    > That's not powering off the system (although it did in earlier openSUSE
    > versions by mistake), it only shuts down the OS.


    halt powered off the machine since I remember... probably since SuSE
    5.3. You say this was a mistake? Curious...

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #5

    Default Re: 12.3 KDE system will not shut computer off after shut-down

    Quote Originally Posted by robin_listas View Post
    On 2015-07-04 18:16, wolfi323 wrote:
    > ran "halt" for shutdown.
    > That's not powering off the system (although it did in earlier openSUSE
    > versions by mistake), it only shuts down the OS.


    halt powered off the machine since I remember... probably since SuSE
    5.3. You say this was a mistake? Curious...
    Yes, or call it bug, incorrect behaviour, whatever.

    Why do you think halt has a -p ("--poweroff") switch otherwise? Or why there's a separate poweroff command that's actually just a symlink to halt, (like reboot too)?
    halt acts differently depending by which name it is being called... See "man halt".

    See also the 12.1 release notes, that's when the behaviour has been "corrected" IIRC:
    https://doc.opensuse.org/release-not...nSUSE/12.1/#18

    Ok, I found this too, which leads me to the conclusion that this was not explicitely "fixed" by openSUSE, but rather by the change to systemd:
    https://en.opensuse.org/openSUSE:Mos...ying_bugs_12.1

    A recent bug report is here btw, where it is again explained that halt won't poweroff your machine:
    https://bugzilla.opensuse.org/show_bug.cgi?id=934395
    It also tells that the OP's message "System halted." means that poweroff was not intended because it was just a halt. (apparently the kernel can also switch to halt instead of poweroff if it detects no possibility for powering off, i.e. there's an ACPI issue)

    Please note, that I don't want to argue which behaviour would be more correct or something like that.
    I'm only stating facts: since the switch to systemd (in 12.1 you could still switch to sysvinit, since 12.3 systemd is the only option), the command "halt" (without '-p') does not power down the machine any more in openSUSE. You have to use "halt -p", "poweroff", or "shutdown" if you want to power down.
    But all of those are legacy commands for compatibility, and actually just symlinks to systemctl.
    Last edited by wolfi323; 04-Jul-2015 at 12:54.

  6. #6

    Default Re: 12.3 KDE system will not shut computer off after shut-down

    ok thanks for the pointers, I will try these things when I can (the machine is always doing something so tough to just experiment with shutting down). This used to work fine but I applied a bunch of updates recently so maybe after that it stopped working. Also I just disabled the internal NIC through bios and plugged in a new NIC into one of the PCI slots.

    I was simply using the "shut off computer" button on the system menu (GUI) in KDE, I was not issuing any shell command to shut down.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •