Results 1 to 5 of 5

Thread: lilypond-editor frescobaldi does not run in openSuSE 13.2

  1. #1

    Default lilypond-editor frescobaldi does not run in openSuSE 13.2

    Hello,
    I need the most recent release 2.18.1 of the lilypond notation editor frescobaldi. I have added the repository /repositories/multimedia:/apps/openSUSE_13.2

    and installed frescobaldi including its dependencies from there, including some python packages and lilypond.

    All dependencies seem to be correct (according to Yast), but frescobaldi does not start. Instead, when I start it from a command line with the command "frescobaldi", I get the following message:

    File"/usr/local/bin/frescobaldi", line 7,in<module>
    import main
    File"/usr/local/lib/python2.7/site-packages/frescobaldi_app/main.py", line 26,in<module>
    import sip
    Import Error:No module named sip

    It does not run from the KDE desktop either. It seems that there is an issue with python-sip or some other python package. Has anyone a solution for this? Thanks!

    Best regards

    Eriol

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,005

    Default Re: lilypond-editor frescobaldi does not run in openSuSE 13.2

    Fresco expects you to use Python3, not 2.x.

    Install python3, python3-sip and change python to python3 with update-alternatives --config python
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: lilypond-editor frescobaldi does not run in openSuSE 13.2

    Wow - thanks! Indeed, I had not installed python3-sip and some other packages. I wonder why the dependencies were still ok. But now it works fine as it should!

    Again - thank you very much for your hints!

    Eriol

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,005

    Default Re: lilypond-editor frescobaldi does not run in openSuSE 13.2

    Quote Originally Posted by EriolBrumel View Post
    I wonder why the dependencies were still ok.
    Packaging error by whoever maintains the package, these things happen.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  5. #5

    Default Re: lilypond-editor frescobaldi does not run in openSuSE 13.2

    Just a note, not directly related to your problem:
    Quote Originally Posted by EriolBrumel View Post
    File"/usr/local/bin/frescobaldi", line 7,in<module>
    import main
    File"/usr/local/lib/python2.7/site-packages/frescobaldi_app/main.py", line 26,in<module>
    import sip
    Import Error:No module named sip
    You say you installed it from the multimedia:apps repo, but the openSUSE package installs the files to /usr/bin/ and /usr/lib/python3.4/.
    So you seem to have a manual installation of frescobaldi too (in /usr/local/) which you are actually using.

    To avoid confusion, I would rather remove one of them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •