Results 1 to 7 of 7

Thread: Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

  1. #1
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    51

    Default Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

    Hello,

    Please let me request your help in resolving the following issue.

    My system is an OpenSUSE 13.1 64bit on an Aspire E1-572-G laptop. Since the OS was out before I bought the machine, I run a more recent kernel (ver. 3.18.6-1.1) from http://download.opensuse.org/reposit...able/standard/ to make the network card work. The Desktop is KDE 4.8.5 .

    Recently, after login, it takes several minutes(!) for the desktop to become reactive to my input (mouse movement, typing etc.). Observing the widget System Load Viewer, I see a very high CPU load while the hard drive LED is lit what seems permanently. Once things settle down, the machine reacts a little sluggish which is slower than what I have been used to. Logout is just as slow.

    A very odd observation: When I log in as a different user, the behavior of the machine is as expected, i.e., once the splash screen has gone away it reacts very soon to input. Likewise, logout is very quick.

    How can this behavior be put back in order? In case more input is needed, I would be happy to provide it. In your instructions, please be specific since I am not an expert.

    Thanks in advance for your help.

  2. #2

    Default Re: Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

    Quote Originally Posted by paschuller View Post
    My system is an OpenSUSE 13.1 64bit on an Aspire E1-572-G laptop. Since the OS was out before I bought the machine, I run a more recent kernel (ver. 3.18.6-1.1) from http://download.opensuse.org/reposit...able/standard/ to make the network card work. The Desktop is KDE 4.8.5 .
    And where did you install KDE 4.8.5 from?
    openSUSE 13.1 comes with 4.11.5.

    Recently, after login, it takes several minutes(!) for the desktop to become reactive to my input (mouse movement, typing etc.). Observing the widget System Load Viewer, I see a very high CPU load while the hard drive LED is lit what seems permanently. Once things settle down, the machine reacts a little sluggish which is slower than what I have been used to. Logout is just as slow.

    A very odd observation: When I log in as a different user, the behavior of the machine is as expected, i.e., once the splash screen has gone away it reacts very soon to input. Likewise, logout is very quick.

    How can this behavior be put back in order? In case more input is needed, I would be happy to provide it. In your instructions, please be specific since I am not an expert.
    Try to rename ~/.kde4 for a start.
    Maybe you have file indexing activated? Check in "Configure Desktop" that it's turned off.
    Could also be because you start some large program on login. How much RAM do you have?

    To find out what's the culprit, run "top" or have a look in the system monitor (Ctrl+ESC) which process uses much CPU or RAM.

  3. #3
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    51

    Default Re: Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

    Quote Originally Posted by wolfi323 View Post
    And where did you install KDE 4.8.5 from?
    openSUSE 13.1 comes with 4.11.5.

    Try to rename ~/.kde4 for a start.
    Maybe you have file indexing activated? Check in "Configure Desktop" that it's turned off.
    Could also be because you start some large program on login. How much RAM do you have?

    To find out what's the culprit, run "top" or have a look in the system monitor (Ctrl+ESC) which process uses much CPU or RAM.
    Re. KDE version - Sorry, I didn't get the right line in the output of 'kwin -v':
    Code:
    # > kwin -v
    Qt: 4.8.5
    KDE Development Platform: 4.11.5
    KWin: 4.11.12
    Renaming temporarily ~/.kde4 did resolve the issue of reactiveness! All the desktop settings were gone, though. What is going on here? Is it possible to tighten the perimeter?

    "Configure Desktop > Workspace Appearance and Behavior > Desktop Search" says "File indexing service not running".

    "top" does not show any process using more than a couple of percent CPU time. Firefox uses the highest amount of memory with about 200MB out of 8GB total.

  4. #4

    Default Re: Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

    Quote Originally Posted by paschuller View Post
    Re. KDE version - Sorry, I didn't get the right line in the output of 'kwin -v':
    Code:
    # > kwin -v
    Qt: 4.8.5
    KDE Development Platform: 4.11.5
    KWin: 4.11.12
    Ok, so it was Qt 4.8.5, but KDE 4.11.5...

    Renaming temporarily ~/.kde4 did resolve the issue of reactiveness! All the desktop settings were gone, though. What is going on here? Is it possible to tighten the perimeter?
    So it is somehow related to your user settings.
    You could try to copy back the content of .kde4 in batches to find out what the culprit is/was.
    I would expect something in .kde4/share/config/ though, so you could copy/move the other sub folders as a whole.

    I'd say the most likely candidate for the behaviour you describe might be file indexing, i.e. the files nepomuk*. But that's just guessing now.

    "Configure Desktop > Workspace Appearance and Behavior > Desktop Search" says "File indexing service not running".
    Yes, it is disabled with the default settings (on openSUSE that is).
    But it might have been enabled before.

    "top" does not show any process using more than a couple of percent CPU time. Firefox uses the highest amount of memory with about 200MB out of 8GB total.
    Ok, then this does not seem to be the reason.
    Although, again, it might have been different before you renamed ~/.kde4/.
    Last edited by wolfi323; 30-Jun-2015 at 07:20.

  5. #5
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    51

    Default Re: Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

    Sorry for taking awhile to get back, I was on travel.

    Quote Originally Posted by wolfi323 View Post
    So it is somehow related to your user settings.
    You could try to copy back the content of .kde4 in batches to find out what the culprit is/was.
    I would expect something in .kde4/share/config/ though, so you could copy/move the other sub folders as a whole.
    The remark about user settings inspired me to try a different thing. I started to close down open windows which would be remembered from one desktop login to the next. In particular, there was one Konsole window with about ten terminal tabs. When I clicked on its "Close Window" button, it took a couple of minutes before it actually closed. The System Load Viewer indicated that RAM usage went way down. Logging out and back in went very well and quick!

    So, problem solved - thank you for your help!

    Still, I would like to understand the problem. Why this behavior? Is there a way to prevent it?

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

    Probably a zombie process. Some times process do not actually quiet and live on as zombies. I have seen it happen with some text editors (nano) in the past that if you just shut the console window without first quieting the editor a zombie version would eat CPU. You can observe what is using excessive cpu cycles with the terminal program top. Also in KDE the GUI program Ksysguard will show CPU activity

  7. #7

    Default Re: Login on OpenSUSE 13.1, KDE 4.8.5: Not reactive for long time

    Quote Originally Posted by paschuller View Post
    Still, I would like to understand the problem. Why this behavior?
    Good question.
    Maybe a bug/inefficiency in Konsole?
    Obviously it needs more RAM the more tabs you have open, but 10 tabs shouldn't drag your system down.
    Of course it also depends on what you run in those tabs...

    Is there a way to prevent it?
    Open less tabs?

    Seriously, 4.11 is not really the newest version any more too.
    You could try to upgrade your KDE to the latest version from KDE:Current (14.12.3). Maybe that works better?
    I just tried to open 10 tabs here on my 13.2 system (with just running bash inside), and I didn't see any negative impact.

    As the KDE4 version is not developed/maintained any more, you might also try the latest KF5 version. You could install it from my Frameworks5 repo, that contains a version that can be installed alongside the KDE4 version.
    http://software.opensuse.org/package/konsole5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •