Results 1 to 6 of 6

Thread: Ruby on Rails - installing problem - OpenSUSE 13.2 KDE x64

  1. #1
    Join Date
    Jun 2015
    Location
    Serbia
    Posts
    6

    Default Ruby on Rails - installing problem - OpenSUSE 13.2 KDE x64

    I have some problem with installing RoR on OpenSUSE 13.2 KDE x64

    Code:
    # ruby -v
    ruby 2.1.3p242 (2014-09-19 revision 47630) [x86_64-linux-gnu]
    # gem -v
    2.4.8
    # uname -a
    Linux linux.site 3.16.7-21-desktop #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) x86_64 x86_64 x86_64 GNU/Linux
    In paste ill give you console exit whan trying to install ruby on rails with
    Code:
    gem install rails

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Ruby on Rails - installing problem - OpenSUSE 13.2 KDE x64

    Code:
    zypper in rubygem-rails-3_2
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    Jun 2015
    Location
    Serbia
    Posts
    6

    Default Re: Ruby on Rails - installing problem - OpenSUSE 13.2 KDE x64

    Thank you @Miuku it was done. One more question, how to check is it all OK and work?

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,256
    Blog Entries
    2

    Default Re: Ruby on Rails - installing problem - OpenSUSE 13.2 KDE x64

    Quote Originally Posted by mikisid View Post
    Thank you @Miuku it was done. One more question, how to check is it all OK and work?
    Create a rails project, invoke the website running on an express server.
    Do you know how to do that? I can post a guide although in the "Install Ruby" on openSUSE link below I simply point to someone else' blog how to do this.

    There are a lot more steps you should run besides what you've described,
    A shortlist of things you probably haven't installed yet
    - A runtime scripting environment
    - Sqlite (for Rails)
    - bundler
    - openssl dev headers

    To install a full Rails environment, you should follow what I posted recently
    https://en.opensuse.org/User:Tsu2/Install_Ruby

    In it I describe various ways to install Ruby, from either the openSUSE repos (like you're doing) or from the official Ruby repos.

    Well, it's actually not that clear what you are doing since without knowing all the steps you've done and by following Miuku's suggestion you may be running a hybrid of Ruby from wherever (since you used the gem command to display your gem version) while also installing rails from the openSUSE repos. Don't know what that would result in, since I've never tried to do what you're doing. If you followed my instructions for installing rails from the Ruby repos, then "gem install rails" would have worked.

    TSU

  5. #5

    Default Re: Ruby on Rails - installing problem - OpenSUSE 13.2 KDE x64

    I'm having the same(-ish) problem/s. I've followed the instructions in the Install_Ruby link referenced here, below. The install succeeds, but the following ruby-vagrant install fails on rubygem, still, because "nothing provides rubygem".

    Code:
    root@thpad  />zypper in ruby rubygem-bundler nodejs git    gcc make libopenssl-devel sqlite3-devel
    Retrieving repository 'Packman Repository' metadata ..................................................................................[done]
    <snip>
    Loading repository data...
    No update candidate for 'ruby-2.1-1.2.x86_64'. The highest available version is already installed.
    <snip>
    Resolving package dependencies...
    
    The following 4 NEW packages are going to be installed:
      libopenssl-devel nodejs rubygem-bundler sqlite3-devel
    
    4 new packages to install.
    Overall download size: 7.0 MiB. Already cached: 0 B  After the operation, additional 25.6 MiB will be used.
    Continue? [y/n/? shows all options] (y): y
    
    <snip>
    Retrieving package rubygem-bundler-1.8.4-2.4.1.x86_64                                                 (3/4), 441.8 KiB (1008.9 KiB unpacked)
    Retrieving: rubygem-bundler-1.8.4-2.4.1.x86_64.rpm .....................................................................[done (462.0 KiB/s)]
    
    <snip>
    Checking for file conflicts: .........................................................................................................[done]
    (1/4) Installing: libopenssl-devel-1.0.1k-2.39.1 .....................................................................................[done]
    (2/4) Installing: nodejs-4.4.5-21.1 ..................................................................................................[done]
    (3/4) Installing: rubygem-bundler-1.8.4-2.4.1 ........................................................................................[done]
    (4/4) Installing: sqlite3-devel-3.8.6-3.1 ............................................................................................[done]
    root@thpad  />
    At this point, ruby-gem and all relevant variations (via the bundler) should be installable, right?

    Code:
    root@thpad  /media/lacie>zypper in rubygem-vagrant
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides rubygem(ruby:2.1.0:listen:2.8) >= 2.8 needed by rubygem-vagrant-1.7.2-7.1.x86_64
     Solution 1: do not install rubygem-vagrant-1.7.2-7.1.x86_64
     Solution 2: break rubygem-vagrant-1.7.2-7.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...
    
    Nothing to do.
    root@thpad  /media/lacie>
    Pulls out remaining hair!

    Any helpful assistance appreciated. Many thanks in advance...

    R.

    Quote Originally Posted by tsu2 View Post
    Create a rails project, invoke the website running on an express server.
    Do you know how to do that? I can post a guide although in the "Install Ruby" on openSUSE link below I simply point to someone else' blog how to do this.

    There are a lot more steps you should run besides what you've described,
    A shortlist of things you probably haven't installed yet
    - A runtime scripting environment
    - Sqlite (for Rails)
    - bundler
    - openssl dev headers

    To install a full Rails environment, you should follow what I posted recently
    https://en.opensuse.org/User:Tsu2/Install_Ruby

    In it I describe various ways to install Ruby, from either the openSUSE repos (like you're doing) or from the official Ruby repos.

    Well, it's actually not that clear what you are doing since without knowing all the steps you've done and by following Miuku's suggestion you may be running a hybrid of Ruby from wherever (since you used the gem command to display your gem version) while also installing rails from the openSUSE repos. Don't know what that would result in, since I've never tried to do what you're doing. If you followed my instructions for installing rails from the Ruby repos, then "gem install rails" would have worked.

    TSU

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,117

    Default Re: Ruby on Rails - installing problem - OpenSUSE 13.2 KDE x64

    Please do not double post.

    Peoplee wanting to join the discussion, ease go to https://forums.opensuse.org/showthre...s-rubygem-quot

    This thread is CLOSED.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •