Results 1 to 4 of 4

Thread: vbox will not start on opensuse 12.3

  1. #1

    Default vbox will not start on opensuse 12.3

    Hello,

    I have vbox 4.2.6-3.6.11 installed on opensuse 12.3 64-bit. When I click on the icon to start it up, the icon bounces around for a while and then goes away. Nothing else happens. If I start vboxgtk from a terminal, I get the following error.

    Code:
    lmh@linux-l2ng:~/RI9_S1v1_INC_64.22_bkey> vboxgtk
    /usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:46:  RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0  was not designed for use with introspection some of the interfaces and  API will fail.  As such this is not supported by the pygobject  development team and we encourage you to port your app to Gtk 3 or  greater. PyGTK is the recomended python module to use with Gtk 2.0
      warnings.warn(warn_msg, RuntimeWarning)
    
    (vboxgtk:4725): Gtk-WARNING **: Unknown property: GtkAboutDialog.license-type
    
    (vboxgtk:4725): GLib-GObject-ERROR **: cannot create instance of abstract (non-instantiatable) type `GtkBox'
    Trace/breakpoint trap
    If virtualbox needs a different python module, why didn't yast take care of that during installation? How do I get this working?

    Thanks,

    LMHmedchem

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,016

    Default AW: vbox will not start on opensuse 12.3

    OpenSUSE 12.3 has reached end-of-life, see your other Thread.

    vboxgtk is not working, install virtualbox-qt

  3. #3

    Default Re: AW: vbox will not start on opensuse 12.3

    Quote Originally Posted by Sauerland View Post
    OpenSUSE 12.3 has reached end-of-life, see your other Thread.

    vboxgtk is not working, install virtualbox-qt
    Thanks, I will look for virtualbox-qt in yast. Should I uninstall vboxgtk first? I have had some issues on linux where uninstalling an application has unforeseen consequences, such as when I tried to uninstall cups and gnome was uninstalled along with it. That was a sub-optimal maneuver on my part.

    LMHmedchem

  4. #4

    Default Re: vbox will not start on opensuse 12.3

    Quote Originally Posted by LMHmedchem View Post
    Thanks, I will look for virtualbox-qt in yast. Should I uninstall vboxgtk first?
    Not really necessary, but as it doesn't work anyway I would uninstall it, yes.
    Btw, if you uninstall it, YaST should select virtualbox-qt automatically for installation.

    I have had some issues on linux where uninstalling an application has unforeseen consequences, such as when I tried to uninstall cups and gnome was uninstalled along with it. That was a sub-optimal maneuver on my part.
    Yes, parts of GNOME require cups.
    But something like that should not happen with vboxgtk.
    And YaST will tell you what changes it would make anyway, you'd still have the chance to abort if stuff gets removed that shouldn't be.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •