Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Reinstalling/Downgrading Packages in YaST, Previous Version not found?

  1. #1

    Default Reinstalling/Downgrading Packages in YaST, Previous Version not found?

    Hello All,

    I want to start by saying this is a slightly older laptop, which is running OpenSuSE 11.4 i586. So I know it's an older/obsolete OS, but for the time being I cannot upgrade the laptop OS.

    So I had been having issues with the Firefox Version I WAS running, which was version --> Firefox-esr 31.5.0-1.1. Where whenever I wanted to confirm a Securtity Exception for a internal site I was going to, nothing would happen if I clicked ok when the Permanently checkbox was checked. If I unchecked it I could then click ok and continue...

    So today I decided to check YaST Software Manager to see if any updates were available for Firefox, and there was. The new Version that was available was 31.7.0-1.2. And I had also seen that just the plain old MozillaFirefox package was available for the same version. So not remembering why I had installed ESR in the first place I decided to update the MozillFirefox package instead of the esr one, which when I click ok to install it it removed esr and install the regular Firefox.

    Also, just before I could upgrade Firefox it said I needed some updated NSS packages. So before I did the Firefox Update, I installed the needed NSS packages, which were ALL in version 3.17.4-1.1. The NSS packages udated to version 3.19.2-1.1. Then, after those completed I ran the actual browser update.

    After I updated all the packages and started up Firefox I attempted to go to an internal https site in my work's network. And when I do I get this error message below and I cannot do anything else...

    Secure Connection Failed

    An error occurred during a connection to 192.168.11.8. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. (Error code: ssl_error_weak_server_ephemeral_dh_key)

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.
    So I Googled that error and found out that it is probably a bug in the NSS versions I installed... So since this is the newest versions I have available in Software Manager my only choice was to dowgrade back to the original versions prior to installing any of the stuff I installed today.

    But, when I check Software Manager those versions are not showing under the Versions section of each package. And I thought I remember if you just right-click on the package and choose Remove that it would reinstall the original version before the most recent update, but when I try to do this to any of the NSS packages I just get a huge LONG list of packages that will break if I continue...

    *SEE ATTACHED SCREENSHOTS... I took screenshots of the Summary of Changes page just before I updated the NSS packages and the Firefox Package. So if you look at those you'll see what was actually updated. The NSS Packages were: libfreebl3, libsoftokn3, mozilla-nss, mozilla-nss-devel, mozilla-nss-certs and mozilla-nss-sysinit.

    So I'm kind of stuck here and don't know what to do now.... Can anyone give me some advice?
    Is there anyway to revert/undo any packages recently installed..?

    Thanks in Advance,
    Matt

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,022

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version not found?

    Switch to Evergreen;
    https://en.opensuse.org/openSUSE:Evergreen

    It's 11.4 with updates - however it'll end this July but you might be able to get updates from there.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version notfound?

    On 2015-06-25 21:56, Miuku wrote:
    >
    > Switch to Evergreen;
    > https://en.opensuse.org/openSUSE:Evergreen
    >
    > It's 11.4 with updates - however it'll end this July but you might be
    > able to get updates from there.


    It ended officially 27 Sep 2014, but even after the announcement they
    continued doing updates.

    By all means, Matt, add the Evergreen update repositories and apply all
    the patches. Don't downgrade anything.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  4. #4

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version not found?

    Hey Miuku and Robin, thanks for the replies, much appreciated!

    Ok cool, I remember "Evergreen" stuff a while ago but didn't know what version it was for... So thanks, Good to know!

    The URL below is the only repo I found in the link you posted on the Evergreen page. Is this the one I would want to use? Also, should I disable any of my old Repos before I try updating any packages?

    This is the Repo I found from the link you posted:
    Is that 2nd URL above the one I want to add to my repos?

    Thanks Again,
    Matt

  5. #5

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version notfound?

    Quote Originally Posted by robin_listas View Post
    On 2015-06-25 21:56, Miuku wrote:
    ........
    By all means, Matt, add the Evergreen update repositories and apply all
    the patches. Don't downgrade anything.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    Hey Carlos,

    I guess it's hard to say for sure, but if I don't downgrade Firefox and the NSS packages back to the version(s) I had, won't it still do the same thing that it's currently doing? It looks like the newest version of Firefox in that Evergreen repo is 31.7.0-140.1...

    Thanks Again,
    Matt

  6. #6

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version not found?

    Duhhhh.... I just realized I forgot to include those screenshots I mentioned in my OP.... They're in this comment below...


    This screenshot contains the Packages I checked off when doing the NSS updates, which was the 1st thing I did:
    This screenshot is the actual Summary of Changes when I clicked apply for the NSS Updates:
    And this last one is the Summary of Changes for the browser:

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version notfound?

    On 2015-06-25 23:26, mmartin0926 wrote:
    >
    > Hey Miuku and Robin, thanks for the replies, much appreciated!
    >
    > Ok cool, I remember -"Evergreen"- stuff a while ago but didn't know what
    > version it was for... So thanks, Good to know!
    >
    > The URL below is the only repo I found in the link you posted on the
    > Also, should I
    > disable any of my old Repos before I try updating any packages?


    No.

    If in doubt, just post your repo list - the output of the command "zypper lr --details", inside a code tags section; the '#' button on the forum editor.

    > *This is the Repo I found from the link you
    > posted:*
    > http://tinyurl.com/d27mz4l
    > *Which contains this URL:*
    > http://tinyurl.com/a8exgah


    Yes.

    just run this command:

    Code:
    sudo zypper ar --refresh -r http://download.opensuse.org/evergreen/11.4/openSUSE:Evergreen:11.4.repo
    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version notfound?

    On 2015-06-25 23:26, mmartin0926 wrote:

    > Hey Carlos,
    >
    > I guess it's hard to say for sure, but if I don't downgrade Firefox and
    > the NSS packages back to the version(s) I had, won't it still do the
    > same thing that it's currently doing? It looks like the newest version
    > of Firefox in that Evergreen repo is 31.7.0-140.1...


    Yes, but it is the long term support version of it. If you look at the
    timestamps, it was updated last May.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  9. #9

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version not found?

    Ok gotcha, thanks Carlos!

    Alright I added the Repo Using your Zypper command and here is the list of Repos that I have after adding that Evergreen repo:
    Code:
    mmartin:/home/mmartin # zypper lr --details
    #  | Alias                            | Name                                                     | Enabled | Refresh | Priority | Type   | URI                                                                                                     | Service
    ---+----------------------------------+----------------------------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------------------------+--------
     1 | New_Mozilla_Repo                 | New Mozilla Repo                                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/                                        |        
     2 | Nvidia                           | Nvidia                                                   | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Kieltux:/nvidia/openSUSE_Evergreen_11.4_standard/       |        
     5 | SUSE_Standard                    | SUSE Standard                                            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/                             |        
     6 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                                               |        
     9 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0                                     | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_DVD+_-RW_TS-U633J_R8706GVB115453,/dev/sr0                   |        
    11 | openSUSE_11.4_Update             | Official released updates for openSUSE 11.4 (standard)   | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.4:/Update/standard/                              |        
    12 | openSUSE_Evergreen_11.4          | Evergreen update repository for openSUSE 11.4 (standard) | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Evergreen:/11.4/standard/                           |        
    13 | repo-debug                       | openSUSE-11.4-Debug                                      | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                                          |        
    14 | repo-debug-update                | openSUSE-11.4-Update-Debug                               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                                                         |        
    15 | repo-non-oss                     | openSUSE-11.4-Non-Oss                                    | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                                            |        
    16 | repo-oss                         | openSUSE-11.4-Oss                                        | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                                                |        
    17 | repo-source                      | openSUSE-11.4-Source                                     | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/                                         |
    Sorry it's a little hard to read, I figured the CODE tags would prevent Word Wrap and add in a horizontal scroll-bar, but I guess not..

    If you go to the 2 Repos labeled, "openSUSE_11.4_Update" and "Updates-for-openSUSE-11.4-11.4-0" in a browser, BOTH redirect you to the same URL, which is --> http://ftp5.gwdg.de/pub/opensuse/dis...d/update/11.4/...

    Thanks Again,
    Matt

  10. #10
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,022

    Default Re: Reinstalling/Downgrading Packages in YaST, Previous Version notfound?

    Quote Originally Posted by robin_listas View Post
    It ended officially 27 Sep 2014, but even after the announcement they
    continued doing updates.
    Ah, then the wiki has it listed wrong - it says July 2015.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •