Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

  1. #1

    Default libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    Dear all,

    I am making an experiment to see whether I will be able to completely ditch windows and use only openSUSE. I have managed so far to resolve some problems but I have some difficulties playing videos with mp4, avi and mpeg extensions. I have googled and came to the conclusion that those are not supported due to some patent issues. Therefore, one has to manage things by installing what is needed. So I did the following:

    Code:
    john@linux-f44g:~/.mozilla/firefox> sudo zypper ar http://download.videolan.org/pub/vlc/SuSE/13.2 videolan
    Adding repository 'videolan' .......................................................................................................................[done]
    john@linux-f44g:~/.mozilla/firefox> sudo zypper mr -r videolan
    Autorefresh has been enabled for repository 'videolan'.
    john@linux-f44g:~/.mozilla/firefox> sudo zypper in vlc
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libgcrypt.so.11()(64bit) needed by vlc-2.2.1-285.26.x86_64
     Solution 1: do not install vlc-2.2.1-285.26.x86_64
     Solution 2: break vlc-2.2.1-285.26.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): c
    Now we come to the problematic point libgcrypt.so.11()(64bit) is missing. To install this I went to

    http://rpmfind.net//linux/RPM/opensu....1.x86_64.html

    I installed something, however the library was still missing. Then I tried to look for this library via zipper

    Code:
    john@linux-f44g:~/.mozilla/firefox> sudo zypper search --installed-only | grep libgcrypt
    i | libgcrypt20                                | The GNU Crypto Library                                                                               | package    
    i | libgcrypt20-32bit                          | The GNU Crypto Library                                                                               | package
    Do I have a conflict, because I have libcrypt20 or something else is wrong? In general, why such a simple thing, which takes 5 second on windows has to be so complicated? Come on guys, an os that can not play video, seriously

    I would appreciate your help.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    On 2015-06-28 13:06, john snow wrote:
    >
    > Dear all,


    You posted twice the same question?


    > I am making an experiment to see whether I will be able to completely
    > ditch windows and use only openSUSE. I have managed so far to resolve
    > some problems but I have some difficulties playing videos with mp4, avi
    > and mpeg extensions. I have googled and came to the conclusion that
    > those are not supported due to some patent issues. Therefore, one has to
    > manage things by installing what is needed. So I did the following:


    There is a sticky at the top of this subforum that explains it all. Just
    follow the guide there.

    You should probably remove the videolan repo.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    [QUOTE=robin_listas;2717200]
    You posted twice the same question?
    [\QUOTE]

    I made a mistake sorry. I was editing the thread, have no idea how this happened.

    [QUOTE=robin_listas;2717200]
    There is a sticky at the top of this subforum that explains it all. Just
    follow the guide there.

    You should probably remove the videolan repo.
    [\QUOTE]

    Could you be more specific? If I removed the vlc repo, wouldn't that jeopardize the installation?

    Quote Originally Posted by robin_listas View Post
    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    Be careful in "Minas Tirith", Frodo Bagins and his buddies might be around!

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,027

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    VLC repo is optional and not recommended anyway only use the packman repo. If you mix packages for a given program from different repos they do not work. ie for vlc get vlc and all related packages from packman only.

    In Yast-Software management you will see a version tab at bottom right. It shows what is installed and what is available from which repo.

  5. #5

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    Hi,

    I removed the vlc repository, but the problem remains. When trying to install vlc from yast I am warned that libgcrypt.so.11()(64bit) is missing. List of my repositories is provided below:

    Code:
    john@linux-f44g:~/.mozilla/firefox> sudo zypper lr
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh
    ---+---------------------------+------------------------------------+---------+-----------+--------
     1 | Packman Repository        | Packman Repository                 | Yes     | (r ) Yes  | Yes    
     2 | SuSE                      | SuSE                               | Yes     | (r ) Yes  | Yes    
     3 | libdvdcss repository      | libdvdcss repository               | Yes     | (r ) Yes  | Yes    
     4 | packman-essentials        | packman-essentials                 | Yes     | (r ) Yes  | Yes    
     5 | packman-multimedia        | packman-multimedia                 | Yes     | (r ) Yes  | Yes    
     6 | repo-debug                | openSUSE-13.2-Debug                | Yes     | (r ) Yes  | Yes    
     7 | repo-debug-update         | openSUSE-13.2-Update-Debug         | Yes     | (r ) Yes  | Yes    
     8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Yes     | (r ) Yes  | Yes    
     9 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | ( p) Yes  | Yes    
    10 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | ( p) Yes  | Yes    
    11 | repo-source               | openSUSE-13.2-Source               | Yes     | (r ) Yes  | Yes    
    12 | repo-update               | openSUSE-13.2-Update               | Yes     | ( p) Yes  | Yes    
    13 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | ( p) Yes  | Yes

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,857
    Blog Entries
    15

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    On Sun 28 Jun 2015 12:36:02 PM CDT, john snow wrote:


    Hi,

    I removed the vlc repository, but the problem remains. When trying to
    install vlc from yast I am warned that libgcrypt.so.11()(64bit) is
    missing. List of my repositories is provided below:

    <snip>
    Hi
    You need to post the output from zypper lr with the -d option, the .11
    version was in 13.1, so one of the repos is the wrong release....

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel
    3.12.43-52.6-default If you find this post helpful and are logged into
    the web interface, please show your appreciation and click on the star
    below... Thanks!


  7. #7

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You need to post the output from zypper lr with the -d option, the .11
    version was in 13.1, so one of the repos is the wrong release....

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel
    3.12.43-52.6-default If you find this post helpful and are logged into
    the web interface, please show your appreciation and click on the star
    below... Thanks!
    Code:
    john@linux-f44g:~/.mozilla/firefox> sudo zypper lr -d
    root's password:
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                             | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------+--------
     1 | Packman Repository        | Packman Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/        |        
     2 | SuSE                      | SuSE                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.videolan.org/SuSE/13.1/                         |        
     3 | libdvdcss repository      | libdvdcss repository               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                            |        
     4 | packman-essentials        | packman-essentials                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Essentials/          |        
     5 | packman-multimedia        | packman-multimedia                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Multimedia/          |        
     6 | repo-debug                | openSUSE-13.2-Debug                | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.2/repo/oss/  |        
     7 | repo-debug-update         | openSUSE-13.2-Update-Debug         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.2/                 |        
     8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/         |        
     9 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/    |        
    10 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/        |        
    11 | repo-source               | openSUSE-13.2-Source               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.2/repo/oss/ |        
    12 | repo-update               | openSUSE-13.2-Update               | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                       |        
    13 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    On 2015-06-28 16:36, john snow wrote:

    Code:
    
    > Code:
    > --------------------
    >     john@linux-f44g:~/.mozilla/firefox> sudo zypper lr -d
    >   root's password:
    >   #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                             | Service
    >   ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------+--------
    >   1 | Packman Repository        | Packman Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/        |
    >   2 | SuSE                      | SuSE                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.videolan.org/SuSE/13.1/                         |
    
    Remove that one, for two reasons: it is videolan, and it is for 13.1.
    
    
    >   4 | packman-essentials        | packman-essentials                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Essentials/          |
    >   5 | packman-multimedia        | packman-multimedia                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Multimedia/          |
    
    Remove these two, they are for 13.1, and they would duplicate the #1 above.
    
    >   6 | repo-debug                | openSUSE-13.2-Debug                | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.2/repo/oss/  |
    >   7 | repo-debug-update         | openSUSE-13.2-Update-Debug         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.2/                 |
    >   8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/         |
    
    Why do you enable debug repos?
    
    >   9 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/    |
    >   10 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/        |
    
    >   11 | repo-source               | openSUSE-13.2-Source               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.2/repo/oss/ |
    
    Why do you enable source repos?
    
    >   12 | repo-update               | openSUSE-13.2-Update               | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                       |
    >   13 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/
    >
    > --------------------

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  9. #9

    Default Re: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    Hi,

    I removed the repositories you instruct me to remove

    Code:
    # | Alias                 | Name                         | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                          | Service
    --+-----------------------+------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------+--------
    1 | Packman Repository    | Packman Repository           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/     |        
    2 | libdvdcss repository  | libdvdcss repository         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                         |        
    3 | openSUSE-13.2-Non-Oss | openSUSE-13.2-Non-Oss        | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |        
    4 | openSUSE-13.2-Oss     | openSUSE-13.2-Oss            | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/     |        
    5 | repo-non-oss          | openSUSE-13.2-Non-Oss        | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |        
    6 | repo-oss              | openSUSE-13.2-Oss            | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/     |        
    7 | repo-update           | openSUSE-13.2-Update         | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                    |        
    8 | repo-update-non-oss   | openSUSE-13.2-Update-Non-Oss | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/
    Then I installed vlc

    Code:
    john@linux-f44g:~> sudo zypper in vlc
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 5 NEW packages are going to be installed:
      libvlc5 libvlccore8 vlc vlc-noX vlc-qt 
    
    5 new packages to install.
    Overall download size: 5.0 MiB. Already cached: 0 B  After the operation, additional 16.1 MiB will be used.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package libvlccore8-2.2.1-285.1.x86_64                                                               (1/5), 415.3 KiB (  1.0 MiB unpacked)
    Retrieving: libvlccore8-2.2.1-285.1.x86_64.rpm ................................................................................................[done]
    Retrieving package libvlc5-2.2.1-285.1.x86_64                                                                   (2/5),  85.4 KiB (131.4 KiB unpacked)
    Retrieving: libvlc5-2.2.1-285.1.x86_64.rpm ....................................................................................................[done]
    Retrieving package vlc-noX-2.2.1-285.1.x86_64                                                                   (3/5),   3.3 MiB ( 11.6 MiB unpacked)
    Retrieving: vlc-noX-2.2.1-285.1.x86_64.rpm ......................................................................................[done (703.9 KiB/s)]
    Retrieving package vlc-qt-2.2.1-285.1.x86_64                                                                    (4/5),   1.0 MiB (  3.0 MiB unpacked)
    Retrieving: vlc-qt-2.2.1-285.1.x86_64.rpm .....................................................................................................[done]
    Retrieving package vlc-2.2.1-285.1.x86_64                                                                       (5/5), 236.0 KiB (398.6 KiB unpacked)
    Retrieving: vlc-2.2.1-285.1.x86_64.rpm ........................................................................................................[done]
    Checking for file conflicts: ..................................................................................................................[done]
    (1/5) Installing: libvlccore8-2.2.1-285.1 .....................................................................................................[done]
    (2/5) Installing: libvlc5-2.2.1-285.1 .........................................................................................................[done]
    (3/5) Installing: vlc-noX-2.2.1-285.1 .........................................................................................................[done]
    (4/5) Installing: vlc-qt-2.2.1-285.1 ..........................................................................................................[done]
    (5/5) Installing: vlc-2.2.1-285.1 .............................................................................................................[done]
    Then I tried to open it and I got the error messages:

    Code:
    john@linux-f44g:~> [00000000009c52d8] core demux error: corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so
    [00000000009030b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [00007f7bac000e68] core demux error: corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so
    [00007f7badf44e18] core decoder error: Codec `h264' (H264 - MPEG-4 AVC (part 10)) is not supported.
    [00007f7badf5b578] core decoder error: Codec `mp4a' (MPEG AAC Audio) is not supported.
    QObject::~QObject: Timers cannot be stopped from another thread
    
    [1]+  Done                    vlc

    Since it was not playing the files I needed I installed the vlc-codecs

    Code:
    john@linux-f44g:~> sudo zypper in vlc-codecs
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      vlc-codecs 
    
    1 new package to install.
    Overall download size: 166.6 KiB. Already cached: 0 B  After the operation, additional 463.3 KiB will be used.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package vlc-codecs-2.2.1-285.1.x86_64                                                                (1/1), 166.6 KiB (463.3 KiB unpacked)
    Retrieving: vlc-codecs-2.2.1-285.1.x86_64.rpm .................................................................................................[done]
    Checking for file conflicts: ..................................................................................................................[done]
    (1/1) Installing: vlc-codecs-2.2.1-285.1 ......................................................................................................[done]
    john@linux-f44g:~> cvlc &
    [1] 2179
    john@linux-f44g:~> VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [00000000012841f8] core demux error: corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so
    [00000000012b49a8] dummy interface: using the dummy interface module...
    As you can see I have the error repeating "corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so".

    I am able to play mp4, which was not playing before but the video runs very slowly. I presume that the "corrupt module" is causing the problems. Have you seen anything like this.

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,015

    Default AW: libgcrypt.so.11()(64bit) mising when installing VLC for 13.2

    Did you switch all packages to the Packman Repo?
    If not and because of former installing from the Videolan-Repo (maybe there are incompatible Packages from Videolan), please do a:
    Code:
    zypper dup --from http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/
    Do it with the URL, because I do not know, if it works with a Name including a space (Packman Repository)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •