Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Yast won't start

  1. #1

    Unhappy Yast won't start

    Hello all,
    I recently updated my openSuse from 13.1 to 13.2 64 bits, had some system update, and suddenly, Yast stopped working.
    I tried to update/reinstall it using zypper, but without any positive result.
    When I launch it, I get the login root dialog, but nothing happens afterwards.
    No trace of yast in the system activity.
    Best regards,
    Jean-Luc

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Yast won't start

    If you try launching it from a terminal, what does it output?

    sudo yast --ncurses

    For example.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: Yast won't start

    Switch to root in a terminal window with "su -" (don't forget the '-'), then run "yast2".
    What output do you get?

    And please also post your repo list:
    Code:
    zypper lr -d

  4. #4

    Default Re: Yast won't start

    Thank you for your help,
    Miuku, I get the command line version of yast.
    Wolfi323, i get this message :
    /sbin/yast2: line 440: 8699 Segmentation fault $y2ccbin $Y2UI_ARGS "$@"

  5. #5

    Default Re: Yast won't start

    Quote Originally Posted by jllprod View Post
    TWolfi323, i get this message :
    /sbin/yast2: line 440: 8699 Segmentation fault $y2ccbin $Y2UI_ARGS "$@"
    Ok, so it is crashing.
    Please post the output of:
    Code:
    sudo tail /var/log/YaST2/y2log
    And your repo list please. As you say this started after some update, it is likely that you have incompatible packages/repos installed.
    Last edited by wolfi323; 23-Jun-2015 at 14:03.

  6. #6

    Default Re: Yast won't start

    Quote Originally Posted by wolfi323 View Post
    Ok, so it is crashing.
    Please post the output of:
    Code:
    sudo tail /var/log/YaST2/y2log
    Here it is :
    Code:
    2015-06-23 22:55:04 <2> linux(8448) [ui-shortcuts] YShortcutManager.cc(checkShortcuts):85 Not enough widgets with valid shortcut characters - no check
    2015-06-23 22:55:08 <1> linux(8448) [ui] YPushButton.cc(setRole):170 Guessing function key F1 for YPushButton "Help" at 0x7f65080060d0 from button role YHelpButton
    2015-06-23 22:55:08 <3> linux(8448) [libycp] clients/menu.rb:212 Unknown option `defaultButton in PushButton widget
    2015-06-23 22:55:08 <1> linux(8448) [ui] YPushButton.cc(setRole):170 Guessing function key F9 for YPushButton "Quit" at 0x7f65080068d0 from button role YCancelButton
    2015-06-23 22:55:26 <1> linux(8448) [ncurses] YNCursesUI.cc(~YNCursesUI):113 Stop YNCursesUI
    2015-06-23 22:55:26 <1> linux(8448) [ncurses] NCurses.cc(~NCurses):145 Shutdown NCurses...
    2015-06-23 22:55:26 <1> linux(8448) [ncurses] NCurses.cc(~NCurses):164 NCurses down
    2015-06-23 22:55:26 <1> linux(8448) [liby2] genericfrontend.cc(main):778 Finished YaST2 component 'y2base'
    2015-06-23 22:55:26 <1> linux(8448) [liby2] genericfrontend.cc(main):783 Exiting with client return value 'nil'
    2015-06-23 22:55:26 <1> linux(8448) [Y2Ruby] binary/YRuby.cc(~YRuby):107 Shutting down ruby interpreter.
    And your repo list please. As you say this started after some update, it is likely that you have incompatible packages/repos installed.
    A stupid question: how do I get the repo list ?
    Best regards,
    JL

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: Yast won't start

    zypper lr -d

    that's it

  8. #8

    Default Re: Yast won't start

    Quote Originally Posted by jllprod View Post
    Here it is :
    Hm, that's from the ncurses version, and doesn't show a problem.
    Can you please run YaST2 (the GUI version) again, and then post the output of "sudo tail /var/log/YaST2/y2log" immediately afterwards?

    And maybe also tell us what graphics card and driver you are using. A problem there might cause Qt5 applications like YaST failing to start.

  9. #9
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: Yast won't start

    what's the output of cmd

    rpm -q yast2

  10. #10

    Default Re: Yast won't start

    Hello all,
    Here is the repo list :
    Code:
    #  | Alias                     | Nom                                     | Activé | Rafraîchir | Priorité | Type   | URI                                                                            | Service
    ---+---------------------------+-----------------------------------------+--------+------------+----------+--------+--------------------------------------------------------------------------------+--------
     1 | AMD-FGLRX                 | AMD-FGLRX                               | Oui    | Oui        |   99     | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2/                          |        
     2 | KDE:Applications          | KDE:Applications                        | Oui    | Oui        |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/     |        
     3 | Packman Repository        | Packman Repository                      | Oui    | Oui        |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                       |        
     4 | home:awissu:NonFree       | home:awissu:NonFree                     | Oui    | Oui        |   99     | rpm-md | http://download.opensuse.org/repositories/home:/awissu:/NonFree/openSUSE_13.2/ |        
     5 | libdvdcss repository      | libdvdcss repository                    | Oui    | Oui        |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                           |        
     6 | multimedia:libs           | multimedia:libs                         | Oui    | Oui        |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_13.2/      |        
     7 | openSUSE-13.2-0           | openSUSE-13.2-0                         | Oui    | Non        |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SH-224BB_R8WS6GBD200HW5     |        
     8 | packman-essentials        | Packman Essentials repository (Factory) | Oui    | Oui        |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_13.2/Essentials/       |        
     9 | repo-debug                | openSUSE-13.2-Debug                     | Non    | Oui        |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                 |        
    10 | repo-debug-update         | openSUSE-13.2-Update-Debug              | Non    | Oui        |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                |        
    11 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss      | Non    | Oui        |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                        |        
    12 | repo-non-oss              | openSUSE-13.2-Non-Oss                   | Oui    | Oui        |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                   |        
    13 | repo-oss                  | openSUSE-13.2-Oss                       | Oui    | Oui        |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                       |        
    14 | repo-source               | openSUSE-13.2-Source                    | Non    | Oui        |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                |        
    15 | repo-update               | openSUSE-13.2-Update                    | Oui    | Oui        |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                      |        
    16 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss            | Oui    | Oui        |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/

    Here is the output of rpm -q yast2 :
    yast2-3.1.109.2-12.1.x86_64

    My graphic card is a AMD Radeon HD 5450 , the driver is the one provided here :
    https://en.opensuse.org/SDB:AMD_fglrx
    in version 15.10.4.

    Thank you for your help !

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •