Results 1 to 10 of 10

Thread: disable touchpad in laptop when plugging usb mouse

  1. #1
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default disable touchpad in laptop when plugging usb mouse

    Hello

    Is there any chance to automatically disable touch-pad in laptop HP 250 G3 when I plug-in a USB mouse?
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,378
    Blog Entries
    1

    Default Re: disable touchpad in laptop when plugging usb mouse

    Quote Originally Posted by GazetaCypr View Post
    Hello

    Is there any chance to automatically disable touch-pad in laptop HP 250 G3 when I plug-in a USB mouse?
    System Settings >> Input Devices >> Touchpad >> Enable/Disable Touchpad >> Check 'Disable touchpad when mouse is plugged in', then 'Apply'

  3. #3
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: disable touchpad in laptop when plugging usb mouse

    Quote Originally Posted by deano_ferrari View Post
    System Settings >> Input Devices >> Touchpad >> Enable/Disable Touchpad >> Check 'Disable touchpad when mouse is plugged in', then 'Apply'
    I do not have this option in my settings.
    There are four tabs in Touchpad configuration: 1. Hardware; 2. Cursor motion; 3. Scrolling; 4. Tapping
    and no option for Enable/Disable Touchpad
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  4. #4
    Join Date
    May 2012
    Location
    Thessaloniki, Greece
    Posts
    114

    Default Re: disable touchpad in laptop when plugging usb mouse

    If you are using KDE, try installing the synaptiks package.

  5. #5
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: disable touchpad in laptop when plugging usb mouse

    Have you tried the cmd synapiks?

  6. #6
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: disable touchpad in laptop when plugging usb mouse

    I became interested in this question/thread as I was unaware there was an easy way to implement.

    I am runing 13.2/KDE, with the synaptiks package installed.
    I do not see the option appearing under System Settings either.

    But following keelambert's suggestion,
    running command synaptiks from a console widow pops up a configuration GUI that provides the desired
    'Disable touchpad when mouse is plugged in' option.

    Thanks for raising the question!
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: disable touchpad in laptop when plugging usb mouse

    When I start synaptiks, in fact there is check box 'disable touchpad' and when I check it, it really switches off touchpad.

    But the problem is when I restart laptop. It does not remember synaptiks settings, so I have to run it again.
    There is an option in synaptiks called 'start up at logon', but then it starts synaptiks gui.
    I'd like to skip that and force computer to remember it.

    thanks anyway
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  8. #8
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: disable touchpad in laptop when plugging usb mouse

    after the cmd synapiks try the command systemsettings (Configure Desktop), then see if the option
    is also available there under -Harware --Input Devices ---Touchpad

  9. #9
    Join Date
    Jun 2015
    Posts
    5

    Default Re: disable touchpad in laptop when plugging usb mouse

    I was thinking more along the lines of something DE/WM-agnostic in the form of system-wide udev rules, but couldn't come up with a working solution, even with the help of this. The only difference I noticed with openSUSE is the Xauthority is stored in /run/user/`id -u`/gdm/ vs /var/run/gdm as with Arch, but trying various things still didn't work, at least with GDM/Gnome. I'm thinking it has something to do with syndaemon (which the arch link suggests may be causing issues), but I didn't have the time to look into it.

  10. #10
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: disable touchpad in laptop when plugging usb mouse

    An update on my experience:
    After running the 'synaptiks' cmd , per keelamberts suggestion, I found the pop-up menu under the System Tray synaptiks icon was modified and provided the "Automatically Turn Off....." option box, as well as deeper options to ignore certain mouse devices.
    Gone was the default menu that allowed manual on/off for the touchpad.

    But, I then found that the 'synaptiks' auto-off did not survive a Sleep-Resume cycle. Aftere Resume, both mouse and synaptiks were active. And, I no longer had the simple Turn Off checkbox under the System Tray.

    Solution: After Resume, unplug, then replug the USB mouse, mouse now works and synaptiks pad is off.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •