Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Update bootloader fails

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Update bootloader fails

    Just did a "zypper up" and got the following error...
    Code:
        Update bootloader...
        Perl-Bootloader: 2015-06-16 18:53:00 <3> pbl-5305.2 Core::RunCommand.1658: Error: '/usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg' failed with exit code 127, output:
        <<<<<<<<<<<<<<<<
        /etc/default/grub: line 12: quiet: command not found
        
        >>>>>>>>>>>>>>>>
    Updating bootloader failed
    Any suggestions?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,873
    Blog Entries
    3

    Default Re: Update bootloader fails

    Looking at that file here, I see that line 12 is:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/nwr2sea/swap splash=silent quiet showopts"
    I would guess that the file has become corrupted -- perhaps it was edited with an editor that wraps long lines.

    Maybe post the first 20 lines of "/etc/default/grub" with code tags. But makes sure that there isn't any private information there that you want to restrict.

    In my case, I suppose that "/dev/nwr2sea/swap" is, technically, private information (the reference to the swap volume of an encrypted LVM), but it doesn't seem to be anything that I should worry about revealing. I'm not seeing anything that raises particular concern in the first 20 lines. (I think the main privacy issue is if you set a password for accessing the grub menu, and I don't do that).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Re: Update bootloader fails

    Quote Originally Posted by nrickert View Post
    Looking at that file here, I see that line 12 is:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/nwr2sea/swap splash=silent quiet showopts"
    I would guess that the file has become corrupted -- perhaps it was edited with an editor that wraps long lines.

    Maybe post the first 20 lines of "/etc/default/grub" with code tags. But makes sure that there isn't any private information there that you want to restrict.

    In my case, I suppose that "/dev/nwr2sea/swap" is, technically, private information (the reference to the swap volume of an encrypted LVM), but it doesn't seem to be anything that I should worry about revealing. I'm not seeing anything that raises particular concern in the first 20 lines. (I think the main privacy issue is if you set a password for accessing the grub menu, and I don't do that).
    As requested...
    Code:
    # cat /etc/default/grub
    # Modified by YaST2. Last modification on Fri May 29 11:19:34 CEST 2015
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader
    
    # If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
    # /boot/grub2/grub.cfg.
    GRUB_DISTRIBUTOR=openSUSE
    GRUB_DEFAULT=saved
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=8
    GRUB_CMDLINE_LINUX_DEFAULT=" " resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts"
    i915.modeset="1 tpm_tis.interrupts=0""
    # kernel command line options for failsafe mode
    GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
    GRUB_CMDLINE_LINUX=""
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM=0x01234567,0xfefefefe,0x89abcdef,0xefefefef
    # Uncomment to disable graphical terminal (grub-pc only)
    GRUB_TERMINAL=gfxterm
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=auto
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY=true
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    # Skip 30_os-prober if you experienced very slow in probing them
    # WARNING foregin OS menu entries will be lost if set true here
    GRUB_DISABLE_OS_PROBER=false
    # Set to 'y' for grub to be installed on an encrypted partition
    GRUB_ENABLE_CRYPTODISK=n
    SUSE_BTRFS_SNAPSHOT_BOOTING=true
    GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png
    GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt

  4. #4
    Join Date
    Jan 2012
    Location
    the 919
    Posts
    38

    Default Re: Update bootloader fails

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" " resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts" i915.modeset="1 tpm_tis.interrupts=0""
    Is there something up with the quotation marks here? Seems like there are too many double-quotes in that line.
    --Ben

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,873
    Blog Entries
    3

    Default Re: Update bootloader fails

    Quote Originally Posted by bigbenaugust View Post
    Is there something up with the quotation marks here? Seems like there are too many double-quotes in that line.
    Yes, exactly. And maybe the line is wrapped, though that might be the copy/paste for posting.

    The messed up quoting is surely the problem.

    Try (for that one line):
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts i915.modeset=1 tpm_tis.interrupts=0"
    And remember that is just one long line
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Re: Update bootloader fails

    I corrected /etc/default/grub so it reads as follows...
    Code:
    cat /etc/default/grub
    # Modified by YaST2. Last modification on Fri May 29 11:19:34 CEST 2015
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader
    
    # If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
    # /boot/grub2/grub.cfg.
    GRUB_DISTRIBUTOR=openSUSE
    GRUB_DEFAULT=saved
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=8
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts"
    i915.modeset="1 tpm_tis.interrupts=0""
    # kernel command line options for failsafe mode
    GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
    GRUB_CMDLINE_LINUX=""
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM=0x01234567,0xfefefefe,0x89abcdef,0xefefefef
    # Uncomment to disable graphical terminal (grub-pc only)
    GRUB_TERMINAL=gfxterm
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command "vbeinfo'
    GRUB_GFXMODE=auto
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY=true
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    # Skip 30_os-prober if you experienced very slow in probing them
    # WARNING foregin OS menu entries will be lost if set true here
    GRUB_DISABLE_OS_PROBER=false
    # Set to 'y' for grub to be installed on an encrypted partition
    GRUB_ENABLE_CRYPTODISK=n
    SUSE_BTRFS_SNAPSHOT_BOOTING=true
    GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png
    GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
    When I execute

    Code:
    # grub2-mkconfig -o /boot/grub2/grub.cfg
     /etc/default/grub: line 32: unexpected EOF while looking for matching `"'
    I don't see the problem especially since line 32 is commented out.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,873
    Blog Entries
    3

    Default Re: Update bootloader fails

    Quote Originally Posted by ionmich View Post
    I don't see the problem especially since line 32 is commented out.
    Is line 32 the last line?

    That's typical of these errors. It's the line where the missing quote was discovered, not where it was caused.

    I'm seeing in your code block:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts"
    i915.modeset="1 tpm_tis.interrupts=0""
    That still looks to me as if it is two lines, but should be one. Try (as a single line)
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts i915.modeset=1 tpm_tis.interrupts=0"
    What editor are you using.

    My guess is that you are using an editor intended for word processing documents, and it is "fixing" your bad grammar, thus breaking the script.

    Try "vi" (steep learning curve), or "nano" (fairly easy), or "joe" (I never tried it, but it is supposed to be okay for these kinds of tasks).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Re: Update bootloader fails

    Quote Originally Posted by nrickert View Post
    Is line 32 the last line?

    That's typical of these errors. It's the line where the missing quote was discovered, not where it was caused.

    I'm seeing in your code block:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts"
    i915.modeset="1 tpm_tis.interrupts=0""
    That still looks to me as if it is two lines, but should be one. Try (as a single line)
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-uuid/40c9d08d-be72-4b80-abb0-b4d42c874871 splash=silent quiet showopts i915.modeset=1 tpm_tis.interrupts=0"
    What editor are you using.

    My guess is that you are using an editor intended for word processing documents, and it is "fixing" your bad grammar, thus breaking the script.

    Try "vi" (steep learning curve), or "nano" (fairly easy), or "joe" (I never tried it, but it is supposed to be okay for these kinds of tasks).
    Joe is what I always use. It always worked in the past. Besides, wouldn't "cat -A" show any illegal characters? I tried that already.

  9. #9
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Re: Update bootloader fails

    By the way this is what "hexedit" shows for the guilty line 32...

    Code:
    000006D8   20 73 74 61  72 74 0A 23  47 52 55 42  5F 49 4E 49  54 5F 54 55  4E 45 3D 22   start.#GRUB_INIT_TUNE="
    000006F0   34 38 30 20  34 34 30 20  31 22 0A 23  20 53 6B 69  70 20 33 30  5F 6F 73 2D  480 440 1".# Skip 30_os-
    I don't see anything odd.

    Sorry I forgot to answer your question, line 32 is NOT the last line.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Update bootloader fails

    On 2015-06-17 15:46, ionmich wrote:

    > Joe is what I always use. It always worked in the past.


    And it does, but by default it wraps lines. You have to toggle this
    behaviour.

    If you use "joe" in the "jstar" flavour, you type "ctrl-o", to reach the
    options, then "W" (W Word wrap ON) to set it off.

    > Besides,
    > wouldn't "cat -A" show any illegal characters? I tried that already.


    But it wraps.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •