Results 1 to 6 of 6

Thread: How to reverse-engineer a keyboard sequence?

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default How to reverse-engineer a keyboard sequence?

    OpenSUSE 13.2/KDE 4.14.8 with fglrx graphics

    n attempting to toggle Compositing (Desktop Effects) from the keyboard, I entered the combination ctl+alt+F12 by mistake and crashed my system.

    Alt+shift+F12 does work as intended.

    If possible, I would like to decouple alt+ctl+F12 from whatever it is doing/starting.

    I don't see that combination in systemSettings-ShortcutsandGestures.
    Is there somewhere else to look?
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: How to reverse-engineer a keyboard sequence?

    ctrl-alt-F12 changes to an apparent uninitiated terminal thus the blank screen ctrl-alt-F7 should bring you back to the GUI

  3. #3

    Default AW: How to reverse-engineer a keyboard sequence?

    Quote Originally Posted by cmcgrath5035 View Post
    If possible, I would like to decouple alt+ctl+F12 from whatever it is doing/starting.
    Add the this to your xorg.conf, in the "ServerFlags" section:
    Code:
    Option "DontVTSwitch"  "true"
    From "man xorg.conf":
    Code:
           Option "DontVTSwitch"  "boolean"
                  This disallows the use of the  Ctrl+Alt+Fn  sequence  (where  Fn
                  refers  to one of the numbered function keys).  That sequence is
                  normally used to switch to another "virtual terminal" on operat-
                  ing  systems  that  have  this  feature.   When  this  option is
                  enabled, that key sequence has no special meaning and is  passed
                  to clients.  Default: off.
    As you probably don't have an xorg.conf, better create a file in /etc/X11/xorg.conf.d/ named 10-myserverflags.conf (the exact name doesn't matter, but it should end in .conf) with this content:
    Code:
    Section "ServerFlags"
      Option "DontVTSwitch"  "true"
    EndSection
    As gogalthorp already indicated, you didn't "crash" your system. You just switched to console#12 (also called "virtual terminal #12" or "VT12"). You can switch back to the graphical system (which normally runs on console#7) with Ctrl+Alt+F7, or to a text mode console via Ctrl+Alt+F1 to Ctrl+Alt+F6.
    Last edited by wolfi323; 16-Jun-2015 at 09:09.

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: How to reverse-engineer a keyboard sequence?

    Ah so, a couple other things are starting to make sense.

    Again, my system is 13.2/KDE 4.14.8 +fglrx.

    IF I have Desktop Effects enabled (Compositing), then alt+ctl+F12 does in fact go to neverland and will not return to F7 or F1.

    IF I toggle compositing off, it works as you describe.

    I have also determined that this system will not Sleep (STR) if Desktop Effects are enabled.
    Seems likely an fglrx issue, based on other discussions.

    I do have an /etc/X11/xorg.conf, but it has no Server Flags section.

    I now, more or less, know what is happening and how to avoid it; thanks
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  5. #5

    Default Re: How to reverse-engineer a keyboard sequence?

    Quote Originally Posted by cmcgrath5035 View Post
    IF I have Desktop Effects enabled (Compositing), then alt+ctl+F12 does in fact go to neverland and will not return to F7 or F1.

    IF I toggle compositing off, it works as you describe.

    I have also determined that this system will not Sleep (STR) if Desktop Effects are enabled.
    Seems likely an fglrx issue, based on other discussions.
    Yeah, sounds like a graphics driver issue.
    Have you updated to the latest fglrx version yet?
    https://forums.opensuse.org/showthre...t-is-available
    Will take a while until it's in the "official" repos, but not too long I suppose.

    I do have an /etc/X11/xorg.conf, but it has no Server Flags section.
    You could add it, if you wanted to disable those keyboard shortcuts.
    Basically, just add the 3 lines I posted (as 10-myserverflags.conf) to the existing xorg.conf.

    If you're in doubt, please ask, and probably post the whole xorg.conf so I could tell you what changes are needed in particular.
    Last edited by wolfi323; 16-Jun-2015 at 10:01.

  6. #6
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: How to reverse-engineer a keyboard sequence?

    Nope, I had not seen the 15-5 post , may give it a go.

    I understand the Xorg tweak, but am good with vt switching so don't want to disable.
    I just need to be more careful with the keyboard
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •