Results 1 to 7 of 7

Thread: pac-manager failed dependencies on OpenSuse 13.2

  1. #1

    Angry pac-manager failed dependencies on OpenSuse 13.2

    Hello,

    I want to install package "pac-manager" from https://software.opensuse.org/packag...rm=pac-manager. I can't install because of failed dependencies - can't install libvte.so.9.

    This is zypper output:
    Code:
    jakub@jd-lifebook:~/Stažené> sudo zypper in pac-manager-4.5.5-12.1.x86_64.rpm 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: pac-manager-4.5.5-12.1.x86_64 requires libvte.so.9, but this requirement cannot be provided
      uninstallable providers: libvte9-0.28.2-18.1.4.i586[repo-oss]
     Solution 1: do not install pac-manager-4.5.5-12.1.x86_64
     Solution 2: do not install pac-manager-4.5.5-12.1.x86_64
     Solution 3: break pac-manager-4.5.5-12.1.x86_64 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/3/c] (c):
    If I install libvte9 package, it doesn't help.

    Please, help me, many thanks!

  2. #2

    Default Re: pac-manager failed dependencies on OpenSuse 13.2

    Quote Originally Posted by jakubd View Post
    I want to install package "pac-manager" from https://software.opensuse.org/packag...rm=pac-manager. I can't install because of failed dependencies - can't install libvte.so.9.
    libvte9 is included in the standard 13.2 repo:
    Code:
    wolfi@amiga:~> zypper se -s libvte9Loading repository data...
    Reading installed packages...
    
    
    S | Name              | Type    | Version       | Arch   | Repository         
    --+-------------------+---------+---------------+--------+--------------------
    i | libvte9           | package | 0.28.2-18.1.4 | x86_64 | openSUSE-13.2-1.28 
    v | libvte9           | package | 0.28.2-18.1.4 | i586   | openSUSE-13.2-1.28 
    wolfi@amiga:~>
    I find it a bit strange that your zypper output only mentions the 32bit (i586) version.
    Are you using a 32bit or 64bit system?
    Code:
    uname -a
    And please post your repo list as well:
    Code:
    zypper lr -d
    Although I have a suspicion what the problem might be. According to https://build.opensuse.org/package/b...=openSUSE_13.2 it requires libvte.so.9 (which isn't provided by any package) in addition to the correct libvte.so.9()(64bit).

    As you have installed libvte9 now anyway, try to ignore the conflict (Solution 3: break pac-manager-4.5.5-12.1.x86_64 by ignoring some of its dependencies). It should work anyway.

  3. #3

    Default Re: pac-manager failed dependencies on OpenSuse 13.2

    Thanks for reply. I'm using 64-bit system.

    Code:
    jakub@jd-lifebook:/> uname -a
    Linux jd-lifebook.suse 3.16.7-21-desktop #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    jakub@jd-lifebook:/> sudo zypper lr -d
    #  | Alias                                        | Name                                         | Enabled | Refresh | Priority | Type   | URI                                                                                                        | Service
    ---+----------------------------------------------+----------------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------------------------------+--------
     1 | devel:languages:perl                         | devel:languages:perl                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_13.2/                            |        
     2 | home:emendonca:branches:devel:languages:perl | home:emendonca:branches:devel:languages:perl | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/emendonca:/branches:/devel:/languages:/perl/openSUSE_13.2/ |        
     3 | home:scalpel4k                               | home:scalpel4k                               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/scalpel4k/openSUSE_13.2/                                   |        
     4 | openSUSE-13.2-0                              | openSUSE-13.2-0                              | No      | No      |   99     | yast2  | hd:///?device=/dev/disk/by-id/scsi-1Sony_Storage_Media-part2                                               |        
     5 | repo-debug                                   | openSUSE-13.2-Debug                          | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                                             |        
     6 | repo-debug-update                            | openSUSE-13.2-Update-Debug                   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                                            |        
     7 | repo-debug-update-non-oss                    | openSUSE-13.2-Update-Debug-Non-Oss           | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                                                    |        
     8 | repo-non-oss                                 | openSUSE-13.2-Non-Oss                        | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                                               |        
     9 | repo-oss                                     | openSUSE-13.2-Oss                            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                                                   |        
    10 | repo-source                                  | openSUSE-13.2-Source                         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                                            |        
    11 | repo-update                                  | openSUSE-13.2-Update                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                                                  |        
    12 | repo-update-non-oss                          | openSUSE-13.2-Update-Non-Oss                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/
    When I install libvte9 and ignore dependency error, it installs pac-manager, but when I start pac-manager, it only displays "Segmentation fault". When I install libvte9.i586, zypper shows me dependency error, that I'm missing libvte.so.9()(64bit).

  4. #4

    Default Re: pac-manager failed dependencies on OpenSuse 13.2

    Quote Originally Posted by jakubd View Post
    When I install libvte9 and ignore dependency error, it installs pac-manager, but when I start pac-manager, it only displays "Segmentation fault".
    Well, this is probably not related to libvte9 then. Or maybe it is, but it's definitely unrelated to ignoring the dependency error.

    When I install libvte9.i586, zypper shows me dependency error, that I'm missing libvte.so.9()(64bit).
    Yes, the i586 version replaces the 64bit version, but you need the latter.
    If you wanted to install the 32bit version as well, you'd need to install libvte9-32bit instead but that doesn't exist.

    I'll give it a try myself, maybe I can find out why it segfaults. I didn't install it earlier because I miss many needed perl packages as well.

  5. #5

    Default Re: pac-manager failed dependencies on OpenSuse 13.2

    I installed it now, and it is indeed segfaulting. I had to install some additional perl packages first though, that are not listed as dependencies.
    Removing /lib64/libtinfo.so.5 fixes the segfault and makes it start fine. But this of course breaks other stuff, like zypper even.

    Somewhere in the back of my head I do remember reading about problems with libvte9 in 13.2 shortly before the release. But I don't remember details.

  6. #6

    Default Re: pac-manager failed dependencies on OpenSuse 13.2

    Quote Originally Posted by wolfi323 View Post
    I installed it now, and it is indeed segfaulting. I had to install some additional perl packages first though, that are not listed as dependencies.
    Removing /lib64/libtinfo.so.5 fixes the segfault and makes it start fine. But this of course breaks other stuff, like zypper even.

    Somewhere in the back of my head I do remember reading about problems with libvte9 in 13.2 shortly before the release. But I don't remember details.
    I installed OpenSuse 13.2 on my laptop few months ago and I solved this dependency error, and pac-manager started, but now I can't remember, how Segmentation fault is totally caused by this dependency error.

  7. #7

    Default Re: pac-manager failed dependencies on OpenSuse 13.2

    I finally solved this problem. First I removed all libvte* packages from my system, then downloaded latest stable *.rpm file from SourceForge - http://sourceforge.net/projects/pacm...files/pac-4.0/. Installation shows error for uninstallable dependencies - ftp ... I skipped this error by selecting "break conflict" and installed pac. Then pac needed to install package perl-Gnome2-Vte.

    Now it's working :-) Thanks for helping

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •