Results 1 to 5 of 5

Thread: Evolution 3.6.4-1.7.1.x86_64 SSL-problem on openSUSE-12.3

  1. #1
    Join Date
    Jul 2010
    Location
    Stockholm, Sweden
    Posts
    85

    Default Evolution 3.6.4-1.7.1.x86_64 SSL-problem on openSUSE-12.3

    I've been using Evolution since 2005, since 2011-2012 using SSL-connection to my ISP's mailserver without any problem.
    I use pop3 port: 995 for fetching and smtp port: 465 for sending. SSL on a dedicated port.
    In march-april this year (2015) I suddenly could no longer connect with SSL to the same mailservers.
    Evolution reports:
    pop: "could not connect to pop.bredband.net: Peer reports incompatible or unsupported protocol version."
    smtp: "could not connect smtp.bredband.net: Peer reports incompatible or unsupported protocol version."


    I immediately contacted my ISP and asked if they had made any changes in protocol, port or connection which they denied.
    They anyway registered an issue, but hasn't got back to me since then.
    [Generally concerning my ISP I can say that it is one of the largest and oldest ISP's in Sweden,
    but since 3 years they've got repeated problem with their mail-servers. Either webmail or mail-clients or both.
    Generally calling the errors "improvements". My trust in their reports has decreased considerably during these years.]


    I haven't had time to look into the problem until now.
    Searched the application forums if someone had expected the same problems without any result.


    In Yast I could see that my current evolution was built 2013-05-28 and installed 2013-06-05
    As far as I could see the problem was not related to any upgrade.
    I anyway tried to downgrade to the original 3.6.3-1.2.1.x86_64 from OSS without any change to the error.


    As information I have no problem with SSL-connection to my ISP's mail using Mail in a very old iPhone (iOS 4.2.1).


    I'm sorry to ask this question concerning an outdated openSUSE version but hope you can give me any suggestion anyway!
    I've got both openSUSE 13.1 and 13.2 installed but use them for other purposes. 12.3 is my wellconfigured daily
    working OS (with many home-builds that I could not bare to build and configure again).
    So please do not simply suggest any openSUSE-upgrades!

    Best regards
    Lars

  2. #2
    Join Date
    Jul 2010
    Location
    Stockholm, Sweden
    Posts
    85

    Default Re: Evolution 3.6.4-1.7.1.x86_64 SSL-problem on openSUSE-12.3

    Can add that I tried SSL-connecting with imap+ (Port: 993) just to get the same error:
    "could not connect to imap.bredband.net: Peer reports incompatible or unsupported protocol version."

    Uncrypted connection to pop3, imap+ and smtp works all the time.
    -Have tried deleting my account and set it up again without any change to the error reported.

    Somewhere I read a suggestion to delete the whole ~.config/evolution directory, but hesitate since I found that this directory also contains information about my mail directories (you see I've sorted my incoming outgoing mails in a quite intricate directory tree of subjects that I will not risk to mess up).

    Have considered to upgrade Evolution to 3.10 from the 13.1 repo, but can read the problem reports concerning also higher versions of Evolution in this forum, even if the problems are of another kind. This makes me hesitate.

    Summary: The problems I've met in Evolution 3.6.4 (for the first time since 2011) that it is impossible to use SSL conecting to the pop/imap/smtp servers at my ISP:
    "could not connect to pop/imap/smtp.bredband.net: Peer reports incompatible or unsupported protocol version."



  3. #3
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Evolution 3.6.4-1.7.1.x86_64 SSL-problem on openSUSE-12.3

    I assume Evolution tries to connect to the IMAP server via SSL only and your ISP/Mail provider has disabled SSLv3 due to POODLE.

    Does Evolution support STARTTLS in the configuration? (TLSv1+)
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  4. #4
    Join Date
    Jul 2010
    Location
    Stockholm, Sweden
    Posts
    85

    Default Re: Evolution 3.6.4-1.7.1.x86_64 SSL-problem on openSUSE-12.3

    Thank you Miuku!

    I assume Evolution tries to connect to the IMAP server via SSL only and your ISP/Mail provider has disabled SSLv3 due to POODLE.
    Well, they claimed they hadn't changed a thing this spring or last autumn (but concerning CVE's, at least heartbleed and the router/bash-vulnerabilities, they never revealed anything but mumbling).

    Does Evolution support STARTTLS in the configuration? (TLSv1+)
    Yes it does! But I couldn't figure out what it really meant?
    In the description it looks as if it runs the authentication unencrypted and then -after connection- uses TLS?
    Therefore I haven't tried it yet.
    Do you know how StartTLS works?

  5. #5
    Join Date
    Jul 2010
    Location
    Stockholm, Sweden
    Posts
    85

    Default Re: Evolution 3.6.4-1.7.1.x86_64 SSL-problem on openSUSE-12.3

    In addition:
    I contacted my ISP again tonight and explicitly asked about SSL v3: They claim their mailserver does not block it (though the CVE)

    Also tried connecting with StartTLS in Evolution just to find that the three mailservers (pop/imap/smtp) doesn't support STLS. Another kind of error msg than the SSL "incompatible or unsupported protocol version."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •