Results 1 to 9 of 9

Thread: I cannot reach official repositories and other repoistories... T^T

  1. #1
    Join Date
    Jun 2014
    Location
    China
    Posts
    35

    Default I cannot reach official repositories and other repoistories... T^T

    http://oi60.tinypic.com/2cf2kgh.jpg

    http://oi61.tinypic.com/2w3w5ew.jpg

    http://oi57.tinypic.com/205y1aw.jpg

    For some information, Please look at two photos above.




    Beside:


    linux-kc7m:~ # uname -a
    Linux linux-kc7m.site 3.16.7-21-desktop #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) x86_64 x86_64 x86_64 GNU/Linux


    I run: zypper ve
    result in timeout...


    Again: zypper lu
    result in timeout...

    But why? Can anyone help me?
    When you get into trouble, settle down and think.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I cannot reach official repositories and other repoistories...T^T

    On 2015-06-13 02:56, snowsun wrote:

    > But why? Can anyone help me?


    It appears you have set up a proxy. You have to prove that you have
    connectivity using it to the repository, which seems to be
    http://ftp.twaren.net/Linux/OpenSuSE/

    Also it seems that you have a lot of repositories installed, so we can
    guess that it worked previously. Is that soe? Something changed, and what?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Jun 2014
    Location
    China
    Posts
    35

    Default Re: I cannot reach official repositories and other repoistories...T^T

    Quote Originally Posted by robin_listas View Post
    On 2015-06-13 02:56, snowsun wrote:

    > But why? Can anyone help me?


    It appears you have set up a proxy. You have to prove that you have
    connectivity using it to the repository, which seems to be
    http://ftp.twaren.net/Linux/OpenSuSE/

    Also it seems that you have a lot of repositories installed, so we can
    guess that it worked previously. Is that soe? Something changed, and what?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    As you can see, I have set up a proxy and the official repositories worked three days before at school. Now I come home and use wireless network at home. It does not work...

    The other repositories such as http://ftp.twaren.net/Linux/OpenSuSE/ are I added yesterday when the official repositories did not work. However, it does not work either. By the way, I paste the URL into web browser and I have access to it.

    And I did not change anything after I got home.

    Can you tell me how to solve it or what is the problem?

    Thank you very much!!
    When you get into trouble, settle down and think.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I cannot reach official repositories and other repoistories...T^T

    On 2015-06-13 04:56, snowsun wrote:

    >
    > As you can see, I have set up a proxy and the official repositories
    > worked three days before at school. Now I come home and use wireless
    > network at home. It does not work...


    Well, obviously. It is trying to go via the proxy, which does not exist...

    > By the way, I paste the URL into web browser
    > and I have access to it.


    Obviously :-)

    Browsers use their own proxy config.


    > And I did not change anything after I got home.


    /That/ is the problem.


    > Can you tell me how to solve it or what is the problem?


    Disable proxy.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #5
    Join Date
    Jun 2014
    Location
    China
    Posts
    35

    Default Re: I cannot reach official repositories and other repoistories...T^T

    Well, obviously. It is trying to go via the proxy, which does not exist...


    But the proxy does exist and I can not watch video on YouTube without it. (I am in China. ;-))


    Browsers use their own proxy config.
    I use Opera and set the proxy, I find that it use the same settings as the system proxy.

    Disable proxy.
    I tried but the same problem remains. ;(
    And I reboot, same...
    When you get into trouble, settle down and think.

  6. #6
    Join Date
    Jun 2014
    Location
    China
    Posts
    35

    Default Re: I cannot reach official repositories and other repoistories...T^T

    By the way, I have Kali Linux on my computer and uses the same proxy, it works well and I can run apt-get update... (Though I love openSUSE more =.=)
    When you get into trouble, settle down and think.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I cannot reach official repositories and other repoistories...T^T

    On 2015-06-14 02:06, snowsun wrote:
    >
    >> Well, obviously. It is trying to go via the proxy, which does not
    >> exist...
    >>

    >
    > But the proxy does exist and I can not watch video on YouTube without
    > it. (I am in China. ;-))


    Huh. And you have the same proxy in school as in home? I'm afraid that I
    don't understand that type of setup. Maybe somebody else knows?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8
    Join Date
    Jun 2014
    Location
    China
    Posts
    35

    Default Re: I cannot reach official repositories and other repoistories...T^T

    Huh. And you have the same proxy in school as in home? I'm afraid that I
    don't understand that type of setup. Maybe somebody else knows?
    Just enter the address in the proxy setting: Use proxy auto configuration URL

    I use the same proxy in school as at home.
    When you get into trouble, settle down and think.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I cannot reach official repositories and other repoistories...T^T

    On 2015-06-14 02:36, snowsun wrote:

    > I use the same proxy in school as at home.


    Astonishing.


    Well... have a look at zypper logs (/var/log/zypper.log).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •