Results 1 to 7 of 7

Thread: KDE 4.14 Desktop Freezes

  1. #1
    Join Date
    Jan 2009
    Location
    Orlando, FL
    Posts
    172

    Default KDE 4.14 Desktop Freezes

    After an update through YaST last evening, when I rebooted this morning, the KDE Desktop freezes after it comes up. Kontact comes up with mail and is operational. I can use ALT-F2 and run any program fine, but neither the tool bar or desktop icons respond. The command Top shows kwin and plasma-desktop pegged at the top with 100% usage each.

    I created a new user and logged in successfully and the desktop and windows work normally. I went to /home/<my user name> and did a mv .kde .kde.org and mv .kde4 .kde4 and then logged in with my own ID again, and the desktop worked fine, albeit missing all my settings and desktop backgrounds, etc.

    How can I tell which component of my desktop is now causing the hang? Is there a way? It's a PIA to reset everything again and hoping there's a better way.

    Thanks in advance.
    Desktop - Custom Build | Intel i7-950 | Asus P6X58D Premium MB | openSUSE 13.2 X86_64 | 12GB Ram | NVidia GTX580 | KDE 4.14.8

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: KDE 4.14 Desktop Freezes

    On 2015-06-11 17:26, DMCorsa wrote:
    >
    > After an update through YaST last evening, when I rebooted this morning,


    What openSUSE release?

    What repos?

    Run this in a terminal and post the results here, inside a code tags
    section (the '#' button in the forum editor).

    Code:
    cat /etc/os-release
    su -
    zypper lr --details
    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Jan 2009
    Location
    Orlando, FL
    Posts
    172

    Default Re: KDE 4.14 Desktop Freezes

    Quote Originally Posted by robin_listas View Post
    On 2015-06-11 17:26, DMCorsa wrote:
    >
    > After an update through YaST last evening, when I rebooted this morning,


    What openSUSE release?

    What repos?

    Run this in a terminal and post the results here, inside a code tags
    section (the '#' button in the forum editor).

    Code:
    cat /etc/os-release
    su -
    zypper lr --details
    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    I also discovered that YaST will not start in graphical mode any longer. Here is the output you requested.

    Code:
    dmc55@linux-DMCDesk:~> cat /etc/os-release
    NAME=openSUSE
    VERSION="13.2 (Harlequin)"
    VERSION_ID="13.2"
    PRETTY_NAME="openSUSE 13.2 (Harlequin) (x86_64)"
    ID=opensuse
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:opensuse:13.2"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://opensuse.org/"
    ID_LIKE="suse"
    dmc55@linux-DMCDesk:~> 
    
    inux-DMCDesk:~ # zypper lr --details
    #  | Alias                              | Name                                  | Enabled | Refresh | Priority | Type     | URI                                                                       | Service
    ---+------------------------------------+---------------------------------------+---------+---------+----------+----------+---------------------------------------------------------------------------+--------
     1 | KDE_Frameworks_5_Repository        | KDE Frameworks 5 Repository           | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/ |        
     2 | KDE_Qt5_Repository                 | KDE Qt5 Repository                    | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/         |        
     3 | Local_RPMS                         | Local RPMS                            | Yes     | Yes     |   99     | plaindir | dir:///data/App_Software/InstalledRPMS                                    |        
     4 | OpenSuse_13.2_Printing_Repository  | OpenSuse 13.2 Printing Repository     | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/Printing/openSUSE_13.2/         |        
     5 | Wine_Repository                    | Wine Repository                       | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_13.2/  |        
     6 | download.nvidia.com-opensuse       | nVidia Graphics Drivers               | Yes     | Yes     |   99     | rpm-md   | http://download.nvidia.com/opensuse/13.2/                                 |        
     7 | download.opensuse.org-13.2-non-oss | Update Repository (Non-Oss)           | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/13.2-non-oss/                         |        
     8 | download.opensuse.org-4.3          | openSUSE BuildService - LibreOffice   | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/LibreOffice:/4.3/openSUSE_13.2/ |        
     9 | download.opensuse.org-Extra        | openSUSE BuildService - KDE:Extra     | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/       |        
    10 | download.opensuse.org-games        | openSUSE BuildService - Games         | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/games/openSUSE_13.2/            |        
    11 | download.opensuse.org-mozilla      | openSUSE BuildService - Mozilla       | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/mozilla/openSUSE_13.2/          |        
    12 | download.opensuse.org-non-oss      | Main Repository (NON-OSS)             | Yes     | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/13.2/repo/non-oss/              |        
    13 | download.opensuse.org-oss          | Main Repository (OSS)                 | Yes     | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/13.2/repo/oss/                  |        
    14 | download.opensuse.org-oss_1        | Main Repository (Sources)             | Yes     | Yes     |   99     | yast2    | http://download.opensuse.org/source/distribution/13.2/repo/oss/           |        
    15 | download.opensuse.org-packages     | openSUSE BuildService - Java:packages | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/Java:/packages/openSUSE_13.2/   |        
    16 | download.opensuse.org-php          | openSUSE BuildService - PHP           | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/server:/php/openSUSE_13.2/      |        
    17 | download.opensuse.org-update       | Main Update Repository                | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/13.2/                                 |        
    18 | ftp.gwdg.de-suse                   | Packman Repository                    | Yes     | Yes     |   99     | rpm-md   | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                  |        
    19 | google-chrome                      | google-chrome                         | No      | No      |   99     | rpm-md   | http://dl.google.com/linux/chrome/rpm/stable/x86_64                       |        
    20 | google-earth                       | google-earth                          | Yes     | Yes     |   99     | rpm-md   | http://dl.google.com/linux/earth/rpm/stable/x86_64                        |        
    21 | google-musicmanager                | google-musicmanager                   | Yes     | Yes     |   99     | rpm-md   | http://dl.google.com/linux/musicmanager/rpm/stable/x86_64                 |        
    22 | google-talkplugin                  | google-talkplugin                     | Yes     | Yes     |   99     | rpm-md   | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                   |        
    23 | google-webdesigner                 | google-webdesigner                    | Yes     | Yes     |   99     | rpm-md   | http://dl.google.com/linux/webdesigner/rpm/stable/x86_64                  |        
    24 | openSUSE-13.2-0                    | openSUSE-13.2-0                       | No      | No      |   99     | yast2    | cd:///?devices=/dev/disk/by-id/ata-HP_BD_Combo_240d_3782508008_226040500  |        
    25 | opensuse-guide.org-repo            | libdvdcss repository                  | Yes     | Yes     |   99     | rpm-md   | http://opensuse-guide.org/repo/13.2/                                      |        
    26 | repo-debug                         | openSUSE-13.2-Debug                   | No      | Yes     |   99     | NONE     | http://download.opensuse.org/debug/distribution/13.2/repo/oss/            |        
    27 | repo-debug-update                  | openSUSE-13.2-Update-Debug            | No      | Yes     |   99     | NONE     | http://download.opensuse.org/debug/update/13.2/                           |        
    28 | repo-debug-update-non-oss          | openSUSE-13.2-Update-Debug-Non-Oss    | No      | Yes     |   99     | NONE     | http://download.opensuse.org/debug/update/13.2-non-oss/                   |
    Desktop - Custom Build | Intel i7-950 | Asus P6X58D Premium MB | openSUSE 13.2 X86_64 | 12GB Ram | NVidia GTX580 | KDE 4.14.8

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: KDE 4.14 Desktop Freezes

    On 2015-06-11 18:56, DMCorsa wrote:

    >
    > I also discovered that YaST will not start in graphical mode any longer.
    > Here is the output you requested.


    Ugh... I don't know how to solve this :-(

    The problem, I guess, is that you have an incompatible mixture of kde
    packages, qt5 perhaps.

    Me, I don't like to install such new stuff, so I don't know how to solve
    this, except by reverting to older versions.

    Wait till other people, more experienced in KDE and qt5, come by.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #5

    Default Re: KDE 4.14 Desktop Freezes

    Quote Originally Posted by robin_listas View Post
    On 2015-06-11 18:56, DMCorsa wrote:

    >
    > I also discovered that YaST will not start in graphical mode any longer.
    > Here is the output you requested.


    Ugh... I don't know how to solve this :-(

    The problem, I guess, is that you have an incompatible mixture of kde
    packages, qt5 perhaps.
    This would be one possible reason for the problem with YaST not starting, yes.
    But it wouldn't explain the original problem with KDE4...
    I'd rather suspect graphics driver issues therefore.

    I see you added the nvidia repo, so you probably have the nvidia driver installed.
    But is it working?
    Please post the content of /var/log/Xorg.0.log (upload to a sharing/pasting site like http://susepaste.org and post a link).
    And please install Mesa-demo-x if it's not installed and post the output of:
    Code:
    glxinfo | grep render
    To rule out incompatible Qt5 packages, run this:
    Code:
    sudo zypper dup --from 1 --from 2
    PS: ~/.kde contains KDE3's settings and stuff. It has no influence whatsoever on KDE4, so no point in removing that to get KDE4 working...

    And one question: why do you even have the KDE:Frameworks5 and KDE:Qt5 repositories, if you use KDE4 anyway?
    Last edited by wolfi323; 12-Jun-2015 at 00:08.

  6. #6
    Join Date
    Jan 2009
    Location
    Orlando, FL
    Posts
    172

    Default Re: KDE 4.14 Desktop Freezes

    Quote Originally Posted by wolfi323 View Post
    This would be one possible reason for the problem with YaST not starting, yes.
    But it wouldn't explain the original problem with KDE4...
    I'd rather suspect graphics driver issues therefore.

    I see you added the nvidia repo, so you probably have the nvidia driver installed.
    But is it working?
    Please post the content of /var/log/Xorg.0.log (upload to a sharing/pasting site like http://susepaste.org and post a link).
    And please install Mesa-demo-x if it's not installed and post the output of:
    Code:
    glxinfo | grep render
    To rule out incompatible Qt5 packages, run this:
    Code:
    sudo zypper dup --from 1 --from 2
    PS: ~/.kde contains KDE3's settings and stuff. It has no influence whatsoever on KDE4, so no point in removing that to get KDE4 working...

    And one question: why do you even have the KDE:Frameworks5 and KDE:Qt5 repositories, if you use KDE4 anyway?
    After clearing the .kde4 and starting from scratch YaST does indeed run.

    Here is the glxinfo output:
    Code:
    dmc55@linux-DMCDesk:~> glxinfo | grep renderdirect rendering: Yes
    OpenGL renderer string: GeForce GTX 580/PCIe/SSE2
        GL_KHR_debug, GL_KTX_buffer_region, GL_NVX_conditional_render, 
        GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
        GL_KHR_debug, GL_KTX_buffer_region, GL_NVX_conditional_render, 
        GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
        GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

    Here is the zypper output:
    Code:
     dmc55@linux-DMCDesk:~> sudo zypper dup --from 1 --from 2root's password:
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    
    The following 6 NEW packages are going to be installed:
      kactivities5 kactivities5-imports libKF5Activities5 libKF5Activities5-lang libQt5Sql5 
      libQt5Sql5-sqlite 
    
    
    The following package is going to be REMOVED:
      kactivities4 
    
    
    The following 34 packages are going to be upgraded:
      cmake kconf_update5 kcoreaddons kcoreaddons-lang kimageformats libKF5Archive5 
      libKF5Attica5 libKF5Codecs5 libKF5Codecs5-lang libKF5ConfigCore5 libKF5ConfigCore5-lang 
      libKF5ConfigGui5 libKF5CoreAddons5 libKF5DBusAddons5 libKF5DNSSD5 libKF5GlobalAccel5 
      libKF5GuiAddons5 libKF5I18n5 libKF5I18n5-lang libKF5ItemViews5 libKF5ItemViews5-lang 
      libKF5Solid5 libKF5SonnetCore5 libKF5SonnetUi5 libKF5WidgetsAddons5 
      libKF5WidgetsAddons5-lang libKF5WindowSystem5 libKF5WindowSystem5-lang libphonon4qt5 
      polkit-default-privs python-sip solid-imports susehelp susehelp_en 
    
    
    The following 34 packages are going to change vendor:
      cmake                      openSUSE -> obs://build.opensuse.org/KDE
      kconf_update5              openSUSE -> obs://build.opensuse.org/KDE
      kcoreaddons                openSUSE -> obs://build.opensuse.org/KDE
      kcoreaddons-lang           openSUSE -> obs://build.opensuse.org/KDE
      kimageformats              openSUSE -> obs://build.opensuse.org/KDE
      libKF5Archive5             openSUSE -> obs://build.opensuse.org/KDE
      libKF5Attica5              openSUSE -> obs://build.opensuse.org/KDE
      libKF5Codecs5              openSUSE -> obs://build.opensuse.org/KDE
      libKF5Codecs5-lang         openSUSE -> obs://build.opensuse.org/KDE
      libKF5ConfigCore5          openSUSE -> obs://build.opensuse.org/KDE
      libKF5ConfigCore5-lang     openSUSE -> obs://build.opensuse.org/KDE
      libKF5ConfigGui5           openSUSE -> obs://build.opensuse.org/KDE
      libKF5CoreAddons5          openSUSE -> obs://build.opensuse.org/KDE
      libKF5DBusAddons5          openSUSE -> obs://build.opensuse.org/KDE
      libKF5DNSSD5               openSUSE -> obs://build.opensuse.org/KDE
      libKF5GlobalAccel5         openSUSE -> obs://build.opensuse.org/KDE
      libKF5GuiAddons5           openSUSE -> obs://build.opensuse.org/KDE
      libKF5I18n5                openSUSE -> obs://build.opensuse.org/KDE
      libKF5I18n5-lang           openSUSE -> obs://build.opensuse.org/KDE
      libKF5ItemViews5           openSUSE -> obs://build.opensuse.org/KDE
      libKF5ItemViews5-lang      openSUSE -> obs://build.opensuse.org/KDE
      libKF5Solid5               openSUSE -> obs://build.opensuse.org/KDE
      libKF5SonnetCore5          openSUSE -> obs://build.opensuse.org/KDE
      libKF5SonnetUi5            openSUSE -> obs://build.opensuse.org/KDE
      libKF5WidgetsAddons5       openSUSE -> obs://build.opensuse.org/KDE
      libKF5WidgetsAddons5-lang  openSUSE -> obs://build.opensuse.org/KDE
      libKF5WindowSystem5        openSUSE -> obs://build.opensuse.org/KDE
      libKF5WindowSystem5-lang   openSUSE -> obs://build.opensuse.org/KDE
      libphonon4qt5              openSUSE -> obs://build.opensuse.org/KDE
      polkit-default-privs       openSUSE -> obs://build.opensuse.org/KDE
      python-sip                 openSUSE -> obs://build.opensuse.org/KDE
      solid-imports              openSUSE -> obs://build.opensuse.org/KDE
      susehelp                   openSUSE -> obs://build.opensuse.org/KDE
      susehelp_en                openSUSE -> obs://build.opensuse.org/KDE
    
    
    
    
    34 packages to upgrade, 6 new, 1 to remove, 34  to change vendor.
    Overall download size: 9.2 MiB. Already cached: 0 B  After the operation, additional 4.2 
    MiB will be used.
    Continue? [y/n/? shows all options] (y):
    I did not answer Y to the above.

    As to why I loaded the KDE5 and QT5I wasn't sure about whether I would run Plasma 5 or not. Everything seemed to work and it appeared as though on KDE4 was ever running until this last update. I can certainly deactivate those and remove them if you think it's best. I don't want to venture to KDE 5 until it's considered ready for prime time.

    What I've done in the meantime was manually copy back from my original copy of the .kde4 directory pretty much everything and then removed all the RC files for plasma and restarted. The system came back up almost normally but without my desktop settings I had obviously. So it appears to working at this point now.

    Thanks for your help. Here is the link to the xorg logfile. http://susepaste.org/7394097
    Desktop - Custom Build | Intel i7-950 | Asus P6X58D Premium MB | openSUSE 13.2 X86_64 | 12GB Ram | NVidia GTX580 | KDE 4.14.8

  7. #7

    Default Re: KDE 4.14 Desktop Freezes

    Quote Originally Posted by DMCorsa View Post
    After clearing the .kde4 and starting from scratch YaST does indeed run.
    Hm, that's strange.
    YaST uses Qt5, .kde4 should have no influence on this.

    Here is the glxinfo output:
    Looks ok, and the Xorg.0.log too.
    Still everything would point to a graphics driver problem IMHO.
    Maybe you fixed that somehow? Or did you boot to recovery mode when you had problems? (this can happen with the nvidia driver, as it replaces some system libraries which breaks Mesa's software OpenGL renderer)

    As to why I loaded the KDE5 and QT5I wasn't sure about whether I would run Plasma 5 or not. Everything seemed to work and it appeared as though on KDE4 was ever running until this last update. I can certainly deactivate those and remove them if you think it's best. I don't want to venture to KDE 5 until it's considered ready for prime time.
    Well, you don't need those repos to use Plasma5. It is included in 13.2, although upto now only a slightly older version (5.2.2).
    5.3 might be released as update for 13.2 (in the standard update repo), but that's not decided yet.

    If you do install Plasma5 from the KF5 repo, you should do that switch as well (the zypper dup line I gave you) to avoid problems due to incompatible packages.
    Btw, I do maintain a repo with co-installable Plasma5 packages (including a lot of KF5 based applications):
    http://download.opensuse.org/reposit.../openSUSE_13.2
    If you add this too (preferably with a higher priority than the other repos) and install Plasma5 from there (plasma5-session should pull in everything necessary for a basic desktop), you can keep KDE4 and switch between KDE4 and Plasma5 at the login screen.
    Last edited by wolfi323; 12-Jun-2015 at 15:36.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •