Results 1 to 5 of 5

Thread: Installing older libraries

  1. #1
    Join Date
    Jun 2014
    Location
    Bonn, Germany
    Posts
    68

    Default Installing older libraries

    Hi folks,

    for work reasons I have to use a program (Genfit, not very well-known), that during installation (more precise: I build it from source with make) produces the following error:
    Code:
    Linking CXX executable bin/vertexingTestRead
    /usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: warning: libGLEW.so.1.9, needed by /usr/lib64/root/5.34/libRGL.so, not found (try using -rpath or -rpath-link)
    …
    As far as I understand, the problem is the following: I installed glew from the repos, but the only versions offered are 1.10 (in the default repo) or 1.12 in some other repos; Genfit however seems to require version 1.9 (from 2013). So: Is there a simple way to get this older version?

    What I already tried was downloading the .rpm from rpmfind. I clicked on the rpm-link (right of the "OpenSuSE 13.1 for x86_64"), rpminstall opened, I clicked yes, okay and got no errors, and there is a file /usr/lib/libGLEW.so.1.9 now, but I still get the same error. Can anyone give me a hint?

    Cheers

    pbiel

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    30,148
    Blog Entries
    15

    Default Re: Installing older libraries

    Hi
    Can't use the version from the Science repository?
    https://software.opensuse.org/package/genfit
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,070

    Default Re: Installing older libraries

    Did you install the development package?? That would be what is needed for a compile.

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,101

    Default Re: Installing older libraries

    glew only contains the binaries.

    libglew contains the libraries. I quickly compiled the libglew1.9 vs 13.2 in my repo from old 12.2 sources.

    You didn't mention whether you had 13.1 or or 13.2, so:

    13.1
    Code:
    http://download.opensuse.org/repositories/home:/Miuku/openSUSE_13.1/x86_64/glew-1.9.0-5.1.x86_64.rpm
    http://download.opensuse.org/repositories/home:/Miuku/openSUSE_13.1/x86_64/glew-devel-1.9.0-5.1.x86_64.rpm
    http://download.opensuse.org/repositories/home:/Miuku/openSUSE_13.1/x86_64/libGLEW1_9-1.9.0-5.1.x86_64.rpm
    13.2
    Code:
    http://download.opensuse.org/repositories/home:/Miuku/openSUSE_13.2/x86_64/glew-1.9.0-5.1.x86_64.rpm
    http://download.opensuse.org/repositories/home:/Miuku/openSUSE_13.2/x86_64/glew-devel-1.9.0-5.1.x86_64.rpm
    http://download.opensuse.org/repositories/home:/Miuku/openSUSE_13.2/x86_64/libGLEW1_9-1.9.0-5.1.x86_64.rpm
    .: miuku #suse @ irc.freenode.net

  5. #5
    Join Date
    Jun 2014
    Location
    Bonn, Germany
    Posts
    68

    Thumbs up Re: Installing older libraries

    @Miuku:

    Thank you very much! That worked like a charm.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •