Results 1 to 8 of 8

Thread: creation of GPG key GNuPG

  1. #1
    Join Date
    May 2015
    Location
    California
    Posts
    37

    Default creation of GPG key GNuPG

    gpg: WARNING: The GNOME keyring manager hijacked the GnuPG agent.
    gpg: WARNING: GnuPG will not work properly - please configure that tool to not interfere with the GnuPG system!

    How would I configure gnome keyring?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,615
    Blog Entries
    3

    Default Re: creation of GPG key GNuPG

    You have not mentioned which version of opensuse you are running. Is this Tumbleweed?

    You also have not mentioned which Desktop you are using. I suppose it is Gnome, but I think XFCE also starts the Gnome keyring manager.

    You could always logout from Gnome, then login to Icewm. And create a GPG key there. That way, Gnome keyring should not get in the way.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: creation of GPG key GNuPG

    Quote Originally Posted by pmcpcm View Post
    gpg: WARNING: The GNOME keyring manager hijacked the GnuPG agent.
    gpg: WARNING: GnuPG will not work properly - please configure that tool to not interfere with the GnuPG system!

    How would I configure gnome keyring?
    This has been covered several times. However, I'll paste my favoured link. https://wiki.gnupg.org/GnomeKeyring

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: creation of GPG key GNuPG

    On 2015-06-05 18:46, jgordon wrote:
    >
    > pmcpcm;2713658 Wrote:
    >> gpg: WARNING: The GNOME keyring manager hijacked the GnuPG agent.
    >> gpg: WARNING: GnuPG will not work properly - please configure that tool
    >> to not interfere with the GnuPG system!
    >>
    >> How would I configure gnome keyring?

    >
    > This has been covered several times. However I'll paste my favoured
    > link. https://wiki.gnupg.org/GnomeKeyring


    The instructions there are not easy to follow on openSUSE.

    What does this do?

    Code:
    $ sudo dpkg-divert --local --rename --divert
    /etc/xdg/autostart/gnome-keyring-gpg.desktop-disable --add
    /etc/xdg/autostart/gnome-keyring-gpg.desktop
    
    If you later decide to reenable it, then you can use:
    
    $ sudo dpkg-divert --rename --remove
    /etc/xdg/autostart/gnome-keyring-gpg.desktop
    There is a mention of bug reports on Gentoo, Debian, and Redhat. Perhaps
    a bug report on openSUSE is in order :-?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #5
    Join Date
    May 2015
    Location
    California
    Posts
    37

    Default Re: creation of GPG key GNuPG

    Quote Originally Posted by robin_listas View Post
    On 2015-06-05 18:46, jgordon wrote:
    >
    > pmcpcm;2713658 Wrote:
    >> gpg: WARNING: The GNOME keyring manager hijacked the GnuPG agent.
    >> gpg: WARNING: GnuPG will not work properly - please configure that tool
    >> to not interfere with the GnuPG system!
    >>
    >> How would I configure gnome keyring?

    >
    > This has been covered several times. However I'll paste my favoured
    > link. https://wiki.gnupg.org/GnomeKeyring


    The instructions there are not easy to follow on openSUSE.

    What does this do?

    Code:
    $ sudo dpkg-divert --local --rename --divert
    /etc/xdg/autostart/gnome-keyring-gpg.desktop-disable --add
    /etc/xdg/autostart/gnome-keyring-gpg.desktop
    
    If you later decide to reenable it, then you can use:
    
    $ sudo dpkg-divert --rename --remove
    /etc/xdg/autostart/gnome-keyring-gpg.desktop
    There is a mention of bug reports on Gentoo, Debian, and Redhat. Perhaps
    a bug report on openSUSE is in order :-?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    it gives a dpkg-divert command not found error


    btw
    I'm running OpenSuse 13.2
    Gnupg 2.1.4

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: creation of GPG key GNuPG

    On 2015-06-10 04:46, pmcpcm wrote:

    > it gives a dpkg-divert command not found error


    That's why I said that the instructions are not valid for openSUSE.

    That tool doesn't exist here, and don't you dare to install it, it will
    destroy your system, if you manage to install it...

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,822
    Blog Entries
    15

    Default Re: creation of GPG key GNuPG

    On Wed 10 Jun 2015 03:34:08 AM CDT, Carlos E. R. wrote:

    On 2015-06-10 04:46, pmcpcm wrote:

    > it gives a dpkg-divert command not found error


    That's why I said that the instructions are not valid for openSUSE.

    That tool doesn't exist here, and don't you dare to install it, it will
    destroy your system, if you manage to install it...

    Hi
    It does exist in the openSUSE dkpg package, will it work on openSUSE as
    expected, who knows....


    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,615
    Blog Entries
    3

    Default Re: creation of GPG key GNuPG

    There is actually an easy way of using "gpg-agent" instead of Gnome keyring.

    Change your display manager (login manager) from "gdm" to "kdm". It would be a good idea to first install "kdm" if it is not already on your system.

    When you login to Gnome using "kdm", then "gpg-agent" and "ssh-agent" are started instead of the Gnome keyring emulations.

    I just retested this with 13.2. I don't know about Tumbleweed.

    One problem, though. Gnome keyring is not automatically opened. So you might need to run "seahorse" and manually open it (using your login password) if you need to access it (probably needed by "evolution").
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •