Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to install Github's Atom text editor on opensuse 13.2

  1. #1

    Default How to install Github's Atom text editor on opensuse 13.2

    Hi,
    I downloaded .rpm file from atom's website https://atom.io/download/rpm after clicking on package install button it's saying installing packages for 2 seconds and then it's closes automatically. any solution?
    Thank you so much.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,816

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    For what it is worth installed fine here

    Maybe use the rpm command it may show more info

  3. #3

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Quote Originally Posted by gogalthorp View Post
    For what it is worth installed fine here

    Maybe use the rpm command it may show more info
    I didn't get you

  4. #4

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Hi,

    Nice and kewl text editor, Thanks! btw

    Code:
    ALT + F2
    then type

    Code:
    atom
    then press the enter/return button that should run atom for you if it is indeed installed and

    Code:
    rpm -ql atom
    seems to be what gogalthorp is talking about ( guessing here )
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,816

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Code:
    rpm -i atom.x86.rpm
    The above may give more detailed error message

    I was assuming the thing did not install for some reason, even though I had no trouble here. It showed up in may menu (KDE) under recent installs and in utilities-editors

  6. #6

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Quote Originally Posted by gogalthorp View Post
    Code:
    rpm -i atom.x86.rpm
    The above may give more detailed error message

    I was assuming the thing did not install for some reason, even though I had no trouble here. It showed up in may menu (KDE) under recent installs and in utilities-editors
    Code:
    package atom-0.199.0-0.1.fc21.x86_64 is intended for a different architecture
    I got this error after typing that command. I'm using 32 bit openSUSE.

  7. #7

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Quote Originally Posted by jetchisel View Post
    Hi,

    Nice and kewl text editor, Thanks! btw
    Yeah It's best text editor after sublime text, I'm using this on my macbook.

  8. #8

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Quote Originally Posted by timwilliams View Post
    Code:
    package atom-0.199.0-0.1.fc21.x86_64 is intended for a different architecture
    I got this error after typing that command. I'm using 32 bit openSUSE.
    Hi,

    Yes you will have that error because you have 32bit and that package is 64bit, this link is worth a read


    Code:
    https://github.com/atom/atom/blob/master/docs/build-instructions/linux.md
    or ask someone here or in OBS to package that editor
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  9. #9
    Join Date
    Oct 2015
    Location
    Europe
    Posts
    16

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Can anyone please explain a n00b how to install atom.x86_64.rpm on Leap 42.1? Downloaded it from the official website and don't know what to do with it. In OpenSUSE 13.2 I could just click on the .rpm file to install the app, but on Leap 42.1 that doesn't work.
    OpenSUSE Leap 42.2 KDE

  10. #10
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: How to install Github's Atom text editor on opensuse 13.2

    Quote Originally Posted by Tsvetanov View Post
    Can anyone please explain a n00b how to install atom.x86_64.rpm on Leap 42.1? Downloaded it from the official website and don't know what to do with it. In OpenSUSE 13.2 I could just click on the .rpm file to install the app, but on Leap 42.1 that doesn't work.
    try installing it with zypper or rpm
    Code:
    sudo zypper in/path/to/atom.rpm
    or
    Code:
    sudo rpm -i /path/to/atom.rpm
    zypper is the preferred method as it will automatically download extra dependencies, if dependencies are not satisfied rpm will refuse to install.
    I don't have that rpm but the reason you can't install it with a double click is you don't have the sign key.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •