Results 1 to 4 of 4

Thread: Octave 4.0 from Science repo wants liboctinterp but not found

  1. #1

    Default Octave 4.0 from Science repo wants liboctinterp but not found

    In the last day or so, Octave version 4.0 became available from the Science repo. Update is good and works no problem, however if I attempt to install any of the packages such as database or image the Yast process demands a library liboctinterp so 2 which cannot be satisfied, so it wants to drag me back to the previous 3.8.2 version. It's quite possible that the packages will be updated in due course so I just have to be patient, or my config is bad and I need to take more drastic action. Anyone else in the same boat?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Octave 4.0 from Science repo wants liboctinterp but not found

    Quote Originally Posted by colbec View Post
    In the last day or so, Octave version 4.0 became available from the Science repo. Update is good and works no problem, however if I attempt to install any of the packages such as database or image the Yast process demands a library liboctinterp so 2 which cannot be satisfied, so it wants to drag me back to the previous 3.8.2 version. It's quite possible that the packages will be updated in due course so I just have to be patient, or my config is bad and I need to take more drastic action. Anyone else in the same boat?
    Hi
    Looking at the build info here;
    https://build.opensuse.org/package/b...=openSUSE_13.2
    octave-cli provides liboctinterp.so.3 now

    I'm guessing you have ocatve-forge installed as well? If so this package is in a failed state and has not rebuilt using octave-devel 4.0.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Octave 4.0 from Science repo wants liboctinterp but not found

    Quote Originally Posted by malcolmlewis View Post
    I'm guessing you have ocatve-forge installed as well? If so this package is in a failed state and has not rebuilt using octave-devel 4.0.
    Thanks for comment.
    Actually no, I don't have that installed, I deliberately nuked everything related to Octave to allow a fresh reload of whatever is available. In Yast, all the packages are now shown in parentheses, which may indicate out of date status.
    You are right, the liboctinterp so is now at 3 so the request for so 2 is now bad. All packages need to be rebuilt, and I am sure that this will be done soon. Pity the update was just before a weekend, but not a problem, just have to be patient.

  4. #4
    Join Date
    Jan 2010
    Location
    Russia
    Posts
    100

    Default Re: Octave 4.0 from Science repo wants liboctinterp but not found

    Quote Originally Posted by colbec View Post
    if I attempt to install any of the packages such as database or image the Yast process demands a library liboctinterp so 2 which cannot be satisfied, so it wants to drag me back to the previous 3.8.2 version.
    New octave-forge packages are not ready, we still discuss packaging details. Temporary you can use my repository https://build.opensuse.org/project/s...mitry_R:octave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •