Results 1 to 5 of 5

Thread: Wireshark cannot be installed

  1. #1

    Default Wireshark cannot be installed

    I am running openSUSE 13.2 (Harlequin) (x86_64) 64-bit with Gnome 3.14.2 and I wanted to install Wireshark. However, Yast came up with a dependency conflict

    Code:
    #### YaST2 conflicts list - generated 2015-05-26 18:15:28 ####
    
    nothing provides libGeoIP.so.1()(64bit) needed by wireshark-1.12.5-15.1.x86_64
    
        [x] do not install wireshark-1.12.5-15.1.x86_64
    
        [ ] break wireshark-1.12.5-15.1.x86_64 by ignoring some of its dependencies
    
    #### YaST2 conflicts list END ###
    Does anyone know how I can resolve this conflict?

    Cheers
    Harvey

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Wireshark cannot be installed

    Harvey,

    this is not the Wireshark I see in the official repos. Looks like you try to install it from somewhere else.

    Uwe


  3. #3

    Default Re: Wireshark cannot be installed

    Quote Originally Posted by buckesfeld View Post
    Harvey,

    this is not the Wireshark I see in the official repos. Looks like you try to install it from somewhere else.

    Uwe
    Well, it is exactly the version that I have installed from the main update repository. My version of libGeoIP comes from the main repository OSS. Hope this helps.

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,012

    Default Re: Wireshark cannot be installed

    I like to do things from the console, so what happens if you;
    Code:
    sudo zypper in libGeoIP1 wireshark
    Or just install libGeoIP1 first. Also make sure your OSS repo is not disabled for some reason.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  5. #5

    Default Re: Wireshark cannot be installed

    Quote Originally Posted by Miuku View Post
    I like to do things from the console, so what happens if you;
    Code:
    sudo zypper in libGeoIP1 wireshark
    Or just install libGeoIP1 first. Also make sure your OSS repo is not disabled for some reason.
    Thanks guys. That was it. I had disabled the main OSS (can't now remember why).

    Cheers
    Harvey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •