Results 1 to 4 of 4

Thread: Kshutdown Starts at boot.

  1. #1

    Question Kshutdown Starts at boot.

    I use kshutdown often. Usually from the GUI. Now when I run it, it does not start.
    So I run for terminal and it says it is already running.
    This is new behaviour. For a long time I ran form GUI with no issues.

    I tried reinstalling kshutdown, but it still acts the same way.
    How can I prevent it from starting when I boot my system?

    opensuse 13.2
    kshutdown 3.2-1.1

    konsole output:
    kilbert@linux-cc3l:~> cat /etc/os-release
    NAME=openSUSE
    VERSION="13.2 (Harlequin)"
    VERSION_ID="13.2"
    PRETTY_NAME="openSUSE 13.2 (Harlequin) (x86_64)"
    ID=opensuse
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/opensusepensuse:13.2"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://opensuse.org/"
    ID_LIKE="suse"

    kilbert@linux-cc3l:~> kshutdown
    kshutdown: KDE Full Session: <FOUND>
    kshutdown: KDE 4: <FOUND>
    KShutdown is already running
    kilbert@linux-cc3l:~>

    thanks in advance.

    J kilbert.

  2. #2

    Default Re: Kshutdown Starts at boot.

    Quote Originally Posted by kilbert View Post
    I tried reinstalling kshutdown, but it still acts the same way.
    How can I prevent it from starting when I boot my system?
    KDE by default starts all programs on login that were running when you logout/shutdown/reboot.

    So quit/kill it before you do that, and it shouldn't be started any more.

    Or set "Start with an empty session" in "Configure Desktop"(Systemsettings)->Startup and Shutdown->Session Management.
    This will of course not start any other applications too, but you can also exclude specific applications from being restarted there.

  3. #3

    Default Re: Kshutdown Starts at boot.

    It would be counter-intuitive to kill kshutdown before shutdown, as the whole reason for the existence is to set a timer to shutdown the system while you are not there.
    It also is new behaviour, I used kshutdown for years and it never acted this way.
    thanks anyway.

  4. #4

    Default Re: Kshutdown Starts at boot.

    Quote Originally Posted by kilbert View Post
    It would be counter-intuitive to kill kshutdown before shutdown, as the whole reason for the existence is to set a timer to shutdown the system while you are not there.
    I meant of course you should kill it when it was started automatically, and reboot or logout/login afterwards. Not after you ran it yourself to do a timed shutdown.

    Other options: try to add it to the list of excluded applications in the session management settings or disable session management altogether ("Start with an empty session"), as suggested.

    Kshutdown should disable session management by itself, if it doesn't it would be a bug (in Kshutdown).

    Maybe it's just still listed in KDE's autosaved session by mistake for some reason though, just deleting the folder ~/.kde4/share/config/session/ might fix your "problem".

    It also is new behaviour, I used kshutdown for years and it never acted this way.
    thanks anyway.
    I cannot tell you whether there was any change in Kshutdown recently as I don't use it.
    There definitely hasn't been a change to KDE4's session management/login behavior since 13.2 (or even 13.1) has been released.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •