Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: VirtualBox not work

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default VirtualBox not work

    I'm using OpenSuse 13.2 and KDE
    I installed VirtualBox but when I try to run it not work

    On command line I get these messages:

    Code:
    sergio@linux-qgry:~> vboxgtk
    Traceback (most recent call last):
      File "/usr/bin/vboxgtk", line 94, in <module>
        vboxgtk.main()
      File "/usr/lib/python2.7/site-packages/vboxgtk/iface.py", line 47, in call_with_method
        return func(self,*args,**kwargs)
      File "/usr/lib/python2.7/site-packages/vboxgtk/iface.py", line 74, in main
        builder.add_from_file(os.path.join(paths.data_path, f))
    GLib.Error: gtk-builder-error-quark: Invalid property: GtkGrid.n_rows on line 1564 (11)
    sergio@linux-qgry:~>
    What should I do to solve this problem?

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,974

    Default AW: VirtualBox not work

    Code:
    What should I do to solve this problem?
    vboxgtk is broken, delete it and install virtualbox-qt.

  3. #3
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: VirtualBox not work

    OK. the instalation VirtualBox qt, but now more problems
    Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

    '/etc/init.d/vboxdrv setup'

    as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.
    I follow the instructions, but I get new problems

    Code:
    sergio@linux-qgry:~> sudo /etc/init.d/vboxdrv setup
    Recompiling VirtualBox kernel module, NOT. It has been packaged.

    And this is reult command line

    Code:
    x
    sergio@linux-qgry:~> VirtualBox 
    Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile

  4. #4

    Default Re: VirtualBox not work

    Quote Originally Posted by sergelli View Post
    I follow the instructions, but I get new problems
    Which instructions did you follow?
    The ones here in this thread, i.e. to uninstall vboxgtk, or do you mean something else?

    The message means that the kernel module cannot be loaded.
    The virtualbox-host-kmp package must match your kernel, so please post the output of:
    Code:
    rpm -qa | egrep -i "kernel|virtualbox"
    Code:
    sergio@linux-qgry:~> sudo /etc/init.d/vboxdrv setup
    Recompiling VirtualBox kernel module, NOT. It has been packaged.
    Yes. The openSUSE packages contain a pre-compiled kernel module. You don't have to build it yourself when using the openSUSE packages, and even cannot because the source code is not included.
    There is a separate package with the source code if you wanted to built it yourself anyway, but normally that's unneccesary.

    And this is reult command line

    Code:
    x
    sergio@linux-qgry:~> VirtualBox 
    Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
    That's irrelevant, and not a problem.

  5. #5
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,054

    Default Re: VirtualBox not work

    On Sat, 23 May 2015 14:06:01 +0000, sergelli wrote:

    > sergio@linux-qgry:~> vboxgtk


    Do not use vboxgtk. Use VirtualBox.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  6. #6
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: VirtualBox not work

    Quote Originally Posted by wolfi323 View Post
    Which instructions did you follow?
    The ones here in this thread, i.e. to uninstall vboxgtk, or do you mean something else?
    Which instructions did you follow?
    The instructions that I mentioned are those that appeared in a warning window that appeared when I called the newly installed VirtualBox QT
    The message is in the beginning of the previous post.

    But that does not matter anymore, because I turned off the PC and when I called again, VirtualBox worked OK.

    Thank you for the help.

  7. #7

    Default Re: VirtualBox not work

    Quote Originally Posted by sergelli View Post
    Which instructions did you follow?
    The instructions that I mentioned are those that appeared in a warning window that appeared when I called the newly installed VirtualBox QT
    The message is in the beginning of the previous post.
    As indicated, this only applies if you install VirtualBox from http://virtualbox.org, but not for the openSUSE packages.
    See also the second message you got when running "vboxdrv setup".

    But that does not matter anymore, because I turned off the PC and when I called again, VirtualBox worked OK.
    So you didn't reboot after installing it, and therefore the necessary kernel modules just weren't loaded yet.
    This is done during boot, but you could have loaded them manually with "/etc/init.d/vboxdrv start" (instead of "setup", which compiles them) too.

  8. #8
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: VirtualBox not work

    Quote Originally Posted by wolfi323 View Post
    As indicated, this only applies if you install VirtualBox from http://virtualbox.org, but not for the openSUSE packages.
    See also the second message you got when running "vboxdrv setup".
    .
    But I used the openSUSE packages.
    I never did VirtualBox installations from http://virtualbox.org,
    It is probable that more people will have the same problem.

    Thank you for explanations

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,974

    Default AW: VirtualBox not work

    You have not answered wolfi323`s Question about the installed Packages:
    Code:
    rpm -qa | egrep -i "kernel|virtualbox"

  10. #10

    Default Re: VirtualBox not work

    Quote Originally Posted by sergelli View Post
    But I used the openSUSE packages.
    I never did VirtualBox installations from http://virtualbox.org,
    Yes, but that's the error message VirtualBox displays when the kernel module is not loaded.
    Again, just rebooting should "fix" that, because the kernel module will be loaded on boot.

    And in openSUSE's packages /etc/init.d/vboxdrv has been patched to display that error message, as it can't build the kernel module (only a binary is included, no source).
    Maybe that message could be worded better, but I suppose that would complicate the patch...

    Quote Originally Posted by Sauerland View Post
    You have not answered wolfi323`s Question about the installed Packages:
    Code:
    rpm -qa | egrep -i "kernel|virtualbox"
    I don't think that's necessary any more.
    It is working for him after a fresh boot, so the correct packages should be installed.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •