Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: New 13.2 install: Certain KDE apps crash entire DE session instantly

  1. #1

    Default New 13.2 install: Certain KDE apps crash entire DE session instantly

    After years of bouncing between Linux Mint KDE and Kubuntu, I've moved to openSUSE (with KDE). Installing Mint on a LUKS/LVM partition has always been a pain, and in the latest release the installer fails on me, taking that distro out of the competition. As far as Kubuntu goes, I made the mistake of upgrading to 15.04 and Plasma 5, which is barely alpha-level software at this point. I picked openSUSE because it's said to take KDE seriously, and because it seems to offer a good balance between stability and up-to-dateness.

    Anyway, things have generally been great -- the power management in openSUSE is better than what I got from Mint KDE or Kubuntu, moving from aptitude to zypper/yast2 hasn't been a big deal, and things seem a bit zippier now.

    But I've had one recurring problem that's driving me crazy -- when launching certain KDE apps at certain times, the entire Desktop Environment dies instantly and completely. The screen goes black for a second or two, and then I'm at the logon screen, forced to start a new session, with any previous unsaved work lost.

    This has happened when pressing CTRL-ESC to open System Activity, when launching Kusers, and when launching the KDE printer config applet. But it doesn't always happen -- I can launch all three of those apps at the moment with no problems at all. So the apps themselves don't seem to be the problem -- or at least, they're not the entire problem. Some other condition must be met in order to cause the crashing.

    The only thing I can think of that I might have "done wrong" was to enable various repositories (openSUSE Build Services KDE:Extra, Packman, etc) that are not standard. Specifically, I set Yast2 to use KDE:Extra as the main repository for KDE stuff and then I updated the system.

    Below is system information that might be of use in troubleshooting this. I'd really like to get to the bottom of this, as I'm liking openSUSE a lot, but I simply can't continue with it if I can't fix this crashing.

    Thanks in advance!


    Code:
    $ sudo inxi -Fxz%System:    Host: XXXXX.site Kernel: 3.16.7-21-desktop x86_64 (64 bit, gcc: 4.8.3) 
               Console tty 1 Distro: openSUSE 13.2 (x86_64) VERSION = 13.2 CODENAME = Harlequin # /etc/SuSE-release is deprecated and will be removed in the future, use /etc/os-release instead
    Machine:   System: TOSHIBA (portable) product: Satellite XXXXX version: XXXXX
               Mobo: TOSHIBA model: VG20SQ Bios: TOSHIBA version: 1.30 date: 08/14/2014
    CPU:       Quad core Intel Core i7-4710HQ CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19953.3 
               Clock Speeds: 1: 2500.683 MHz 2: 3061.328 MHz 3: 2503.906 MHz 4: 2500.00 MHz 5: 2500.00 MHz 6: 2500.00 MHz 7: 2500.00 MHz 8: 2733.203 MHz
    Graphics:  Card: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 
               X.org: 1.16.1 drivers: intel (unloaded: fbdev,vesa) tty size: 176x52 Advanced Data: N/A for root out of X
    Audio:     Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
               Card-2: Intel 8 Series/C220 Series Chipset High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
               Sound: Advanced Linux Sound Architecture ver: k3.16.7-21-desktop
    Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
               driver: r8169 ver: 2.3LK-NAPI port: d000 bus-ID: 04:00.0
               IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
               Card-2: Intel Wireless 7260 driver: iwlwifi ver: in-tree:d bus-ID: 03:00.0
               IF: wlp3s0 state: up mac: <filter>
    Drives:    HDD Total Size: 2500.5GB (79.1% used) 1: /dev/sda ST2000LM003_HN 2000.4GB 
               2: /dev/sdb Samsung_SSD_840 500.1GB 0C 
    Partition: ID: / size: 456G used: 359G (83%) fs: ext4 ID: /boot size: 379M used: 36M (10%) fs: ext4 
               ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap 
    Sensors:   System Temperatures: cpu: 59.0C mobo: N/A gpu: N/A 
               Fan Speeds (in rpm): cpu: N/A 
    Info:      Processes: 294 Uptime: 8:28 Memory: 5481.0/11949.7MB Runlevel: 5 Gcc sys: 4.8.3 Client: Shell inxi: 1.7.24

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,156

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    I set Yast2 to use KDE:Extra as the main repository for KDE stuff and then I updated the system.
    Please explain what you mean by using the colloquial term "update". That word is often used loosely by people who do the equivalent of zypper patch, zypper up, or zypper dup or the same sort of action using YaST > Software > Software Management, or other tools. We can not assume when you do not tell.

    And when you have doubt about your repos list, you better show it. Again we can not help you with something we do not know about:
    Code:
    zypper lr -d
    Henk van Velden

  3. #3

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    Quote Originally Posted by hcvv View Post
    Please explain what you mean by using the colloquial term "update". That word is often used loosely by people who do the equivalent of zypper patch, zypper up, or zypper dup or the same sort of action using YaST > Software > Software Management, or other tools. We can not assume when you do not tell.
    I wasn't aware of all that! What I did, in the case of repos such as Packman, openSUSE Build Service: KDE:Extra, openSUSE Build Service: Mozilla, was:

    • Select them in YaST's repositories view.
    • Choose "Switch system packages to the versions in this repository".
    • Perform all the installations and updates that YaST suggested after that.



    Quote Originally Posted by hcvv View Post
    And when you have doubt about your repos list, you better show it. Again we can not help you with something we do not know about:
    Code:
    zypper lr -d
    My apologies! I didn't even know YaST had such a convenient command! Here it goes:

    Code:
    $ zypper lr -d#  | Alias                                | Name                                                | Enabled | Refresh | Priority | Type   | URI                                                                                        | Service
    ---+--------------------------------------+-----------------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------------+--------
     1 | Infinality                           | Infinality                                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/namtrac:/subpixel/openSUSE_13.2/           |        
     2 | X11:GNUstep                          | X11:GNUstep                                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/GNUstep/openSUSE_13.2/                      |        
     3 | X11:lxde                             | X11:lxde                                            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/lxde/openSUSE_13.2/                         |        
     4 | devel:languages:R:released           | devel:languages:R:released                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/R:/released/openSUSE_13.2/     |        
     5 | devel:languages:lua                  | devel:languages:lua                                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/lua/openSUSE_13.2/             |        
     6 | download.opensuse.org-13.2-non-oss   | Update Repository (Non-Oss)                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                                          |        
     7 | download.opensuse.org-4.4            | openSUSE BuildService - LibreOffice                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/4.4/openSUSE_13.2/                  |        
     8 | download.opensuse.org-Extra          | openSUSE BuildService - KDE:Extra                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/                        |        
     9 | download.opensuse.org-Virtualization | openSUSE BuildService - Virtualization (VirtualBox) | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_13.2/                    |        
    10 | download.opensuse.org-mozilla        | openSUSE BuildService - Mozilla                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.2/                           |        
    11 | download.opensuse.org-non-oss        | Main Repository (NON-OSS)                           | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                               |        
    12 | download.opensuse.org-oss            | Main Repository (OSS)                               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                                   |        
    13 | download.opensuse.org-perl           | openSUSE BuildService - devel:languages:perl        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_13.2/            |        
    14 | download.opensuse.org-update         | Main Update Repository                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                                  |        
    15 | ftp.gwdg.de-suse                     | Packman Repository                                  | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                                   |        
    16 | google-chrome                        | google-chrome                                       | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                        |        
    17 | home:AndnoVember:test                | home:AndnoVember:test                               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/AndnoVember:/test/openSUSE_13.2/           |        
    18 | home:Fisiu:lcd                       | home:Fisiu:lcd                                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Fisiu:/lcd/openSUSE_13.2/                  |        
    19 | home:Lazy_Kent                       | home:Lazy_Kent                                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Lazy_Kent/openSUSE_13.2/                   |        
    20 | home:Nemton                          | home:Nemton                                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Nemton/openSUSE_13.2/                      |        
    21 | home:fabio_s                         | home:fabio_s                                        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/fabio_s/openSUSE_13.2/                     |        
    22 | home:pgajdos:font-setting            | home:pgajdos:font-setting                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/pgajdos:/font-setting/openSUSE_13.2/       |        
    23 | home:ruario:opera                    | home:ruario:opera                                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/ruario:/opera/openSUSE_13.2/               |        
    24 | multimedia:apps                      | multimedia:apps                                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_13.2/                  |        
    25 | multimedia:libs                      | multimedia:libs                                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_13.2/                  |        
    26 | openSUSE-13.2-0                      | openSUSE-13.2-0                                     | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/usb-hp_CDDVDW_SN-208DB_30303030303030303030303030303030-0:0 |        
    27 | openSUSE:13.2:Update                 | openSUSE:13.2:Update                                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/13.2:/Update/standard/                 |        
    28 | opensuse-guide.org-repo              | libdvdcss repository                                | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                                       |        
    29 | repo-debug                           | openSUSE-13.2-Debug                                 | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                             |        
    30 | repo-debug-update                    | openSUSE-13.2-Update-Debug                          | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                            |        
    31 | repo-debug-update-non-oss            | openSUSE-13.2-Update-Debug-Non-Oss                  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                                    |        
    32 | repo-source                          | openSUSE-13.2-Source                                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.2/repo/oss/
    Thanks for your help so far!

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    I wasn't aware of all that! What I did, in the case of repos such as Packman, openSUSE Build Service: KDE:Extra, openSUSE Build Service: Mozilla, was:
    this was your error, you should only do this for packman (because of the codec's restrictions to get multimedia support)and for no other repo, how to fix this?
    you could try
    zypper dup -from 26
    and then to get the packman stuff working again
    zypper dup -from 15

    and while in yast set packman as the system repo (do this only once and only for packman) so when a vlc update is out you will use the full featured packman variant and not the restricted one from all the other repo's
    note the 26 and 15 are based on your repos, you have way too many conflicting repositories.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,156

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    And disable your installation device (it is #26 in your list).
    Henk van Velden

  6. #6

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    Quote Originally Posted by I_A View Post
    this was your error, you should only do this for packman (because of the codec's restrictions to get multimedia support)and for no other repo...
    A-ha! Good to know! OpenSUSE's package management is still a bit mysterious to me.


    how to fix this?
    you could try
    zypper dup -from 26
    and then to get the packman stuff working again
    zypper dup -from 15
    That's giving me an error:

    Code:
    $ sudo zypper dup -from 26
    Unknown option 'f'
    $

    and while in yast set packman as the system repo (do this only once and only for packman) so when a vlc update is out you will use the full featured packman variant and not the restricted one from all the other repo's
    note the 26 and 15 are based on your repos, you have way too many conflicting repositories.
    I'll be sure to try this as soon as I get the issue above sorted out.

    Thanks so much!

  7. #7

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    Quote Originally Posted by hcvv View Post
    And disable your installation device (it is #26 in your list).
    Will do! Thanks!

  8. #8

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    I_A, I noticed a second dash was missing from the code above, so I added it and the command now works. I've now got a choice to make, and I'd appreciate input before making it.

    Code:
    $ sudo zypper dup --from 26Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    32 Problems:
    Problem: problem with installed package kernel-desktop-3.16.7-21.1.x86_64
    Problem: problem with installed package kernel-desktop-devel-3.16.7-21.1.x86_64
    Problem: problem with installed package kernel-devel-3.16.7-21.1.noarch
    Problem: problem with installed package kernel-source-3.16.7-21.1.noarch
    Problem: freetype2-devel-32bit-2.5.5-132.1.x86_64 requires freetype2-devel = 2.5.5, but this requirement cannot be provided
    Problem: apper-lang-0.9.2-14.1.noarch requires apper = 0.9.2, but this requirement cannot be provided
    Problem: calligra-words-common-2.9.4-49.4.x86_64 requires calligra = 2.9.4, but this requirement cannot be provided
    Problem: k3b-lang-2.0.80+git20150209.2250-1.3.noarch requires k3b = 2.0.80+git20150209.2250, but this requirement cannot be provided
    Problem: kipi-plugins-lang-4.10.0-42.2.noarch requires kipi-plugins = 4.10.0, but this requirement cannot be provided
    Problem: audacity-lang-2.1.0-93.8.noarch requires audacity = 2.1.0, but this requirement cannot be provided
    Problem: glib-networking-lang-2.42.1-4.1.noarch requires glib-networking = 2.42.1, but this requirement cannot be provided
    Problem: gstreamer-lang-1.4.5-60.10.noarch requires gstreamer = 1.4.5, but this requirement cannot be provided
    Problem: gstreamer-plugins-ugly-orig-addon-1.4.5-50.3.x86_64 requires gstreamer-plugins-ugly >= 1.4.5, but this requirement cannot be provided
    Problem: gtk2-devel-32bit-2.24.27-4.8.1.x86_64 requires gtk2-devel = 2.24.27, but this requirement cannot be provided
    Problem: java-1_8_0-openjdk-devel-1.8.0.45-9.3.x86_64 requires java-1_8_0-openjdk = 1.8.0.45-9.3, but this requirement cannot be provided
    Problem: libQt5XmlPatterns5-5.4.1-6.1.x86_64 requires libQt5Core5 >= 5.4.1, but this requirement cannot be provided
    Problem: libQt5Network5-5.4.1-19.1.x86_64 requires libQt5DBus5 = 5.4.1, but this requirement cannot be provided
    Problem: libqt5-qtbase-platformtheme-gtk2-5.4.1-19.1.x86_64 requires libQt5Gui5 = 5.4.1, but this requirement cannot be provided
    Problem: libQt5WebKitWidgets5-5.4.1-7.2.x86_64 requires libQt5Widgets5 >= 5.4.1, but this requirement cannot be provided
    Problem: libKF5WindowSystem5-5.10.0-22.1.x86_64 requires libQt5X11Extras5 >= 5.4.1, but this requirement cannot be provided
    Problem: vlc-noX-2.2.1-285.1.x86_64 requires libbluray1 >= 0.8.0, but this requirement cannot be provided
    Problem: gtk3-branding-SLED-13.2-14.2.noarch requires libgtk-3-0 = 3.14.12, but this requirement cannot be provided
    Problem: gtksourceview-lang-3.14.4-11.1.noarch requires gtksourceview = 3.14.4, but this requirement cannot be provided
    Problem: libwebkit2gtk3-lang-2.6.4-4.9.noarch requires libwebkit2gtk3 = 2.6.4, but this requirement cannot be provided
    Problem: libwebkitgtk2-lang-2.4.7-4.11.noarch requires libwebkitgtk2 = 2.4.7, but this requirement cannot be provided
    Problem: libwebkitgtk3-lang-2.4.7-4.10.noarch requires libwebkitgtk3 = 2.4.7, but this requirement cannot be provided
    Problem: libxine2-codecs-1.2.6-93.6.x86_64 requires libxine2 = 1.2.6, but this requirement cannot be provided
    Problem: pidgin-otr-4.0.1-7.4.1.x86_64 requires pidgin >= 2.10.10, but this requirement cannot be provided
    Problem: yast2-fonts-3.1.14-5.1.x86_64 requires fonts-config >= 20150424, but this requirement cannot be provided
    Problem: oxygen-icon-theme-large-14.12.3-2.16.1.noarch requires oxygen-icon-theme = 14.12.3, but this requirement cannot be provided
    Problem: digikam-4.3.0-2.2.x86_64 requires libkgeomap.so.1()(64bit), but this requirement cannot be provided
    Problem: libkgeomap-lang-4.10.0-42.2.noarch requires libkgeomap = 4.10.0, but this requirement cannot be provided
    
    
    Problem: problem with installed package kernel-desktop-3.16.7-21.1.x86_64
     Solution 1: Following actions will be done:
      downgrade of kernel-desktop-3.16.7-21.1.x86_64 to kernel-desktop-3.16.6-2.1.x86_64
      deinstallation of kernel-desktop-3.16.7-21.1.x86_64
     Solution 2: keep obsolete kernel-desktop-3.16.7-21.1.x86_64
    
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):
    What do you recommend here?

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    it was partially my error I didn't see that #26 was the install DVD I can't seam to find the online # let me look...
    it's #12
    try
    zypper dup --from 12 the main oss repo
    zypper dup --from 15 packman for video's and audio

    edit
    I only have 6 repo's and a smooth system, I've got the main oss, the non-free, nvidia, packman and the update repo, if I need an extra package I only temporarily use an extra repository just to satisfy dependencies, having 32 repositories is just bad practice.

  10. #10

    Default Re: New 13.2 install: Certain KDE apps crash entire DE session instantly

    Quote Originally Posted by I_A View Post
    it was partially my error I didn't see that #26 was the install DVD I can't seam to find the online # let me look...
    it's #12
    try
    zypper dup --from 12 the main oss repo
    zypper dup --from 15 packman for video's and audio
    Thanks for staying with me here! I just ran the first command and got a similar result:

    Code:
    $ sudo zypper dup --from 12root's password:
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    18 Problems:
    Problem: problem with installed package kernel-desktop-3.16.7-21.1.x86_64
    Problem: problem with installed package kernel-desktop-devel-3.16.7-21.1.x86_64
    Problem: problem with installed package kernel-devel-3.16.7-21.1.noarch
    Problem: problem with installed package kernel-source-3.16.7-21.1.noarch
    Problem: k3b-codecs-2.0.80+git20150209.2250-1.3.x86_64 requires k3b = 2.0.80+git20150209.2250-1.3, but this requirement cannot be provided
    Problem: audacity-lang-2.1.0-93.8.noarch requires audacity = 2.1.0, but this requirement cannot be provided
    Problem: gstreamer-plugins-ugly-orig-addon-1.4.5-50.3.x86_64 requires gstreamer-plugins-ugly >= 1.4.5, but this requirement cannot be provided
    Problem: kded-lang-5.10.0-21.1.noarch requires kded = 5.10.0, but this requirement cannot be provided
    Problem: libqt5-qtbase-platformtheme-gtk2-5.4.1-19.1.x86_64 requires libQt5Gui5 = 5.4.1, but this requirement cannot be provided
    Problem: libQt5WebKit5-imports-5.4.1-7.2.x86_64 requires libQt5WebKit5 = 5.4.1, but this requirement cannot be provided
    Problem: libQt5WebSockets5-imports-5.4.1-6.1.x86_64 requires libQtQuick5 >= 5.4.1, but this requirement cannot be provided
    Problem: gtk3-branding-SLED-13.2-14.2.noarch requires libgtk-3-0 = 3.14.12, but this requirement cannot be provided
    Problem: libxine2-codecs-1.2.6-93.6.x86_64 requires libxine2 = 1.2.6, but this requirement cannot be provided
    Problem: vlc-codecs-2.2.1-285.1.x86_64 requires vlc-noX = 2.2.1, but this requirement cannot be provided
    Problem: yast2-fonts-3.1.14-5.1.x86_64 requires fonts-config >= 20150424, but this requirement cannot be provided
    Problem: kio-core-5.10.0-21.4.x86_64 conflicts with kio <= 5.8.0 provided by kio-5.3.0-1.3.x86_64
    Problem: libQt5Sensors5-imports-5.4.1-6.1.x86_64 conflicts with libQt5Sensors5 < 5.4.1 provided by libQt5Sensors5-5.3.2-1.2.x86_64
    Problem: digikam-4.3.0-2.2.x86_64 requires libkgeomap.so.1()(64bit), but this requirement cannot be provided
    
    
    Problem: problem with installed package kernel-desktop-3.16.7-21.1.x86_64
     Solution 1: Following actions will be done:
      downgrade of kernel-desktop-3.16.7-21.1.x86_64 to kernel-desktop-3.16.6-2.1.x86_64
      deinstallation of kernel-desktop-3.16.7-21.1.x86_64
     Solution 2: keep obsolete kernel-desktop-3.16.7-21.1.x86_64
    
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):
    Since I'm effectively downgrading, should I opt for solution 1?


    edit
    I only have 6 repo's and a smooth system, I've got the main oss, the non-free, nvidia, packman and the update repo, if I need an extra package I only temporarily use an extra repository just to satisfy dependencies, having 32 repositories is just bad practice.
    I hear you! Most of mine are for a single program (e.g. Infinality, Chrome, a more updated Firefox and Libre Office), and some seem to have been pulled in by R, though I could be mistaken on that. But I'd definitely like to slim things down!

    Do you recommend just deactivating these repositories once the software is installed, and then reactivating them from time to time to get updates?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •