Results 1 to 7 of 7

Thread: Login to KDE without keyboard repeat

  1. #1

    Default Login to KDE without keyboard repeat

    Hello, how could I switch off keyboard-repeat, when typing in my password into the linux greater window after booting? Sometimes I don't get the fingers off the keyboard fast enough. For safety-reasons I don't want to get the system opened neither by auto-login nor by password-less login. My system: os 13.2 KDE 4 EXT4 fresh install on ASUS P42J dual boot with win7. Thanks Ebkr

  2. #2

    Default Re: Login to KDE without keyboard repeat

    Quote Originally Posted by Ebkr View Post
    Hello, how could I switch off keyboard-repeat, when typing in my password into the linux greater window after booting?
    Hm, I'm not sure this is possible.

    But you can change the repeat delay and repeat rate in /etc/sysconfig/keyboard (you can use a text editor or YaST->System->"/etc/sysconfig Editor" to change that, search for KBD_DELAY or KBD_RATE accordingly). I think that should be carried over to the login screen.

    If not, try this, in particular the last paragraph:
    https://wiki.archlinux.org/index.php...delay_and_rate

  3. #3

    Default Re: Login to KDE without keyboard repeat

    Quote Originally Posted by wolfi323 View Post
    Hm, I'm not sure this is possible.

    But you can change the repeat delay and repeat rate in /etc/sysconfig/keyboard (you can use a text editor or YaST->System->"/etc/sysconfig Editor" to change that, search for KBD_DELAY or KBD_RATE accordingly). I think that should be carried over to the login screen.

    If not, try this, in particular the last paragraph:
    https://wiki.archlinux.org/index.php...delay_and_rate
    Thanks,Wolfi
    I tried a couple of values in KBD Delay and/or KBD Rate. But there was no change of the behaviour of the login screen.
    I'ii try later wiki.archlinux.org and report.
    Ebkr

  4. #4

    Default Re: Login to KDE without keyboard repeat

    Quote Originally Posted by Ebkr View Post
    Thanks,Wolfi
    I tried a couple of values in KBD Delay and/or KBD Rate. But there was no change of the behaviour of the login screen.
    Pity. I would have hoped that it works...

    I'ii try later wiki.archlinux.org and report.
    If that doesn't work either, you could also try to add an xset command (see also the Arch page I mentioned) to /etc/X11/xdm/Xsetup, that script is run when the login screen is started, unlike xinitrc which only is run when you actually log in.

    According to "man xset", it is even possible to disable auto repeat completely with "xset -r" or "xset r off". This (or setting the rate) is even possible separately for each specific key...

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: Login to KDE without keyboard repeat

    In times long past you could set the repeat delay and repeat speed in BIOS. It became (almost) irrelevant when this could be set at the start of the DE. It is possible your BIOS support it, maybe in advanced mode. I've seen it recently in one UEFI BIOS IINM.

  6. #6

    Default Re: Login to KDE without keyboard repeat

    Quote Originally Posted by wolfi323 View Post
    Pity. I would have hoped that it works... If that doesn't work either, you could also try to add an xset command (see also the Arch page I mentioned) to /etc/X11/xdm/Xsetup, that script is run when the login screen is started, unlike xinitrc which only is run when you actually log in. According to "man xset", it is even possible to disable auto repeat completely with "xset -r" or "xset r off". This (or setting the rate) is even possible separately for each specific key...
    On my second laptop where I have o.S.13.2 on Oracle VM within Win 7 i tried out Xset -r and xset r off, but without any change after rebooting. So for the time being I will make it do with the existing constellation. Thanks anyway Ebkr

  7. #7

    Default Re: Login to KDE without keyboard repeat

    Quote Originally Posted by Ebkr View Post
    On my second laptop where I have o.S.13.2 on Oracle VM within Win 7 i tried out Xset -r and xset r off, but without any change after rebooting.
    It is "xset", not "Xset" (note the capitalisation, Linux filesystems are case-sensitive).

    And it only affects the currently running session (it doesn't save any settings)), so if you ran it manually inside an X session, it's to be expected that there's no change after reboot.
    You need to add it to some startup script, like /etc/X11/xdm/Xstartup for the login screen (xdm and kdm at least, I'm not sure if all DMs run that file).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •