Results 1 to 7 of 7

Thread: [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

  1. #1

    Default [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

    there is this plasmoid (device <something>, I don't know the english name) in the KDE panel that pops up when eg. a USB stick is attached or a DVD is inserted, and asks which of several proposed actions should be performed.
    one of such actions is to open the USB stick (or DVD) with a file manager.
    If I select the file manager then vlc is starting up!! instead of the file manager.

    how can I repair that to use dolphin instead of vlc?

  2. #2

    Default Re: [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

    Quote Originally Posted by suse_paul View Post
    how can I repair that to use dolphin instead of vlc?
    Maybe "Configure Desktop"->Default Applications->Filemanager, or have a look in "File Associations" as well. The file type that affects this is "inode/directory" I think, move dolphin to the top of the list of applications there.

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,302
    Blog Entries
    2

    Default Re: [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

    Probably easiest is to
    Open Dolphin
    Browse to the specified file in question
    Rt-click on the file and select "Properties"
    Follow the instructions to set the file type to open using Dolphin instead.

    Note that some file types can be used for multiple purposes, so you'll have an ongoing issue regardless what default app you choose to open a file.

    HTH,
    TSU

  4. #4

    Default Re: [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

    maybe may problem was misunderstood.
    there are no problems when opening anything from within the file manager / dolphin.
    the problem only occurs with the plasmoid.
    file associations, therefore, seem to me correct and need not to be changed.

    I thought about modfying system settings -> device actions
    but I don't know how to properly modify it.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

    This usually means that the device you plug in has or once had media on it.

    this is controlled in KDE at System settings (configure desktop) -> Device Actions. There you will find the rules of what opens when the system sees this or that.

  6. #6

    Default Re: [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

    Quote Originally Posted by suse_paul View Post
    maybe may problem was misunderstood.
    there are no problems when opening anything from within the file manager / dolphin.
    the problem only occurs with the plasmoid.
    file associations, therefore, seem to me correct and need not to be changed.
    "Open with Filemanager" actually opens it with the default application (which normally is the filemanager).
    So I still think the file associations are wrong, for "inode/directory" in particular as mentioned.

    Dolphin itself ignores the settings for that filetype, it just opens directories directly. So that's why it's working there.

    I thought about modfying system settings -> device actions
    but I don't know how to properly modify it.
    That shouldn't be necessary, unless you modified them yourself in the first place.
    Last edited by wolfi323; 19-May-2015 at 13:50.

  7. #7

    Default Re: [13.2/KDE] plasmoid opens DVD with vlc instead of file manager

    thank you for the explanation.
    vlc was the default application under inode/directory.
    changing the order solved it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •