Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Sound only from headphones on laptop

  1. #1
    Join Date
    Jul 2008
    Location
    Nottingham, UK
    Posts
    37

    Default Sound only from headphones on laptop

    I've recently installed Opensuse 13.2 on a new laptop (Gigabyte P35X v3), and most things work fine except for the sound. I've tried literally everything, including the Opensuse SDB articles on sound troubleshooting and elsewhere. I'm not exactly a newbie to Linux, and have always managed to solve problems in the past, but this one has me stumped. I get sound from the headphone jack with no issues, but I simply cannot persuade my laptop to give me sound from the speakers. Except by booting into Windows.

    In Yast, I see there are two sound devices: Haswell HD and Lynx Point. Changing the default device has no effect. Installing Pavucontrol or using alsa mixer to ensure no channels are muted has no efffect. Fiddling with modprobe.d files has no effect. Nor permissions or anything else.

    Any help anyone can give on this would be greatly appreciated!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,696
    Blog Entries
    38

    Default Re: Sound only from headphones on laptop

    Its possible the alsa driver is buggy for your laptop (in which case a bug report on openSUSE would get the attention of the SuSE-GmbH sound packager for openSUSE who is also an alsa sound driver developer, and who solves most sound problems quickly), ... but before raising a bug report, could you provide some more information so that we can confirm there is not some strange mixer or other sound configuration at issue here ?

    Please with your laptop connected to the internet, as a regular user run this diagnostic script in a konsole/xterm :
    Code:
    /usr/sbin/alsa-info.sh
    and do not Update if asked, and select the SHARE/UPLOAD option, and let the script run to completion. After it finishes it will put a web-address/URL in the konsole/xterm indicating where it has uploaded your laptop's audio-configuration information. Please copy the web-address/URL here (just the address), so that we can examine it and maybe sight an issue that can be fixed.

    Thanks and good luck.

  3. #3
    Join Date
    Jul 2008
    Location
    Nottingham, UK
    Posts
    37

    Default Re: Sound only from headphones on laptop

    Thanks for the response, OldCPU. Here's the link:

    http://www.alsa-project.org/db/?f=23...53d2cf7dee9494

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,696
    Blog Entries
    38

    Default Re: Sound only from headphones on laptop

    Quote Originally Posted by colinpendred View Post

    Quote Originally Posted by colinpendred View Post
    I get sound from the headphone jack with no issues, but I simply cannot persuade my laptop to give me sound from the speakers. Except by booting into Windows.

    In Yast, I see there are two sound devices: Haswell HD and Lynx Point. Changing the default device has no effect. Installing Pavucontrol or using alsa mixer to ensure no channels are muted has no efffect. Fiddling with modprobe.d files has no effect. Nor permissions or anything else.
    I note this:
    Code:
    !!Aplay/Arecord output
    !!--------------------
    
    APLAY
    
    **** List of PLAYBACK Hardware Devices ****
    card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: PCH [HDA Intel PCH], device 0: ALC282 Analog [ALC282 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: PCH [HDA Intel PCH], device 1: ALC282 Digital [ALC282 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    and this:
    Code:
    !!Loaded ALSA modules
    !!-------------------
    
    snd_hda_intel
    snd_hda_intel
    The problem, as I see it could be because HDMI is identified as card-0 (ie default sound device) and analog/digital sound is card-1. Your audio applications will by default send sound to card-0, the HDMI device. Of course plugging in headphones is not impacted by that.

    You noted you tried to change default audio device. In turn I note to you that YaST will fail to do such if both HDMI and analog/digital audio use the same alsa sound module. In your PC's case they both use "snd_hda_intel" and hence your efforts there likely did not succeed. ie you did not achieve to change the two devices.

    You noted you tried fiddling with the 50-sound.conf (I assume) in the modprobe.d directory. My guess is you did not try what I am about to propose, which is I am going to propose forcing HDMI to be card-1 and analog/digital sound to be card-0, by specifying this specifically in the 50-sound.conf file.

    I note this:
    Code:
    !!Advanced information - PCI Vendor/Device/Subsystem ID's
    !!-------------------------------------------------------
    
    00:03.0 0403: 8086:0c0c (rev 06)
        Subsystem: 8086:2010
    --
    00:1b.0 0403: 8086:8c20 (rev 05)
        Subsystem: 1458:b556
    I assume the 8c20 is your analog/digital sound device, and the 0c0c is the HDMI.

    Try either replacing the /etc/modprobe.d/50-sound.conf entire file with the following (or place it at the start of the file) :
    Code:
    options snd_hda_intel index=0 model=auto vid=8086 pid=8c20
    options snd_hda_intel index=1 model=auto vid=8086 pid=0c0c
    Then save that, reboot and test. (Its possible that 'model=auto' is NOT needed in those lines).

    I am trying to force index=0 to 8c20 where I think index=0 means card-0 and 8c20 analog/digital sound device. And I am trying to force index=1 to 0c0c where I think index=1 means card-1 and 0c0c is HDMI audio.

    If you already tried that , I apologize for wasting your time. It was difficult to discern from your very general "Fiddling with modprobe.d files has no effect" (as I am ignoring that fiddling claim and telling you to try and fiddle some more). < gulp > Hopefully this is ok with you.
    .
    .
    Last edited by oldcpu; 13-May-2015 at 04:04.

  5. #5
    Join Date
    Jul 2008
    Location
    Nottingham, UK
    Posts
    37

    Default Re: Sound only from headphones on laptop

    This is one thing I did try previously by directly editing sound.conf, but to no avail. I followed your instructions any way, but still no sound. As you can see, the order of the cards is reversed.

    http://www.alsa-project.org/db/?f=8e...869f7dec117b92

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,696
    Blog Entries
    38

    Default Re: Sound only from headphones on laptop

    Quote Originally Posted by colinpendred View Post
    This is one thing I did try previously by directly editing sound.conf, but to no avail. I followed your instructions any way, but still no sound. As you can see, the order of the cards is reversed.

    http://www.alsa-project.org/db/?f=8e...869f7dec117b92
    When you say 'no sound' can you help me better understand what test you are doing to come to that conclusion ?

    Further, keep that edit in the file for now.

    Lets try some other things ... In the off chance pulse audio has a bad configuration, blocking sound through the speakers, if your PC has a /~pulse and a /~config/pulse directory, delete those and test.

  7. #7
    Join Date
    Jul 2008
    Location
    Nottingham, UK
    Posts
    37

    Default Re: Sound only from headphones on laptop

    By "no sound" I mean that I'd tested the sound in KDE's System Settings. The speaker-test scripts from the "SDB:Audio troubleshooting" article don't work either, whether as a regular user or superuser.

    I deleted the ~.config/pulse directory, but didn't have a ~/.pulse one, but still no luck.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,117
    Blog Entries
    1

    Default Re: Sound only from headphones on laptop

    Quote Originally Posted by colinpendred View Post
    By "no sound" I mean that I'd tested the sound in KDE's System Settings. The speaker-test scripts from the "SDB:Audio troubleshooting" article don't work either, whether as a regular user or superuser.

    I deleted the ~.config/pulse directory, but didn't have a ~/.pulse one, but still no luck.
    With the edited 50-sound.conf (as recommended by oldcpu), please run the diagnostic script again for us to review further.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,696
    Blog Entries
    38

    Default Re: Sound only from headphones on laptop

    Quote Originally Posted by colinpendred View Post
    By "no sound" I mean that I'd tested the sound in KDE's System Settings. The speaker-test scripts from the "SDB:Audio troubleshooting" article don't work either, whether as a regular user or superuser.

    I deleted the ~.config/pulse directory, but didn't have a ~/.pulse one, but still no luck.
    Have you also (with the 50-sound.conf file edit forcing card-0 to be analog sound) tried pavucontrol again ?

    Quote Originally Posted by colinpendred View Post
    This is one thing I did try previously by directly editing sound.conf, but to no avail.
    Did you try any of the model options from the HD-Audio-Models.txt file ? ie
    Code:
    ALC269/270/275/276/28x/29x
    ======
      laptop-amic        Laptops with analog-mic input
      laptop-dmic        Laptops with digital-mic input
      alc269-dmic        Enable ALC269(VA) digital mic workaround
      alc271-dmic        Enable ALC271X digital mic workaround
      inv-dmic        Inverted internal mic workaround
      lenovo-dock       Enables docking station I/O for some Lenovos
      dell-headset-multi    Headset jack, which can also be used as mic-in
      dell-headset-dock    Headset jack (without mic-in), and also dock I/O

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,005

    Default Re: Sound only from headphones on laptop

    YOu will have to restart after removing the puleaudio config/cache files

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •