Results 1 to 4 of 4

Thread: openSUSE-2015-21-1.noarch does not update

  1. #1

    Default openSUSE-2015-21-1.noarch does not update

    Hello, i upgraded from 12.3 to 13.1 and then to 13.2 (not sure if this is relevant, though).

    I get the update message for openSUSE-2015-21-1.noarch, but it is in conflict with other stuff:

    Code:
    Problem: patch:openSUSE-2015-21-1.noarch conflicts with rdesktop-debuginfo.x86_64 < 1.8.3-2.7.1 provided by rdesktop-debuginfo-1.7.1-5.1.1.x86_64
     Solution 1: Following actions will be done:
      deinstallation of rdesktop-debuginfo-1.7.1-5.1.1.x86_64
      deinstallation of rdesktop-debugsource-1.7.1-5.1.1.x86_64
     Solution 2: do not install patch:openSUSE-2015-21-1.noarch
    which one should i choose?

    Thanks

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: openSUSE-2015-21-1.noarch does not update

    unless you're debugging rdesktop I'd say remove both an ordinary user has no need for the debuginfo or debugsource packages, just run
    zypper rm rdesktop-debuginfo rdesktop-debugsource
    and then run zypper up
    or chose solution 1.

  3. #3

    Default Re: openSUSE-2015-21-1.noarch does not update

    And if you do want to have debuginfo packages installed (this is not only restricted to rsyslog), enable repo-debug-update as well in addition to repo-debug. That contains the debuginfo packages for the updates and would avoid those conflicts as the debuginfo packages could be updated together with the standard packages.

  4. #4

    Default Re: openSUSE-2015-21-1.noarch does not update

    That is what i thought, too, but better be sure.

    Thank you both.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •