Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: nothing provides libstdc++.so.6

  1. #1

    Default nothing provides libstdc++.so.6

    Since I am having problems with the java version of passwordsafeSWT, I thought I'd try Password Safe at sourceforge.

    I downloaded pwsafe-0.95.1BETA-3.x86_64.rpm which is packaged to run on Fedora. When I try to install it I get this error:

    Code:
    nothing provides libstdc++.so.6(CXXABI_1.3.8)(64bit) needed by pwsafe-0.95.1BETA-3.x86_64
    I have installed:
    Code:
    ls /usr/lib64/libstdc++*
    /usr/lib64/libstdc++.so.6  /usr/lib64/libstdc++.so.6.0.18
    I'm guessing that the installer is looking for those files in /usr/lib rather than lib64? Or is there more to it than this?

    Is there anything I can do to get this installed?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: nothing provides libstdc++.so.6

    On 2015-05-03 21:26, 6520302 wrote:

    > I'm guessing that the installer is looking for those files in /usr/lib
    > rather than lib64? Or is there more to it than this?


    Or... if it is trying to /build/ something, perhaps it wants the -devel
    version of the rpm. :-?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3

    Default Re: nothing provides libstdc++.so.6

    Quote Originally Posted by robin_listas View Post
    On 2015-05-03 21:26, 6520302 wrote:

    Or... if it is trying to /build/ something, perhaps it wants the -devel
    version of the rpm. :-?
    I have both rpm-devel & rpm-build installed. Is this what you mean?

    jon

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: nothing provides libstdc++.so.6

    I downloaded pwsafe-0.95.1BETA-3.x86_64.rpm which is packaged to run on Fedora
    that's your problem fedora uses different package names, why not get the opensuse version from here
    https://software.opensuse.org/package/passwordsafe
    https://build.opensuse.org/package/s...e=passwordsafe
    it's in the security repo you might need to add it.

    edit, you might force an rpm install and that app might run but that will cause a hell of lot other problems just use the opensuse rpm or build it yourself.

  5. #5

    Default Re: nothing provides libstdc++.so.6

    Beautiful, I didn't know about this repo. I'll check it out
    Thanks!!
    jon

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: nothing provides libstdc++.so.6

    On 2015-05-03 23:06, 6520302 wrote:
    >
    > robin_listas;2708118 Wrote:
    >> On 2015-05-03 21:26, 6520302 wrote:
    >>
    >> Or... if it is trying to /build/ something, perhaps it wants the -devel
    >> version of the rpm. :-?

    >
    > I have both rpm-devel & rpm-build installed. Is this what you mean?


    Close :-)

    Let me check, a minute...

    I have these:

    Code:
    minas-tirith:~ # rpm -qa | grep libstdc
    libstdc++-devel-4.8-2.1.2.x86_64
    libstdc++6-4.8.1_20130909-3.2.1.x86_64
    libstdc++6-32bit-4.8.1_20130909-3.2.1.x86_64
    libstdc++48-devel-4.8.1_20130909-3.2.1.x86_64
    minas-tirith:~ #
    (the versions might be different in your case; mine are for oS 13.1)

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7

    Default Re: nothing provides libstdc++.so.6

    Quote Originally Posted by I_A View Post
    that's your problem fedora uses different package names, why not get the opensuse version from here
    https://software.opensuse.org/package/passwordsafe
    https://build.opensuse.org/package/s...e=passwordsafe
    it's in the security repo you might need to add it.

    edit, you might force an rpm install and that app might run but that will cause a hell of lot other problems just use the opensuse rpm or build it yourself.
    Unfortunately that link is for v13.2, I am running v13.1
    The notes show it could not be built for v13.1?

  8. #8

    Default Re: nothing provides libstdc++.so.6

    Carlos:

    I too am running oS 13.1x64
    Mine are slightly different tho. That said, as noted earlier, the build for oS v13.1 doesn't work.

    I've been using the java version for a few years and it has suddenly stopped working. It usually runs after a reboot but once closed it won't reopen. It writes a log error file in /tmp.

    jon

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: nothing provides libstdc++.so.6

    the problem there is that wxWidgets 3.0 haven't been officially ported to 13.1,
    from the spec file
    BuildRequires: wxWidgets-devel >= 3
    as 13.1 is still supported wait until wxWidgets is updated and then you'll get a working passwordsafe
    or get a new version wxWidgets from here https://build.opensuse.org/package/s...=wxWidgets-3_0 do it your self.

  10. #10
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: nothing provides libstdc++.so.6

    I really don't get it as there doesn't seam to be a binary for wxWidgets 3.0 for any version 13.1 or 13.2, you might need to do this the hard way, build wxWidgets3.0 and then build passwordsafe

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •