Results 1 to 5 of 5

Thread: Python

  1. #1

    Default Python

    Sorry if been asked before, but did not really know where to look.

    Question is, I am trying to install Variety in Suse, but keep being advised, via answers in the Internet, that I need Python Pillow. Yes well, when I try to install same, get message that it will be be loaded, no reason given.

    Spent hours trying to get solution then, to my shame, remembered all you helpful people.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: Python

    People her may (try to) be helpful, but they are not clairvoyant. And the above is in fact no more then "It does not work". People need information!

    What version of openSUSE?

    You tried, but what exactly did you do? Like from where did you download what and what did you do with it, etc., etc.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: Python

    Looks like Python Pillow is available at software.opensuse.org as a Tumbleweed package. My guess is that it should work in any/all current supported versions of openSUSE... Just don't "enable" the repo so that only this one package and dependencies are installed and nothing else.
    http://software.opensuse.org/search?...SUSE%3AFactory

    As an alternative,
    It also looks like you can get it from the official (non-openSUSE) repositories, or get a python3 version.
    To pull packages from the Python repos, you use the utility "pip"
    Install pip as follows and then run the utility(there is also a python3 version if you want that)
    Code:
    zypper in python-pip
    HTH,
    TSU

  4. #4

    Default Re: Python

    Quote Originally Posted by leilton View Post
    Sorry if been asked before, but did not really know where to look.

    Question is, I am trying to install Variety in Suse, but keep being advised, via answers in the Internet, that I need Python Pillow. Yes well, when I try to install same, get message that it will be be loaded, no reason given.

    Spent hours trying to get solution then, to my shame, remembered all you helpful people.
    Hope this is correct way to reply to the answers I have seen.

    Running SUSE 13.1 GNOME.

    When I try to install from Software Manager, get message that nothing provides Python Pillow and it will not be installed.
    So, go on Internet, and get info must have Python-ppa, so install that, so cant get Variety, and every solution shown on the forum and on the internet, comes done to not having Python Pillow.

    Yes know I must appear to be dense, but not everyone is a computer genius, hoped that would like SUSE more than Ubuntu, butl its a lot more involved. Will persevere, but nice if could have all that should be available.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,071
    Blog Entries
    15

    Default Re: Python

    Hi
    Are you using the version of variety from my testing repository?

    You need to install python-Pillow from the devel:languages:python repository;

    Code:
    zypper ar -f http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_13.1/ "devel:languages:python"
    zypper ref
    zypper in python-Pillow
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •