Results 1 to 6 of 6

Thread: Need help w/ desktop shortcut problem

  1. #1

    Default Need help w/ desktop shortcut problem

    I have a shortcut on my desktop that has worked for years. It runs a /bin/sh script & starts a JRE app. The app still runs fine if I run it from the commandline in it's proper directory. It won't start from the commandline if I specify the full directory path.

    That is, if I cd /opt/directoryname, /bin/sh name.sh works fine.
    But if I do /bin/sh /opt/directoryname/name.sh it fails.....and this syntax is what I have in the desktop shortcut settings that fails.
    As said above, I've used the same shortcut for years.

    openSuse 13.1 x64, KDE 4.11.5

    java -version
    java version "1.7.0_55"
    OpenJDK Runtime Environment (IcedTea 2.4.8) (suse-24.17.1-x86_64)
    OpenJDK 64-Bit Server VM (build 24.55-b03, mixed mode)

    The app I'm trying to run is pwsafe, a password manager (PasswordSafeSWT-0.8.1-linux-x86_64.tar.gz).

    This is the beginning of the error JRE throws out:

    Code:
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    #  SIGSEGV (0xb) at pc=0x00007f870192827c, pid=4360, tid=140218405594880
    #
    # JRE version: OpenJDK Runtime Environment (7.0_55-b14) (build 1.7.0_55-b14)
    # Java VM: OpenJDK 64-Bit Server VM (24.55-b03 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C  [libgobject-2.0.so.0+0x3327c]  g_type_check_instance_cast+0x1c
    #
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    #
    # If you would like to submit a bug report, please include
    # instructions on how to reproduce the bug and visit:
    #   http://icedtea.classpath.org/bugzilla
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    
    ---------------  T H R E A D  ---------------
    
    Current thread (0x00007f871c00a000):  JavaThread "main" [_thread_in_native, id=4361, stack(0x00007f872431a000,0x00007f872441b000)]
    
    siginfo:si_signo=SIGSEGV: si_errno=0, si_code=1 (SEGV_MAPERR), si_addr=0x0000000000003e10
    The only thing I've recently changed is to enable Packman repository and do an update. Packman is now disabled again.

    Any ideas on why this might have started failing?
    thanks, Jon

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,504
    Blog Entries
    15

    Default Re: Need help w/ desktop shortcut problem

    On Fri 01 May 2015 08:46:01 PM CDT, 6520302 wrote:


    I have a shortcut on my desktop that has worked for years. It runs a
    /bin/sh script & starts a JRE app. The app still runs fine if I run it
    from the commandline in it's proper directory. It won't start from the
    commandline if I specify the full directory path.

    <snip>
    Hi
    What are the permissions on pwsafe.sh or the ~/.passwordsafe directory?

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Default Re: Need help w/ desktop shortcut problem

    ~/.passwordsafe
    Code:
    ls -l ~/.passwordsafe
    total 8
    -rw------- 1 jon users 511 May  1 09:14 preferences.properties
    -rw------- 1 jon users 571 May  1 13:39 widget.properties
    The script:
    Code:
    -rwxr-xr-x 1 jon  users   6877 Feb 23  2014 pwsafe.sh
    NOTE: I initially found it to be root:root and changed it to jon:users. It has made no difference. It still doesn't work.

    What I find odd is that it works from terminal if I change to the directory of pwsafe.sh

    Jon

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,504
    Blog Entries
    15

    Default Re: Need help w/ desktop shortcut problem

    On Sat 02 May 2015 12:06:01 AM CDT, 6520302 wrote:


    ~/.passwordsafe

    Code:
    --------------------
    ls -l ~/.passwordsafe
    total 8
    -rw------- 1 jon users 511 May 1 09:14 preferences.properties
    -rw------- 1 jon users 571 May 1 13:39 widget.properties
    --------------------


    The script:

    Code:
    --------------------
    -rwxr-xr-x 1 jon users 6877 Feb 23 2014 pwsafe.sh
    --------------------


    NOTE: I initially found it to be root:root and changed it to jon:users.
    It has made no difference. It still doesn't work.

    What I find odd is that it works from terminal if I change to the
    directory of pwsafe.sh

    Jon


    Hi
    Leaving as root:root is fine....

    You don't need to prefix it with /bin/sh the script has the whole
    shebang.

    In you shortcut just have /opt/directoryname/name.sh and try again,
    else create a test user and then create a shortcut, does that work? If
    it does then something is up as your user.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Default Re: Need help w/ desktop shortcut problem

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Leaving as root:root is fine....

    You don't need to prefix it with /bin/sh the script has the whole
    shebang.

    In you shortcut just have /opt/directoryname/name.sh and try again,
    else create a test user and then create a shortcut, does that work? If
    it does then something is up as your user.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    Thanks, I'll give those ideas a shot and get post results.
    jon

  6. #6

    Default Re: Need help w/ desktop shortcut problem

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Leaving as root:root is fine....
    OK, I will revert to that this weekend. I thought it may have been the problem but it wasn't.

    Quote Originally Posted by malcolmlewis View Post
    You don't need to prefix it with /bin/sh the script has the whole
    shebang.
    I wish that were true, but not here. Is there a place to set an association so I don't need to prefix it? Or maybe the script is meant to be edited as required, I never did that. But then again, it has always worked fine, for several years.....
    Code:
    ls -l
    total 200
    -rw-r--r-- 1 jon root    1839 Feb 23  2014 jpwsafe_32.xpm
    -rw-r--r-- 1 jon root    3108 Feb 23  2014 jpwsafe_48.xpm
    drwxr-xr-x 2 jon root    4096 Feb 23  2014 lib
    -rw-r--r-- 1 jon root    9174 Feb 23  2014 LICENSE
    -rw-r--r-- 1 jon root  169776 Feb 23  2014 PasswordSafeSWT.jar
    -rwxr-xr-x 1 jon users   6877 Feb 23  2014 pwsafe.sh
    jon@linux-shpr:/opt/PasswordSafeSWT-0.8.1> pwsafe.sh
    If 'pwsafe.sh' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf pwsafe.sh
    jon@linux-shpr:/opt/PasswordSafeSWT-0.8.1>
    On a different note, when adding a new user to test my problem, I note that the default login script is /bin/bash. Is that in reference only to login or is that some kind of global setting? At any rate, I tried changing the desktop shortcut from sh to bash and it still fails.

    Quote Originally Posted by malcolmlewis View Post
    In you shortcut just have /opt/directoryname/name.sh and try again,
    else create a test user and then create a shortcut, does that work? If
    it does then something is up as your user.
    That doesn't work. Neither does a new test user.

    I can post the desktop ~/.local/share/applications/pwsafe.desktop contents if you think that might be useful.

    I've rechecked for a typo many times, I don't find one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •