Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Dolphin getting slower

  1. #1

    Default Dolphin getting slower

    In the last few weeks I find that Dolphin is getting slower, there is a noticeable lag when opening it and sometimes when I close it I wait a long time (well, more than 10 seconds...I didn't time it).

    I'm not (or don't think I am) running the indexer app.

    openSuse 13.1x64, 4gb ram, KDE 4.11.5

    I saw a prior post recommending disable of a file plugin but I don't see that in Services so I don't think I'm running that.

    Looking for ideas on what I might try to correct this issue.

    jon

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Dolphin getting slower

    run top in a console and see if some process is hogging the CPU

  3. #3

    Default Re: Dolphin getting slower

    I forgot about top....My biggest got is Firefox, at 4%. Everything together is well under 10%

    I recently downloaded a 1.4gb .iso that is in a different directory. After deleting that file and emptying the trash things are much better. I'll see how it goes after my next startup.

    Thanks.
    jon

  4. #4

    Default Re: Dolphin getting slower

    A few suggestions:

    Maybe may have some weird preview enabled and it's trying to preview some large file. Although granted I've had some huge files and preview never took more than 1-2 seconds per file. Check Dolphin -> Control -> Configure Dolphin -> General -> Previews. Make sure you only have what you want/need selected - also, I would suggest settings remote max to something low, like 5MB.

    Also, make sure you have plenty of space:
    df -h

    And make sure you're thumbnails cache is not going crazy:
    du -sh ~/.thumbnails/

    If it is, you can always delete it. You apps will then have to re-do all thumbnails, but that may be a good compromise.

    There's no reason why an ISO should slow down dolphin. It should not be previewing it, maybe, maybe you have some Dolhpin addon that handles ISO files and it's badly coded?

  5. #5

    Smile Re: Dolphin getting slower

    Quote Originally Posted by winski View Post
    A few suggestions:

    Maybe may have some weird preview enabled and it's trying to preview some large file. Although granted I've had some huge files and preview never took more than 1-2 seconds per file. Check Dolphin -> Control -> Configure Dolphin -> General -> Previews. Make sure you only have what you want/need selected - also, I would suggest settings remote max to something low, like 5MB.

    Also, make sure you have plenty of space:
    df -h

    And make sure you're thumbnails cache is not going crazy:
    du -sh ~/.thumbnails/

    If it is, you can always delete it. You apps will then have to re-do all thumbnails, but that may be a good compromise.

    There's no reason why an ISO should slow down dolphin. It should not be previewing it, maybe, maybe you have some Dolhpin addon that handles ISO files and it's badly coded?
    winski:

    Thanks for these tips. When I check the Previews I have checked only folders, images, & jpeg images. The remote max was set to 0 which is lower than 5mb. I changed it to 5mb because it seems that it may be useful. That said, the only remote connections I have are not automatic and they are internal network via smb.

    I'm pretty much a default kind of guy, I have no Dolphin addon's that I am aware of. I suppose it's possible that some could have been added without my direct knowledge, just like those folks that inadvertently change their browser search toolbar. I went ahead and deleted the .iso since I have burned it, using the default app K3b.

    Code:
    df -h
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/sda6        20G   13G  6.5G  66% /
    devtmpfs        3.9G   40K  3.9G   1% /dev
    tmpfs           3.9G  1.1M  3.9G   1% /dev/shm
    tmpfs           3.9G  1.1M  3.9G   1% /run
    tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
    tmpfs           3.9G  1.1M  3.9G   1% /var/lock
    tmpfs           3.9G  1.1M  3.9G   1% /var/run
    /dev/sda7       890G  424G  465G  48% /home
    That doesn't seem too tight on space.

    Code:
    du -sh ~/.thumbnails/
    646M    /home/jon/.thumbnails/
    I don't know if 646M is too much thumbnail overhead or not. I do notice that when opening dolphin I sometimes need to wait 10-15 sec or longer before my last mouse click responds, say, to opening a folder or text file. I do have indexing disabled so maybe that is slowing things down?

    I notice when I open dolphin, on the right side of the screen there is an info panel with some details about the current selected object. I have to wait until it updates, as shown by a brief flicker of screen refresh, before I can actually do anything in dolphin.

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Dolphin getting slower

    Try this, see if it helps.

    Close all instances of Dolphin.

    Open a terminal window.

    At the command line, do:
    Code:
    cd ~/.kde4/share/config/
    Then:
    Code:
    mv dolphinrc dolphinrc.bak
    This will remove your Dolphin configurations (actually, it will rename your Dolphin configuration to a backup file in case you decide to restore it).

    Now, launch Dolphin (it will have the raw defaults, ready to reconfigure if you so desire).

    See if that helps.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7

    Default Re: Dolphin getting slower

    Gerry:

    Thanks, unfortunately, that did not help. It takes me 24 sec after Dolphin opens until I can scroll the window. And if I change directories it takes at least 12 sec before I can scroll.

    Also, now it frequently freezes and I have to terminate. I looked for some kind of log file but cannot find one... nothing in /var/log/messages.

    I'm starting to consider either fresh install, moving from 13.1 -> 13.2 or maybe a restore from a 3 week old backup. I've never restored an entire system so I'm not sure how that will handle locked files, kernel, etc. My backup was w/ LuckyBackup to external hard drive.

    jon

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Dolphin getting slower

    Quote Originally Posted by 6520302 View Post
    Gerry:

    Thanks, unfortunately, that did not help. It takes me 24 sec after Dolphin opens until I can scroll the window. And if I change directories it takes at least 12 sec before I can scroll.

    Also, now it frequently freezes and I have to terminate. I looked for some kind of log file but cannot find one... nothing in /var/log/messages.

    I'm starting to consider either fresh install, moving from 13.1 -> 13.2 or maybe a restore from a 3 week old backup. I've never restored an entire system so I'm not sure how that will handle locked files, kernel, etc. My backup was w/ LuckyBackup to external hard drive.

    jon
    ... just a thought, a wild stab:

    Try running diagnostics on the HD and on the memory.

    Do you see any lags anywhere else besides in Dolphin?
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  9. #9
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Dolphin getting slower

    ... and, what do you have in /var/log/messages?
    Code:
    ls -l -a /var/log/messages
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  10. #10

    Default Re: Dolphin getting slower

    Quote Originally Posted by Fraser_Bell View Post
    ... and, what do you have in /var/log/messages?
    Code:
    ls -l -a /var/log/messages
    This is the end of messages. Lot of stuff trying to start bluetooth. My problems seemed to be worse after making some changes based on info in a blog posting about getting BT running. Initially I enabled Packman repo (now disabled) and installed a bunch of stuff designed to get BT working (it didn't work for me). So now BT service is continually trying to start and fails. Perhaps this is related?

    Code:
    2015-05-03T08:59:18.047118-07:00 linux-shpr bluetoothd[3251]: Starting SDP server
    2015-05-03T08:59:18.047341-07:00 linux-shpr systemd[1]: Started Bluetooth service.
    2015-05-03T08:59:18.047559-07:00 linux-shpr bluetoothd[3251]: Bluetooth management interface 1.3 initialized
    2015-05-03T08:59:18.049513-07:00 linux-shpr kernel: [   59.393283] bluetoothd[3251]: segfault at 0 ip 00007ff45f503066 sp 00007ffd7a3f8ca0 error 4 in bluetoothd[7ff45f4ce000+a4000]
    2015-05-03T08:59:18.048249-07:00 linux-shpr systemd[1]: bluetooth.service: main process exited, code=killed, status=11/SEGV
    2015-05-03T08:59:18.048551-07:00 linux-shpr systemd[1]: Unit bluetooth.service entered failed state.
    2015-05-03T08:59:18.048849-07:00 linux-shpr dbus[889]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
    2015-05-03T08:59:18.049185-07:00 linux-shpr systemd[1]: Starting Bluetooth service...
    2015-05-03T08:59:18.050335-07:00 linux-shpr bluetoothd[3253]: Bluetooth daemon 5.8
    2015-05-03T08:59:18.051212-07:00 linux-shpr dbus[889]: [system] Successfully activated service 'org.bluez'
    2015-05-03T08:59:18.051502-07:00 linux-shpr systemd[1]: Started Bluetooth service.
    2015-05-03T08:59:18.051906-07:00 linux-shpr bluetoothd[3253]: Starting SDP server
    2015-05-03T08:59:18.052359-07:00 linux-shpr bluetoothd[3253]: Bluetooth management interface 1.3 initialized
    2015-05-03T08:59:18.052967-07:00 linux-shpr systemd[1]: bluetooth.service: main process exited, code=killed, status=11/SEGV
    2015-05-03T08:59:18.053254-07:00 linux-shpr systemd[1]: Unit bluetooth.service entered failed state.
    2015-05-03T08:59:18.053304-07:00 linux-shpr kernel: [   59.398088] bluetoothd[3253]: segfault at 0 ip 00007f177c334066 sp 00007ffcfd7d7d70 error 4 in bluetoothd[7f177c2ff000+a4000]
    2015-05-03T08:59:18.054161-07:00 linux-shpr dbus[889]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
    2015-05-03T08:59:18.054372-07:00 linux-shpr systemd[1]: Starting Bluetooth service...
    2015-05-03T08:59:18.054544-07:00 linux-shpr systemd[1]: bluetooth.service start request repeated too quickly, refusing to start.
    2015-05-03T08:59:18.054723-07:00 linux-shpr systemd[1]: Failed to start Bluetooth service.
    2015-05-03T08:59:20.994662-07:00 linux-shpr systemd[1]: Starting Stop Read-Ahead Data Collection...
    2015-05-03T08:59:20.995999-07:00 linux-shpr systemd[1]: Started Stop Read-Ahead Data Collection.
    2015-05-03T08:59:43.063147-07:00 linux-shpr dbus[889]: [system] Failed to activate service 'org.bluez': timed out
    2015-05-03T09:00:01.268579-07:00 linux-shpr systemd[1]: Starting user-0.slice.
    2015-05-03T09:00:01.387390-07:00 linux-shpr systemd[1]: Created slice user-0.slice.
    2015-05-03T09:00:01.387813-07:00 linux-shpr systemd[1]: Starting User Manager for 0...
    2015-05-03T09:00:01.388086-07:00 linux-shpr systemd[1]: Starting Session 2 of user root.
    2015-05-03T09:00:01.388357-07:00 linux-shpr systemd[1]: Started Session 2 of user root.
    2015-05-03T09:00:01.388608-07:00 linux-shpr systemd[3495]: Failed to open private bus connection: Failed to connect to socket /run/user/0/dbus/user_bus_socket: No such file or directory
    2015-05-03T09:00:01.403346-07:00 linux-shpr systemd[3495]: Mounted /sys/fs/fuse/connections.
    2015-05-03T09:00:01.403568-07:00 linux-shpr systemd[3495]: Stopped target Bluetooth.
    2015-05-03T09:00:01.403744-07:00 linux-shpr systemd[3495]: Stopped target Sound Card.
    2015-05-03T09:00:01.403906-07:00 linux-shpr systemd[3495]: Starting Default.
    2015-05-03T09:00:01.404069-07:00 linux-shpr systemd[3495]: Reached target Default.
    2015-05-03T09:00:01.404227-07:00 linux-shpr systemd[3495]: Startup finished in 90ms.
    2015-05-03T09:00:01.404396-07:00 linux-shpr systemd[1]: Started User Manager for 0.
    2015-05-03T09:00:01.472048-07:00 linux-shpr run-crons[3498]: suse.de-snapper: OK
    2015-05-03T09:00:01.488911-07:00 linux-shpr systemd[1]: Stopping User Manager for 0...
    2015-05-03T09:00:01.502524-07:00 linux-shpr systemd[3495]: Stopping Default.
    2015-05-03T09:00:01.502752-07:00 linux-shpr systemd[3495]: Stopped target Default.
    2015-05-03T09:00:01.502928-07:00 linux-shpr systemd[3495]: Starting Shutdown.
    2015-05-03T09:00:01.503107-07:00 linux-shpr systemd[3495]: Reached target Shutdown.
    2015-05-03T09:00:01.503324-07:00 linux-shpr systemd[3495]: Starting Exit the Session...
    2015-05-03T09:00:01.519925-07:00 linux-shpr systemd[1]: Stopped User Manager for 0.
    2015-05-03T09:00:01.520189-07:00 linux-shpr systemd[1]: Stopping user-0.slice.
    2015-05-03T09:00:01.520395-07:00 linux-shpr systemd[1]: Removed slice user-0.slice.
    When I started Dolphin a few minutes ago it seemed snappy enough, it started in 12 sec and I could traverse various directory tree's without delay. When I closed it, it closed properly and left no entries in /var/log/messages. Then again, the system is just freshly booted with no activity. My most common activities are with Firefox & Thunderbird, which I typically leave running for the duration of a session. Last night I closed both and still had problems with Dolphin. Top shows no excessive CPU activity. I have 8gb ram so I don't suspect ram to be a problem.

    I haven't run any diagnostics yet (I need to research how to do that).

    Other apps seem to work as expected. Since I cannot get BT working perhaps all I need to do is disable the service and this thing will settle down?

    Thanks, Jon

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •