Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Installing Spotify on 13.2

  1. #1

    Default Installing Spotify on 13.2

    I have searched the internet restlessly for a way to properly install Spotify on openSUSE 13.2, but so far haven't been able to find one that works. I tried pretty much everything I could find. Does anyone know how to do this?
    Thanks very much, anyway.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Installing Spotify on 13.2

    Did you search Yast-software management?

    I see a spotify installer in the packman repo

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: Installing Spotify on 13.2

    On Wed, 29 Apr 2015 15:26:01 +0000, mtbisc wrote:

    > I have searched the internet restlessly for a way to properly install
    > Spotify on openSUSE 13.2, but so far haven't been able to find one that
    > works. I tried pretty much everything I could find. Does anyone know how
    > to do this?
    > Thanks very much, anyway.


    I have got it working on my desktop (in fact, listening to something on
    the latest build right now).

    I'll have to dig around a bit and see which installer I used the last
    time - I've got a few versions on my system. The primary maintainer
    (aspiers) indicates that the scripts are currently broken, but there a
    few forks that apply various fixes. As I recall, when I last updated my
    installation, I had to manually tweak the spec file.

    I'll try to find some time tonight (or as late as this weekend) to see if
    I can work out what exactly I did.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: Installing Spotify on 13.2

    On Wed, 29 Apr 2015 15:46:02 +0000, gogalthorp wrote:

    > Did you search Yast-software management?
    >
    > I see a spotify installer in the packman repo


    As I recall, it doesn't use the latest Spotify packages.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: Installing Spotify on 13.2

    On Wed, 29 Apr 2015 15:41:36 +0000, Jim Henderson wrote:

    > On Wed, 29 Apr 2015 15:26:01 +0000, mtbisc wrote:
    >
    >> I have searched the internet restlessly for a way to properly install
    >> Spotify on openSUSE 13.2, but so far haven't been able to find one that
    >> works. I tried pretty much everything I could find. Does anyone know
    >> how to do this?
    >> Thanks very much, anyway.

    >
    > I have got it working on my desktop (in fact, listening to something on
    > the latest build right now).
    >
    > I'll have to dig around a bit and see which installer I used the last
    > time - I've got a few versions on my system. The primary maintainer
    > (aspiers) indicates that the scripts are currently broken, but there a
    > few forks that apply various fixes. As I recall, when I last updated my
    > installation, I had to manually tweak the spec file.
    >
    > I'll try to find some time tonight (or as late as this weekend) to see
    > if I can work out what exactly I did.


    Actually, I think I just sorted it out...

    I used the script from:

    https://github.com/nesnomis/opensuse-spotify-installer

    But made the following changes:

    1. In the install-spotify.sh script, I changed the version from
    0.9.10.17.g4129e1c.78-1 to 0.9.17.1.g9b85d43.7-1 (this is the VERSION
    setting).

    2. In the spotify-client.spec file, I also changed the version to match,
    and had to change the compression algorithms used in the tar commands -
    the following diff captures the changes:

    Code:
    @@ -67,9 +67,9 @@ It includes the following features:
    # unpack deb
    ar -x %{SOURCE0}
    # unpack data
    -tar -xzf data.tar.gz
    +tar -xJf data.tar.xz
    # remove used files
    -rm {control,data}.tar.gz debian-binary
    +rm data.tar.xz debian-binary
    3. The script downloads the .spec file from the github repository; I
    manually copied the .spec file to the proper build location - as I
    recall, the script didn't overwrite it because it already existed (my
    diff on the script doesn't show that I removed the download operation)

    4. Run the script.

    That *should* get it built and installed, or at least get you on the
    right path.

    Jim




    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  6. #6

    Default Re: Installing Spotify on 13.2

    Quote Originally Posted by hendersj View Post
    On Wed, 29 Apr 2015 15:41:36 +0000, Jim Henderson wrote:

    > On Wed, 29 Apr 2015 15:26:01 +0000, mtbisc wrote:
    >
    >> I have searched the internet restlessly for a way to properly install
    >> Spotify on openSUSE 13.2, but so far haven't been able to find one that
    >> works. I tried pretty much everything I could find. Does anyone know
    >> how to do this?
    >> Thanks very much, anyway.

    >
    > I have got it working on my desktop (in fact, listening to something on
    > the latest build right now).
    >
    > I'll have to dig around a bit and see which installer I used the last
    > time - I've got a few versions on my system. The primary maintainer
    > (aspiers) indicates that the scripts are currently broken, but there a
    > few forks that apply various fixes. As I recall, when I last updated my
    > installation, I had to manually tweak the spec file.
    >
    > I'll try to find some time tonight (or as late as this weekend) to see
    > if I can work out what exactly I did.


    Actually, I think I just sorted it out...

    I used the script from:

    https://github.com/nesnomis/opensuse-spotify-installer

    But made the following changes:

    1. In the install-spotify.sh script, I changed the version from
    0.9.10.17.g4129e1c.78-1 to 0.9.17.1.g9b85d43.7-1 (this is the VERSION
    setting).

    2. In the spotify-client.spec file, I also changed the version to match,
    and had to change the compression algorithms used in the tar commands -
    the following diff captures the changes:

    Code:
    @@ -67,9 +67,9 @@ It includes the following features:
    # unpack deb
    ar -x %{SOURCE0}
    # unpack data
    -tar -xzf data.tar.gz
    +tar -xJf data.tar.xz
    # remove used files
    -rm {control,data}.tar.gz debian-binary
    +rm data.tar.xz debian-binary
    3. The script downloads the .spec file from the github repository; I
    manually copied the .spec file to the proper build location - as I
    recall, the script didn't overwrite it because it already existed (my
    diff on the script doesn't show that I removed the download operation)

    4. Run the script.

    That *should* get it built and installed, or at least get you on the
    right path.

    Jim




    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C
    Thanks so much!
    So, I tried following your steps and got this error:
    About to build spotify-client rpm; please be patient ...

    Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.2HhBb7
    + umask 022
    + cd /home/eagle/rpmbuild/BUILD
    + cd /home/eagle/rpmbuild/BUILD
    + rm -rf spotify-client-0.9.11.27.g2b1a638.81
    + /usr/bin/mkdir -p spotify-client-0.9.11.27.g2b1a638.81
    + cd spotify-client-0.9.11.27.g2b1a638.81
    + /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
    + ar -x /home/eagle/rpmbuild/SOURCES/spotify-client_0.9.11.27.g2b1a638.81-1_amd64.deb
    ar: /home/eagle/rpmbuild/SOURCES/spotify-client_0.9.11.27.g2b1a638.81-1_amd64.deb: File format not recognized
    error: Bad exit status from /var/tmp/rpm-tmp.2HhBb7 (%prep)


    RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.2HhBb7 (%prep)
    rpmbuild -ba /usr/src/packages/SPECS/spotify-client.spec failed! Aborting.
    I got the same thing on one of my attemps to install it before, no idea why.

  7. #7
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: Installing Spotify on 13.2

    On Wed, 29 Apr 2015 16:26:01 +0000, mtbisc wrote:

    > Thanks so much!
    > So, I tried following your steps and got this error:
    >
    > About to build spotify-client rpm; please be patient ...
    >
    > Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.2HhBb7 + umask 022 + cd
    > /home/eagle/rpmbuild/BUILD + cd /home/eagle/rpmbuild/BUILD + rm -rf
    > spotify-client-0.9.11.27.g2b1a638.81 + /usr/bin/mkdir -p
    > spotify-client-0.9.11.27.g2b1a638.81 + cd
    > spotify-client-0.9.11.27.g2b1a638.81 + /usr/bin/chmod -Rf
    > a+rX,u+w,g-w,o-w .
    > + ar -x
    > /home/eagle/rpmbuild/SOURCES/spotify-

    client_0.9.11.27.g2b1a638.81-1_amd64.deb
    > ar:
    > /home/eagle/rpmbuild/SOURCES/spotify-

    client_0.9.11.27.g2b1a638.81-1_amd64.deb:
    > File format not recognized error: Bad exit status from
    > /var/tmp/rpm-tmp.2HhBb7 (%prep)
    >
    >
    > RPM build errors:
    > Bad exit status from /var/tmp/rpm-tmp.2HhBb7 (%prep)
    > rpmbuild -ba /usr/src/packages/SPECS/spotify-client.spec failed!
    > Aborting.
    >
    >
    > I got the same thing on one of my attemps to install it before, no idea
    > why.


    What version of ar is on your system?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  8. #8

    Default Re: Installing Spotify on 13.2

    Quote Originally Posted by hendersj View Post
    What version of ar is on your system?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C
    Version 2.24.0.20140403-6.1

  9. #9
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: Installing Spotify on 13.2

    On Wed, 29 Apr 2015 19:26:02 +0000, mtbisc wrote:

    > hendersj;2707436 Wrote:
    >>
    >> What version of ar is on your system?
    >>
    >> Jim
    >>
    >>
    >>
    >> --
    >> Jim Henderson openSUSE Forums Administrator Forum Use Terms &
    >> Conditions at http://tinyurl.com/openSUSE-T-C

    >
    > Version 2.24.0.20140403-6.1


    That's the version I have. Does an "rpm -V" of binutils report any
    issues related to it?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  10. #10

    Default Re: Installing Spotify on 13.2

    Quote Originally Posted by hendersj View Post


    That's the version I have. Does an "rpm -V" of binutils report any
    issues related to it?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C
    Nope, doesn't report anything

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •