Results 1 to 9 of 9

Thread: OCtave Not On GUI Menu and Does Not Run in GUI

  1. #1

    Default OCtave Not On GUI Menu and Does Not Run in GUI

    Hi,

    I installed from YAST - Octave, but there are no GUI icons in the menus - so can someone assist on how to place an icon within the GUI menu system ?. Thanks.

    Also, Octave does not start any GUI windows - it did before when i had Opensuse 13.1, now on OpenSuse 13.2 - no GUI windows appearing, but i can see the program running as a process in a terminal window.

    Any ideas ?.

    Thanks and regards,

    Shadders.

  2. #2

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    shadders,

    There is a gui for octave available. It is noted as experimental. It is available as a separate package from octave and is obtained from the 13.2/science repository. It is named octave-gui

    It gets installed into the /usr/lib..... directory. Most likely should be in the /usr/bin.... directory with the other executable guis and more easily found by environment. Rather than move octave-gui around to make it more easy to run as a user, I created a launcher using alacarte menu editor.

    I use mate desktop and octave-gui is in both mate menu and gnome menu under programming.

    I am using the launcher command of:

    "gnome-terminal -x /usr/lib/octave/3.8.2/exec/i586-suse-linux-gnu/octave-gui"

    With limited testing I believe the gui is functional when accessed in the above manner.

    Hope this helps,
    Tom Kosvic

  3. #3

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    Hi Tom,

    Thanks - yes - i can see the /usr/bin entries - and can run Octave from the terminal window - but i am sure that Opensuse 13.1 it was working with the GUI automatically.

    I am using KDE - so not sure about the mate desktop aspect.

    If i check YAST - there is an Octave-gui package installed - so not sure why it is not being run.

    I do not have the sub directory as you have indicated.

    I have searched Ocatve.org for a bug report - but there is none listed for opensuse.

    As such - no gui listed in /usr/bin for octave.

    Any ideas - how Octave gui would run for a KDE installation ?.

    Thanks and regards,

    Shadders.

  4. #4

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    Hi,

    Just reinstalled - still the same issue, only the cli is run.

    Any ideas on who to contact for this ? as it seems to be a bug ?

    Regards,

    Shadders.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    On 2015-04-26 20:56, shadders wrote:
    >
    > Hi,
    >
    > Just reinstalled - still the same issue, only the cli is run.


    The gui for 3.11 is installed in
    /usr/lib64/octave/3.8.2/exec/x86_64-suse-linux-gnu

    There is no desktop file, so you don't get a menu entry for it.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    Hi Carlos,

    Thank you very much - i ran the program and now have the GUI open and running - functioning too.

    How would i then add a GUI icon to the desktop and menu system ?.

    In general - how would this be done for any program ?

    Is there an online resource explaining this ?

    Thanks and regards,

    Shadders.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    On 2015-04-27 18:36, shadders wrote:
    > How would i then add a GUI icon to the desktop and menu system ?.


    I have done this, but I don't remember offhand. Typically I don't bother
    to do it.

    The menus are created automatically, by reading files with the .desktop
    extension that packagers include in the rpms. For instance, krusader has
    "/usr/share/applications/kde4/krusader.desktop":

    Code:
    cer@minas-tirith:~> cat /usr/share/applications/kde4/krusader.desktop
    [Desktop Entry]
    X-SuSE-translate=true
    Name=Krusader
    Exec=krusader -caption "%c" %i
    Icon=krusader_user
    Terminal=false
    Type=Application
    X-DocPath=krusader/index.html
    Categories=FileManager;Utility;Qt;KDE;
    Comment=Twin-Panel File Manager
    GenericName=File Manager
    
    cer@minas-tirith:~>

    I think that you would have to create your file under
    /usr/local/share/applications


    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8
    Join Date
    Jan 2010
    Location
    Russia
    Posts
    100

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    Quote Originally Posted by shadders View Post
    I installed from YAST - Octave, but there are no GUI icons in the menus - so can someone assist on how to place an icon within the GUI menu system ?
    I expect you are using version 3.8 of Octave. This version has experimental GUI, not very stable. You can use "octave --force-gui" command, see "2.1.1 Command Line Options" from manual. Octave 4.0 has stable GUI with .desktop file.

  9. #9

    Default Re: OCtave Not On GUI Menu and Does Not Run in GUI

    Hi Carlos, Dmitry,

    Thanks for the response.

    Regards,

    Shadders.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •