Results 1 to 10 of 10

Thread: OpenSuse 13.2 KDE not play wav files

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default OpenSuse 13.2 KDE not play wav files

    I recently installed the OpenSuse 13.2 32-bit with KDE

    Mp3 music files are OK, but I can not open any wav file

    How do I do I hear wav files in openSUSE 13.2?

    Tanks in advance

  2. #2

    Default Re: OpenSuse 13.2 KDE not play wav files

    Quote Originally Posted by sergelli View Post
    Mp3 music files are OK, but I can not open any wav file
    And which application(s) have you tried to play them with?

    Most media players should have no problem playing back wav files though.

  3. #3
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: OpenSuse 13.2 KDE not play wav files

    I try open with Amarok and fail.
    The ThunderBird no more plays the sound alert.wav when receiving a message

  4. #4
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: OpenSuse 13.2 KDE not play wav files

    When I click on a file within the Dolphin, amarok is open to run the file but do not hear the sound and the file does not enter to the playlist.
    I have the same problem if I try open the file (with the dolphin) using "Open With" and choose the Dolphin.

    When I open the file by using the Amarok "Add Media", the file enters the playlist and when I click here the sound appears.

    I do not understand what is happening.
    Being able to play wav sounds, but not the normal way.

    Can you tell what to do?

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,617
    Blog Entries
    3

    Default Re: OpenSuse 13.2 KDE not play wav files

    Quote Originally Posted by sergelli View Post
    When I click on a file within the Dolphin, amarok is open to run the file but do not hear the sound and the file does not enter to the playlist.
    Is there something funky about that file?

    What's the output from:
    Code:
    file filename.wav
    I just tested this. I get:
    Code:
    % file *.wav
    NEW YORK-Today, 0303 PM.wav: RIFF (little-endian) data, WAVE audio, ITU G.711 mu-law, mono 8000 Hz
    This is downloaded voice mail file (probable scam).

    I click on it in Dolphin, and it plays in Amarok (and is added to playlist).

    Or I right click in Dolphin, and select to open with Amarok. Again, it plays and is added to the playlist.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: OpenSuse 13.2 KDE not play wav files

    Although there is no apparent reason.... the sound returned to work well with wav files.

    I'm embarrassed. I know that things happened exactly as reported, but made me look like an idiot.

    I'm sorry for using your time unnecessarily.

    Thanks for the help.

  7. #7

    Default Re: OpenSuse 13.2 KDE not play wav files

    In addition to what nrickert already wrote:
    Quote Originally Posted by sergelli View Post
    I try open with Amarok and fail.
    And how did you try? With the right-click "Open With" menu?

    The ThunderBird no more plays the sound alert.wav when receiving a message
    No idea what Thunderbird uses to play that sound, but that's definitely unrelated to KDE and/or Amarok.

    Quote Originally Posted by sergelli View Post
    I have the same problem if I try open the file (with the dolphin) using "Open With" and choose the Dolphin.
    You cannot open a WAV file with dolphin. Dolphin is a file manager, not a media player.

    When I open the file by using the Amarok "Add Media", the file enters the playlist and when I click here the sound appears.
    So it actually does play, and just doesn't when you click on it in Dolphin?
    Then probably just the file association is wrong. (as nrickert indicated, you can right-click on the file on choose a different entry in "Open With")

    Please do the following:
    - right-click on a WAV file in Dolphin and choose "Properties"
    - click on "File Type Options"
    What entries do you have there in "Application Preference Order"?
    Select the top-most entry, click on "Edit" and post what it says under "Command" in the "Application" tab, and what name and "Location" you see on the "General" tab.

    You could move a different entry to the top if you wanted to.

  8. #8
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: OpenSuse 13.2 KDE not play wav files

    Thank you Wolfi, but the wav files again be opened normally, without any apparent reason.

  9. #9

    Default Re: OpenSuse 13.2 KDE not play wav files

    Quote Originally Posted by sergelli View Post
    Thank you Wolfi, but the wav files again be opened normally, without any apparent reason.
    Yes, I saw your post after I replied.

    Maybe somehow caused by the broken pulseaudio update? But then sound shouldn't have worked at all...
    Maybe you installed some other updates? This can temporarily cause an inconsistent state sometimes. It's often a good idea to logout or even reboot after installing updates, especially if they affect the desktop or some lower levels.
    Last edited by wolfi323; 24-Apr-2015 at 02:00.

  10. #10
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    467

    Default Re: OpenSuse 13.2 KDE not play wav files

    Quote Originally Posted by wolfi323 View Post
    It's often a good idea to logout or even reboot after installing updates, especially if they affect the desktop or some lower levels.
    Yes, you're right. The problem happened after an update made yesterday and today normalized.
    Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •