Results 1 to 8 of 8

Thread: MySQL Start "Something went wrong"

  1. #1
    Join Date
    Apr 2014
    Location
    Kampala, Uganda
    Posts
    95

    Default MySQL Start "Something went wrong"

    Hi guys,

    I tried to enable/start MySQL for the first time today but got this error message

    Code:
    Doofenshmirtz:~ # systemctl status mysql.service
    mysql.service - MySQL server
       Loaded: loaded (/usr/lib/systemd/system/mysql.service; enabled)
       Active: active (running) since Wed 2015-04-22 13:06:56 EAT; 5min ago
      Process: 14824 ExecStop=/usr/lib/mysql/rcmysql stop (code=exited, status=0/SUCCESS)
      Process: 14958 ExecStart=/usr/lib/mysql/rcmysql start (code=exited, status=0/SUCCESS)
     Main PID: 15020 (mysqld_safe)
       CGroup: /system.slice/mysql.service
               ├─15020 /bin/sh /usr/bin/mysqld_safe --mysqld=mysqld --user=mysql --pid-file=/var/run/mysql/mysqld.pid --socket=/var/run/mysql/mysql.sock --datadir=/var/lib/mysql
               └─15116 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --user=mysql --log-error=/var/lib/mysql/Doofenshmirtz.err --pid-file=/var/ru...
    
    Apr 22 13:06:56 Doofenshmirtz rcmysql[14958]: Starting service MySQL Something went wrong
    I'm running

    Code:
    NAME=openSUSE
    VERSION="13.2 (Harlequin)"
    VERSION_ID="13.2"
    PRETTY_NAME="openSUSE 13.2 (Harlequin) (x86_64)"
    ID=opensuse
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:opensuse:13.2"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://opensuse.org/"
    ID_LIKE="suse"
    Please help.

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: MySQL Start "Something went wrong"

    It's enabled and running.

    Try: mysqladmin -u root -p status

    It'll ask for your MySQL root password, if you've never set it just press enter.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    Apr 2014
    Location
    Kampala, Uganda
    Posts
    95

    Default Re: MySQL Start "Something went wrong"

    Quote Originally Posted by Miuku View Post
    It's enabled and running.

    Try: mysqladmin -u root -p status

    It'll ask for your MySQL root password, if you've never set it just press enter.
    Looks like it is.

    Code:
    Doofenshmirtz:~> mysqladmin -u root -p status
    Enter password: 
    Uptime: 8567  Threads: 1  Questions: 1  Slow queries: 0  Opens: 0  Flush tables: 1  Open tables: 63  Queries per second avg: 0.000
    Thanks

  4. #4

    Default AW: MySQL Start "Something went wrong"

    Quote Originally Posted by MissSB View Post
    Hi guys,

    I tried to enable/start MySQL for the first time today but got this error message

    Code:
    Doofenshmirtz:~ # systemctl status mysql.service
    mysql.service - MySQL server
       Loaded: loaded (/usr/lib/systemd/system/mysql.service; enabled)
       Active: active (running) since Wed 2015-04-22 13:06:56 EAT; 5min ago
      Process: 14824 ExecStop=/usr/lib/mysql/rcmysql stop (code=exited, status=0/SUCCESS)
      Process: 14958 ExecStart=/usr/lib/mysql/rcmysql start (code=exited, status=0/SUCCESS)
     Main PID: 15020 (mysqld_safe)
       CGroup: /system.slice/mysql.service
               ├─15020 /bin/sh /usr/bin/mysqld_safe --mysqld=mysqld --user=mysql --pid-file=/var/run/mysql/mysqld.pid --socket=/var/run/mysql/mysql.sock --datadir=/var/lib/mysql
               └─15116 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --user=mysql --log-error=/var/lib/mysql/Doofenshmirtz.err --pid-file=/var/ru...
    
    Apr 22 13:06:56 Doofenshmirtz rcmysql[14958]: Starting service MySQL Something went wrong
    That "error" message is bogus, see here:
    https://bugzilla.opensuse.org/show_bug.cgi?id=914370
    Last edited by wolfi323; 22-Apr-2015 at 06:24.

  5. #5
    Join Date
    Apr 2014
    Location
    Kampala, Uganda
    Posts
    95

    Default Re: AW: MySQL Start "Something went wrong"

    Quote Originally Posted by wolfi323 View Post
    That "error" message is bogus, see here:
    https://bugzilla.opensuse.org/show_bug.cgi?id=914370
    Thanks Wolfi!

  6. #6

    Default Re: MySQL Start "Something went wrong"

    I have the same "error" and the output is:

    webserver162:~ # mysqladmin -u root -p status
    Enter password:
    Uptime: 686 Threads: 1 Questions: 2 Slow queries: 0 Opens: 70 Flush tables: 1 Open tables: 63 Queries per second avg: 0.002

    But I also have Webmin installed, which should normally be able to access mysql to add/edit databases etc, but webmin doesn't see the MySQL server.

  7. #7

    Default Re: MySQL Start "Something went wrong"

    Quote Originally Posted by criskolkman1 View Post
    I have the same "error" and the output is:

    webserver162:~ # mysqladmin -u root -p status
    Enter password:
    Uptime: 686 Threads: 1 Questions: 2 Slow queries: 0 Opens: 70 Flush tables: 1 Open tables: 63 Queries per second avg: 0.002
    So your mysql server seems to be running fine.
    And "systemctl status mysql" should show "active (running)" too, right?

    But I also have Webmin installed, which should normally be able to access mysql to add/edit databases etc, but webmin doesn't see the MySQL server.
    I haven't used Webmin in years.
    Maybe you have to configure it/point it to the server it should connect to?

  8. #8

    Default Re: MySQL Start "Something went wrong"

    Quote Originally Posted by wolfi323 View Post
    So your mysql server seems to be running fine.
    And "systemctl status mysql" should show "active (running)" too, right?


    I haven't used Webmin in years.
    Maybe you have to configure it/point it to the server it should connect to?
    Thank you very much for your reply.
    I read on a website that I had to refresh the Webmin modules, that did the trick!

    And yes MySQL shows running indeed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •