Results 1 to 10 of 10

Thread: How to get Japanese input on openSUSE 13.2

  1. #1

    Unhappy How to get Japanese input on openSUSE 13.2

    Hello. I want to start learning some Japanese, so I wanted to configure openSUSE so I could input characters using hiragana, katakana and kanji.
    I have tried at first using ibus, I downloaded lots of packages on yast, logged out and in again, but it didn't work, because the characters would still come using the latin alphabet.
    Then I tried using the fcitx, I think that's how it's spelled, and it did not work either, even after I selected the proper methods and selected Japanese as default input in qtconfig. Characters come in the latin alphabet no matter how I configure the system.

    What can I do now?

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: How to get Japanese input on openSUSE 13.2

    You don't say which desktop you use: with KDE, System settings (Configure desktop)/Input devices>Keyboard>Layouts>Add offers you a range of layouts to choose from. Obviously, you also need to install some Japanese fonts for this to work.

  3. #3
    Join Date
    Sep 2014
    Location
    Shah Alam, Malaysia
    Posts
    68

    Default Re: How to get Japanese input on openSUSE 13.2

    Go to Yast > language.
    Add Japanese as secondary language. ok. It will start downloading whatever package it need.
    Everything you need to read/write Japanese should be properly configured now.

    Then you need to select input method on your DE setting (not sure for KDE since im using Gnome).
    There will be Mozc and Anthy to choose for. I would recommend you to use Mozc.

    If you are using Japanese 109 keyboard, 半角・全角 button wont be recognized so you have to use some other way to switch the input.

  4. #4

    Default Re: How to get Japanese input on openSUSE 13.2

    Oh man, I am really sorry. I forgot to say I am using KDE.

    Well, I did that, I selected Japanese as my second language on Yast. It even installed ibus and all of that.
    Problem is, when I use the ibus, nothing happens. I am typing this with ibus on and the Japanese characters do not appear on screen like I thought they would.
    And yes, I have tried using both mozc and ibus. I do not know what I am doing wrong...

  5. #5

    Default Re: How to get Japanese input on openSUSE 13.2

    OK, I managed to get it working...

    I switched the main language to Japanese using Yast AND set it to change the keyboard layout to Japanese. Then, I logged out and logged in again and everything worked just fine.
    Then, switching back the main language and keyboard layout to Portuguese made ibus stop working again. Maybe both yast and ibus are conflicting?

  6. #6
    Join Date
    Sep 2014
    Location
    Shah Alam, Malaysia
    Posts
    68

    Default Re: How to get Japanese input on openSUSE 13.2

    Working perfectly for me.
    Using gnome and Japanese-109 keyboard.

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: How to get Japanese input on openSUSE 13.2

    AFAIK ibus is not needed by KDE. I don't have it installed and I have no difficulty getting foreign characters to display.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: How to get Japanese input on openSUSE 13.2

    You do have to configure it in KDE also Yast is system setting KDE settings aer personal

  9. #9
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,567

    Default Re: How to get Japanese input on openSUSE 13.2

    if you want to keep your desktop in another language and just have the option to input in Japanese then I'd avoid installing via the second language option as it installs a lot of things that you don't need. It also install ibus as the input method which (imo) does not play well with KDE.

    The easiest option to gain Japanese input is to install the following . . .

    fcitx (ime - works much better in KDE than ibus)
    fcitx-config-kde4
    mozc
    fcitx-mozc (for Japanese input)
    it will also pull in a number of dependencies.

    You'll also need a Japanese font - vlgothic-fonts are probably the nicest looking Japanese fonts in the OSS repo.

    edit: once you've installed fcitx you willneed to configure it to use Japanese input.
    Right click on the icon in systray (after starting fcitx) and select configure.
    The move mozc into the "current input method" field and finally set up a trigger to switch between mozc and your usual language/keyboard.
    http://paste.opensuse.org/20757869

  10. #10
    Taki NNTP User

    Default Re: How to get Japanese input on openSUSE 13.2

    On 04/21/2015 07:36 PM, gustavokrm wrote:
    >
    > Hello. I want to start learning some Japanese ... ibus, ...fcitx, I think that's how it's spelled, and it
    > did not work either, even after I selected the proper methods and
    > selected Japanese as default input in qtconfig. Characters come in the
    > latin alphabet no matter how I configure the system.
    >
    > What can I do now?
    >
    >

    You've got it going. That's good.

    First, I would stay way from 'ibus'; it has been unstable or very
    finicky after being tinkered around. There may be some advantages for
    it. But for a simple need like yours, 'fcitx' is more than fine.

    Second, I have never tinkered with a secondary language. I don't think
    there is any need for that, for your need.

    With 'fcitx', there are a few Japanese-input methods. I go along with
    the poster who has suggested 'mozc' / 'fcitx-mozc', to start with; later
    you can experiment with other IMEs. The combo 'anthy' / 'fcitx-anthy' is
    OK, too. I have KDE fully installed and updated, but I use it only
    occasionally, especially for configuring keyboard, file associations,
    etc. 'Fluxbox' or 'Openbox' is good enough for me.

    I don't know whether the following is still required,
    but in '.xim' file I have:
    export XMODIFIERS="@im=fcitx"
    export GTK_IM_MODULE=fcitx
    export QT_IM_SWITCHER=imsw-multi
    export QT_IM_MODULE=fcitx
    fcitx -d
    You seem to have done without this. So perhaps it's not needed. I have
    patterned the configuration from earlier times when this kind of thing
    was necessary.

    There are two additional repositories of interest to you as you progress
    in your studies:
    1. http://download.opensuse.org/reposit...openSUSE_13.2/
    2. http://download.opensuse.org/reposit...openSUSE_13.2/

    The standard main repositories are enough, though.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •