Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Akonadi again

  1. #1

    Default Akonadi again

    I posted an earlier thread on akonadi making the system unusable. I removed baloo-pim which made it somewhat better but still fairly slow - at least compared to some of my other computers which have 4GB of RAM. This computer - a 586 machine with the latest (standard) 13.2 version (all up-to date) with KDE desktop has only 2GB of ram and (default 2GB) swap space. As soon as I open Kmail (and start akonadi) the computer gets extremely sluggish. I sometimes have to wait for minutes to be able to move the mouse. The hard drive LED is on constantly and nothing happens on the desktop.
    The top command reveals the following under VIRT:
    akonadi_notes-a 1520600 (67.33% of memory)
    akonadiserver 343664
    akonadi_agent_1 106872
    akonadi total 1971136
    If I add mysql:
    mysqld 447904
    total 2419040
    Do I read this correct that the virtual memory exceeds the set-up 2GB by over 400MB and the RAM is used up (more or less) at the same time? Then it is no surprise that the hard drive is running constantly and there are no system resources left. The computer runs well without akonadi/mysql if I leave Kmail off. Is my computer too low spec for this version of opensuse/kmail? can I do something to restrict its system resources?
    Cheers
    Uli

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: Akonadi again

    1) you turned off indexing in config desktop right?? That should be sufficient to stop indexing
    2) Since baloo-pim is probable a recommended package it may have slipped back in check and if so taboo it

  3. #3

    Default Re: Akonadi again

    Thanks, gogalthorp, for your reply. Regarding turning indexing off - where do I do this? Baloo-pim is already taboo so it didn't slip back in.
    Cheers
    Uli

  4. #4

    Default Re: Akonadi again

    OK, I tried KDE handbook - find funktion does not find indexing.
    A web search to KDE turn indexing off didn't turn up anything which applies to my setup. I have neither indexing in the file ~/.kde4/share/config/baloofilerc, nor do I find under System Settings "Desktop Search". I don't even know whether this is the problem when baloo-pim isn't even installed. Maybe I have to look for a mail software which does not use akonadi?
    Uli

  5. #5

    Default Re: Akonadi again

    Yeah you should. Akonadi itself can easily use 100+ Mb, but depends on usage. Is not light that is for sure, loads of sub processes or agents make it worse. Open System Monitor and look for processes - and activate/use columns "Memory" and "Shared Memory", ignore "Virtual". Add those 2 together and you have "Resident" memory though KDE would like you to focus on "Memory". Is best case scenario but not all wrong, on a good day.

    Only problem by killing Akonadi and taboo on its grave via Yast is https://userbase.kde.org/Akonadi#ApplicationTable You will have to figure that out. After much tweaking I did love Kmail and PIM stuff for a couple of weeks but Akonadi broke the relationship. Can say there is life after Kmail so you will get over the loss.

    You can boot up KDE in under 250Mb memory usage if you fiddle enough. As with Akonadi usage will grow unless you just stare at black screen but still - with only 2Gb it seems silly to waste so much on things you might be able to compute without. You might be able to finetune Akonadi a bit by disabling Agents not used but tinker options are limited. Has a life of its own.

    If you want to keep Akonadi and its hardcoded friends may be you need to reset it somehow. Force it to rebuild cache. Things can get corrupted so may be why it seems to act like Baloo or Super Fetch did in Vista? There are ways to do this and someone will tell you how. Akonaditray, Akonadi console, something like that.

  6. #6

    Default Re: Akonadi again

    Regarding usage. "mysqld" process is started by Akonadi so with that plus "Akonadi*" stuff it adds up. Baloo is sugar on top. Wonder what they were drinking or smoking all those years ago. Was it not about the time where Linux was such a nice option for an old computer which was to be thrown out anyway? 512Mb-1Gb range I guess. I blame KDE if I am confused

  7. #7

    Default Re: Akonadi again

    Quote Originally Posted by js9600 View Post
    Regarding usage. "mysqld" process is started by Akonadi so with that plus "Akonadi*" stuff it adds up. Baloo is sugar on top. Wonder what they were drinking or smoking all those years ago.
    Well, they used a database as cache to make certain stuff easier. Other mail clients (like Thunderbird) use a database (sqlite in this case) as well btw.

    You can choose between 3 different backends in Akonadi's settings, sqlite is an option too and doesn't need mysqld running. But back then mysql was much faster (especially for larger mail accounts), so this is the default. Also there has been concurrency problems with sqlite, causing intermittent hangs, I don't know how the current state regarding this is.
    Run "kcmshell4 akonadi" to get to the akonadi server settings.

    They currently plan to redesign and rewrite Akonadi from scratch (and work is underway already AIUI), to work without a central server and without a database. But that will take a while, a year at least I suppose.

    Btw, I am using KMail/Akonadi (with a system-wide MariaDB server) here with "only" 2GiB RAM, and cannot confirm such freezes.
    Maybe it's possible that your MySQL configuration consumes too much RAM? Are you using an external mysql instance, or the internal one? MySQL or MariaDB?
    (since 13.1, MySQL's default setup takes a quarter of the available RAM here, that's why I switched to MariaDB back then)

    Tweaking that config might help.
    If you are using an internal server, try to remove the file ~/.local/share/akonadi/mysql.config, to reset it to the current defaults.

    And maybe also try to cleanup the akonadi database, with "akonadictl vacuum".

  8. #8

    Default Re: Akonadi again

    Yeah, I was too fast with taboo instinct because cant know if Kmail and other PIM stuff is high priority or not. Well if not they should be killed. Baloo should also be killed if not in real use. The few other programs with Akonadi dependencies can be replaced with alternatives - or minor sacrifices. KDE works fine without any of Akonadi code even if not most announced feature.

    Thunderbird with Lightning, RSS Reader and other extensions to make it a clued together PIM is not super light, much worse than Kmail on its own. But runs without Akonadi so less load overall.

    Compared to Thunderbird KDE programs are being developed so that might encourage troubleshooting until KDE stuff behaves. A Mozilla guy recently said they have pulled out even more. Was a comment to a semi famous guy who wrote Thunderbird was doing a come back. Moz guy also said only chance to get a Mozilla email client for desktop is if they port an FirefoxOS version. Is how it works these days, not just in Android world. Linux distros are probably biggest customer because program is part of many default installs.

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: Akonadi again

    The indexing is controlled from configure desktop- desktop search

  10. #10

    Default Re: Akonadi again

    PS, I somehow overlooked this up to now:

    Quote Originally Posted by fuerstu View Post
    The top command reveals the following under VIRT:
    akonadi_notes-a 1520600 (67.33% of memory)
    So it's actually the akonadi_notes_agent that hogs up your memory. (I think, your output is truncated...)
    Haven't ever had a problem with that...
    AFAIK, that's only needed to send/receive notes via the network. Try to kill it, and/or even put it offline/delete it in akonadiconsole.

    Might be worth a bug report updstream at http://bugs.kde.org/.

    OTOH, the VIRT usage is irrelevant. Better check the RES column, or did you?

    For comparison, mysqld has 1GiB VIRT and 150MiB RES here (MySQL took 4 times the RES, that's why I switched). Konqueror has 3GiB VIRT, and plasma-desktop even 4GiB. My system wouldn't even run at all any more... (2GiB RAM and 2GiB swap)
    Last edited by wolfi323; 20-Apr-2015 at 05:48.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •